Skin changes lost after a reboot

I just installed it (remotely) via SSH but the apt-get dist-upgrade command seems to run without any installing anything:

osmc@osmc-keuken:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following package was automatically installed and is no longer required:
libjasper1
Use ‘apt-get autoremove’ to remove it.
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Maybe it’s because I did a manual upgrade earlier this morning via the GUI?

Yes. It’s been in the repository for a few hours.

I will do a couple of reboots and hopefully the problem is resolved. I guess this will take some time to be 100% sure as my last reboots without the fix also kept the menu settings.

thanks for all the work on fixing this!

Same here with confluence skin. Online-update on Apr. 2nd did not improve anything.
Looks like the libreELEC dudes have similar problems. I’ll switch one of my boxes over to LE, to see differences - or not.

@Laser_Man have you tested with today’s update to jessie-devel?

We’ve had some good reports.

Sam

Hi Sam,
just did
apt-get -y update
apt-get -y upgrade
reboot

… but System info still tells me, Kodi was compiled on March, 22nd. Ist this okay?

cheers,
Laser_Man

Don’t run apt-get upgrade. That will break your system and you’ll need to reinstall.
If you have run this, you need to reinstall. You should’ve actually received a warning preventing you from doing this; but on older versions of OSMC this won’t show up.

The Kodi build on Raspberry Pi should show 10th April. The Kodi build on 22nd March is still affected by the issue.

i have also added the:

deb http://apt.osmc.tv jessie-devel main

on my sources.list

I have executed now the SSH command and i obtain about 50MB of updates… wait installation and reboot to see what’s appened…

this is the list founded:

armv7-connman-osmc mediacenter-addon-osmc rbp-bootloader-osmc rbp-userland-osmc rbp2-libcec-osmc rbp2-mediacenter-osmc

Just tested this. The apt-get -y upgrade runs fine without warnings on an updated system, but not apt-get upgrade.
Guess the system does not check on the -y switch.

Looks like we will need to add that. Thanks for letting me know.

I’m having the same issue with my RP3. I’ve read the thread and I’m a bit confused. Is there an update I have to run manually or was there a patch that was pushed down via automatic update?

I am very new the the RP3 and Linux in general. Very basic knowledge.

It’s in our testing repository but is likely to be pushed to public with the next update that should be available in short order.

I have a possibly stupid question… about my previous reply i have installed some many updates for see if this little issue it’s disappears :slight_smile:

Right now… i need to leave the voices from sources.list or i can leave it here whitout any problems for future release ?

I think what you are asking is should you leave the changes you made to sources.list?

Way back when the change was recommended:

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

So the answer would be to remove (or you can just put a # at the start of the line) the line you added.

Yes… exactly :slight_smile:

Ok… i put a # at start of develop voices…

Thanks for suggest…

Uhm, that’s surprising!
Shouldn’t we hook apt-get by a script that dumps a warning and asks for “doing anyway [Y/N]?”, then calling the original apt-get?

regarding the line in /etc/apt/sources.list
deb http://apt.osmc.tv jessie-devel main
… sorry, as I just found out, I put the line into the wrong Pi. I accidentally confused 192.168.0.197 with 192.168.0.179. So the device under observation still has normal jessie source, while my spare/workbench testing equipment was shut down for a week, right after apt-get upgrade. Lost a week of investigation results. Nobody got hurt :wink:

… BTW, another observation is:

  1. the reboot/crash has a very high probability around 02:00 and 05:00 o’clock in the night. This is apx. 3…4 hours after pressing the “Square” or “Stop” button on the remote, while life TV streaming was active until the button pressed.
  2. the reboot/crash has a higher probability on RPi3/WiFi (>10 Crashes) compared to RPi2/eth0 (4 Crashes in the same time)
  3. the crash/reboot never loads some of the confluence settings (weather, big icons, video calibration) on RPi3/WiFi, while the same has a 50/50 chance on RPi2/eth0
  4. but the crash/reboot always loads TV/EPG channels on RPi3/WiFi well, while the same always fails on RPi2/eth0

May be all these observations are worth nothing, but somebody should note it. Done hereby.

A QUESTION
How can I tell KODI to log all and everything to an external syslogd (UDP myserver.home:514, format RFC 3164)?
I have such deamon running 24/7 and I’d prefer it over SD Card writing.

Cheers,
Laser_Man

There is a warning since quite a while:
“Running apt-get upgrade on your system can cause adverse effects on your system
Use apt-get dist-upgrade, which is the proper way
to administer a Debian / Ubuntu system”

We can do yes. I have already tried to do this but it looks like you can get around it.

apt-get upgrade is not recommended by Debian.

Sounds power related.

You can’t. You can redirect journalctl to a remote syslog server, but not Kodi’s logger.

Sam

Hello everyone.
I have added the line in etc / apt / sources.list
I have updated it with the commands that Sam recommends, but I still see it in kodi March 22nd.
What can it be?
Thank you very much.

Post the output of

cat /etc/apt/sources.list

and

sudo apt-get update
sudo apt-get dist-upgrade