SMB issues with new router

I recently purchased a new router (Asus RT-AC1200G+) and have been setting up my individual devices to the smb. I haven’t had any issues connecting kodi from my pc and my phone to the router but when trying to connect my Raspberry Pi 3 to the SMB it refuses my user/pw credentials. I’ve tried using both the device name and the ip but neither works. I’ve also tried adding another smb user to the router with different username and password but still can’t connect (this login also worked with my pc and phone).

Log from attempting to connect (disregard my brainfart with the 192192 ip)

Did you try to set smb protocol to 1 under Settings - Services - SMB Client?

Alternatively you want to mount the smb share via fstab which also would be more performant.

Yeah I’ve tried with protocol 1, 2 and 3.

Oh, no I have not. I’ll try to figure out how to do the fstab

You might also want to install smbclient sudo apt-get isntall smb-client and then check with smbclient -L <IP of Router>

I’ve mounted the folders I wanted to and everything shows up when I list them but when I try to do the smbclient -L this happens:

Also, once the folders are mounted should I still add them to osmc as I usually do with “add network location” and choosing smb?

Sorry if this is very low level stuff :slight_smile:

Once they are mounted they become local you will find them under “root folder” / media

Found them under mnt instead of media but it all finally works, and faster than before.
Thank you so much, you’re amazing!

Sorry my Mix up

This is interesting…

So how would one do this with multiple RPi and Vero 4K and Windows systems sharing a MySQL DB? The paths have to be consistent in the DB.

I can imagine it being ok for the Pi and Vero as long as mounts are all on /mnt (or similar)

Of course!

I do that now as I have two physical locations (joined via VPN) and just switch out the IP address of the files server so I read from the local one.