SMB Share no more working after recent upgrade of windows

I have always used… i have a SMB shared folder at:
smb://192.168.1.2/

Username of windows it’s (example) -> users@mail.com
and password of microsoft account it’s (another example) -> 12345678-mynameandsurname

For today when i try to access on smb shared from osmc i ever obtain the request of username and password… i have also tryed to re-insert my correct windows password but it’s not works anymore.

How i can resolve this issue ?

Hi,

Can you access the SMB share from another device?

debugging logs, will probably help resolve, details can be found here.

Thanks Tom.

Yes… i have another PC whit windows 7 and from this i can open and see the sharing folder directly from “Windows Explorer” whitout insert/using anythings user or password.

Otherwise about 30 minutes ago i have found a possibly solution or somethigs like a workaround… i have to do:

  1. Add “Everyone” on Permission of shared folder in windows 10…

  2. Disabled a option inside “advanced shared preferences”. I have disabled the shared files whit password…

Now i don’t know… but now i can reach the smb share also i ever do…