(SOLVED)DVD want play, WHY!

So you guys dont know whats wrong. I dont understand why its so hard to get this thing to play dvds. Ive never had so much trouble with something so simple.

Nice hostname.

StratosphereSystemsPrototypev1.0

22 hours isn’t giving us much time to look at this.

Because you have a variety of pirate repositories on your system, we cannot provide support for you.

1 Like

Those arnt pirated repositories, Those are the top repos for kodi. If it wasnt for those repos and add-ons then kodi would be nothing more then a simple media player.

Anyway its yalls site yalls rules, Tomorrow i will reinstall OSMC with a fresh blank Kodi and try and play some dvds again then repost my log file with kodi in debug mode. Then will yall help me?

Then people who spend their freetime to help people without making any money from it, with as you call it “simple things” might decide to try to help you. But only if you tone it down a little bit.

And those aren’t “pirated repositories”. Those are repositories that deliver pirated content and are known to be out of the support scope of KODI and osmc as they are known to cause problems.

Some people actually like KODI for being a mediaplayer instead of an unsupportable piracy machine.

2 Likes

I’m not trying to upset or fight anybody I just want to get this thing to play dvds. If it’s that big a deal or nobody wants to help then fine. I can’t make y’all, I’m sure I’ll figure it out sooner or later.

Entirely possible that even your hub does not provide enough juice to support the DVDdrive.

I thought when i first bought my license keys and installed them and checked it told me they were enabled. Now ive been trying to double and triple check some stuff and bother the RPI guys for a little while before i came back and posted here again, but its telling me all of my codec are disabled even H264. So i dont understand why, ive read a few things about the gpu memory but its the default 256 witch is plenty.

The only licences you purchase are MPEG2 and VC1 - if these are showing as disabled, then you must have something wrong in your config files.
Derek

Alright im still cant get dvds to play. I have a RPI 3 model B running OSMC 2017.02-2. I have the codec license keys installed and working. Its a fresh blank install, the only thing i did was enable debugging and try to play some dvd. I tried 4 different dvds the last being a burnt copy and it played fine. I think its something to to with libdvdscc but i dont know i can install that on osmc. I see lots of commands and stuff to do this but most of the are for Raspbian. I did a lot of googling and youtube and i don’t understand why i having so much trouble. From what i can see most people just plug everything up and it works, and i know you guys are tried of hearing from me. Thank in advance for any help. any additional info y’all need just let me know.

Here is my Log file:
http://paste.osmc.io/kacabaheda.vhdl

PLEASE don’t clutter the forum with mulitple threads when you already have one open addressing the same issue!

sorry i couldn’t find this thread

whats the point of having a thread if nobody will help ive asked nicely and done everything yall have asked

INFO:   msg: libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_02_1.VOB (0x001dbfaa)!!

That looks like the problem to me. For some reason, the DVD can’t be cracked. Have you tried other DVDs? Have you tried a different DVD reader?

I’m checking on this for you.

I think you need libdvdcss to play these scrambled DVDs but I don’t think it’s currently bundled with OSMC or in the repository. I think it used to be available or bundled so unsure if something has changed to remove this.

libdvdcss is bundled. @telcar, please try with other DVDs.

The region of my DVD drive was set incorrectly. I ordered it from amazon and it was set to the region were it was originally purchased witched was region 2. After i changed it to region 1 everything works perfect.

Good to hear you fixed it. I did notice in the log about the region, but I didn’t think about that as a problem.