[solved] Problem with upgrading to atv-image-4.2.3-12-osmc

I ended up with this error:

osmc@ATV:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
Suggested packages:
  fdutils atv-doc-4.2.3-12-osmc atv-source-4.2.3-12-osmc atv-image-4.2.3-12-osmc-dbg atv-manual-4.2.3-12-osmc
Recommended packages:
  initramfs-tools linux-initramfs-tool kernel-common
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/11.4 MB of archives.
After this operation, 29.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
(Reading database ... 36574 files and directories currently installed.)
Preparing to unpack .../atv-image-4.2.3-12-osmc_12_i386.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/001-preprocess-atv 4.2.3-12-osmc /boot/vmlinuz-4.2.3-12-osmc
Unpacking atv-image-4.2.3-12-osmc (12) ...
dpkg: error processing archive /var/cache/apt/archives/atv-image-4.2.3-12-osmc_12_i386.deb (--unpack):
 unable to clean up mess surrounding `./boot/config-4.2.3-12-osmc' before installing another version: Read-only file system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


This means you have not powered off the aTV properly, so /boot has become read only. You should fsck /boot first and ensure it is RW before re-running apt-get -f install.

thx a lot sam

Sorry, I have the same problem.
(Error code 13)
But I’m noob :disappointed:
How may I “fsck /boot” ???

sudo umount /boot
sudo fsck.hfsplus -f /dev/sda1
sudo mount -o force,rw /dev/sda1 /boot

What he says :wink:

Change sda1 to sdb1 if running off a USB based install and a hard disk is still attached to your PATA port.

Thanks cybero and sam

Is this the fsck sequence I have to run @sam_nazarko for unsafe shutdowns?


This worked great!! Thanks!!

hi Sam and Guys

I am stuck on this also, wont update with the apple image, error 13. this is from a brand new install to HDD, using the usb stick with the latest disk image.

how do I do this sudo thing. I am on a pc, which piece of software is the simplest to do the sudo. sorry I am a noob and have never sudo’d.

please could you hel me out here thank you, its driving me mad

ok followed the wiki with putty and cut and pasted those 3 lines of sudo stuff and it seems to have worked

the apple still seems to be on kodi 16.1. is this correct? thanks guys

is the latest kodi for osmc on apple tv still on 16.1? thanks guys

thanks folks

thanks !!! :slight_smile:

i’m having an issue with my system. some of the changes will become permanent but some doesn’t such as every time I boot my OSMC, the directory help (which normally once you pressed OKAY, it will disappear forever) always pops-out again. Another issue is the theme shortcut will disappear on every boot, but the system config will be permanent. I’ve done the fsck with no resolution, and updating atv-image also seems to be fail. Fresh reinstall twice.

osmc@osmc:~$ sudo uname -a
Linux osmc 4.2.3-13-osmc #1 Wed Jun 22 03:41:20 UTC 2016 i686 GNU/Linux

Please let me know which log you need to see to resolve this.