[solved] "Sadface" after a system update

Hi all,

My ATV was working perfectly before going away for a few weeks. Upon my return I did the usual:

apt-get update && apt-get dist-upgrade

A bunch of stuff got updated and upon a:

sync && shutdown -r now

my ATV booted to “sadface”.

I SSHed in, and manually installed “atv-image-4.2.3-7-osmc”, and all … was well…

Redoing the update, which completed without errors, whether SSH or from the menu, results in the same “sadface”.

Anyone have any ideas?


PS: I’ll be glad to submit any logs, as long as someone tells me how to grab them, and where to upload them.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

latest is “atv-image-4.2.3-12-osmc” why did you install “atv-image-4.2.3-7-osmc” manually?

Because when the ATV was updated to the newest version it went to “sdadface”. The whole raison d’être of my post.

Once again I did an:
apt-get update && apt-get dist-upgrade

and, sadly, it stopped working again.

I then did a:
apt-get remove atv-image-4.2.3-12-osmc
followed by
apt-get install --reinstall atv-image-4.2.3-7-osmc

In spite of apt complaining about some unmet dependency:
“The following packages have unmet dependencies:
atv-kernel-osmc : Depends: atv-image-4.2.3-12-osmc but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).”

…upon reboot all is well once again.

Here is the result of “grab-logs -A -C”

Updated to latest, and not working

Forced rollback to and working.

If Sam, or any other dev, wants to have a look, just PM me with your ssh public keys and I’ll set you up with remote access to the box; so you can have a proper look around.

A Kodi log with debugging would be helpful.


Okay, run

sudo apt-get update
sudo apt-get dist-upgrade

And you should get the new kernel.

I did. And it did update to 4.2.3.-12 without any errors. It did, however, make no difference, still not working. :frowning:

I am going to go back to 4.2.3-7 in the morning and then enable debugging from the GUI. I will then post the working and not working logs one more time. Hopefully the debugging being turned on will make a difference.

Thanks for all the help.

-13 is the version you should be on

I ran the commands again - up arrow up arrow enter, so identical command - and it’s now installing -13.

And we have SUCCESS!!!

Perfect. Thanks.

Can someone please to me how to SSH to Apple TV 1 when getting sadface after OSMC update?


Thanks for you reply…I’ve seen this but I’m still not sure how to SSH as the Apple TV just stops at Sadface and I’m not able to find the IP address of the device. I’m using a Mac and my device is connected to my network via ethernet.

Your router webconfiguration page should contain the ability to see all devices and their IP addresses. You’ll have to figure out which device is the one you are looking for.

Alternatively, type arp -a into Terminal on your Mac and you’ll see a response that lists all known devices on your LAN. Again, determining which is the ATV is up to you.

Thank you very much, that was helpful to get into the device.