Some (or more precisely many) of my video files cannot play - resulting sad face

Hi,
After a successful transfer from my Popcorn A-500 system to the Vero 4K+, I’m very happy with the result, the snappy interface and the unlimited functionality all are great!

However … I do not mind to spend days/hours to optimize and build my huge media database on my SQL database / NAS solution, but I need a stable and easily usable Media player solution, which won’t or only very rarely will crash, especially when my wife wants to use it.

Unfortunately this is not the case yet, I ran into the same SAD FACE problem with many of my movie or TV series files, without any error message or a clue what causing this.
The files are not corrupt, they all play fine on my PC and on the good old Popcorn Hour, to be honest I had never had and issues with corrupted video files in the past. However the new Vero is super sensitive, and crashing on them, rather then try to play even if it does not like some part of the file.

So far the movies which causing the SAD FACE are all SD resolution avi, or mkv files. 4K, 1080p files are playing fine. I let all resolutions in the whitelist to output to my Panasonic OLED TV which can handle and upscale everything in a perfect way.

Do you have any idea where to start to investigate this issue? My wife easily picks with 80% chance from the nearly 2000 items in my database the faulty ones… and wants the Popcorn A500 back… :frowning:

Debug Logs might give an idea. Also if it always help if the problem is reproducible to try first to play the file from USB instead of network.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Uploaded Debug log

Hi, thanks. Yes, this is the log file, what I uploaded after the crash.

I also made a test what you suggested, and the movie file plays well from a USB stick!
Even more interesting, that when I go to the Settings/Media and Videos … and manually start the video from the network share, it plays fine. It only crashing, when I start from the Media Library.
Very weird…

Nothing standing out in the log file (at least for me).

Really really weird

So: you have files that play OK from local storage (USB) but not over the network?
I see you installed autofs, so assume mounts are set up that way.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

There’s some dodgy data, possibly in a tag or database, that’s causing an SQL command to fail:

2021-03-16 22:38:51.383 T:3438276832   DEBUG: Mysql execute: INSERT INTO streamdetails (idFile, iStreamType, strAudioCodec, iAudioChannels, strAudioLanguage) VALUES (38502,1,'ac3',2,'��')
2021-03-16 22:38:51.384 T:3438276832   ERROR: SQL: [MyVideos116] Undefined MySQL error: Code (1366)

strAudioLanguage is, as the name implies, a text column and error 1366 seems to be an invalid value. https://mariadb.com/kb/en/mariadb-error-codes/

I also came across this which discusses a similar problem.

As to whether this a character-set problem or simply bad data, I have no way of knowing. It’s also unclear whether this will cause Kodi to crash but the first step shold be to fix the error. Perhaps @darwindesign can shed some light on the possible source of the problematic string.

I don’t think it has anything to do with the crash. I’m pretty limited on my db knowledge but I think there was an issue where sometimes a db would get created and not set to use UTF-8.

Well, it’s not clear whether it’s UTF-8 or just junk. I downloaded the log and ran it through a hex dumper but what’s in the log might not be a true representation of the data. FWIW, it showed:

63 33 27 2c 32 2c 27 ef bf bd ef bf bd 27 29 0a |c3',2,'......').|

Some of the other examples in the log show “real” values, like 'hun'.

Do you have any ideas for the source of this data?

As I said, in the absence of other leads, it would make sense to eliminate this possibility.

Hi Sam, yes I have nfs share set up correctly. And I can play the files from usb and also through the file explorer on the share but not from the media library scan. It seems like a weird sql database error without any error message?

No, I just remember running into an issue at one point with something that sounded similar and the solution was to set the field in question to use UTF-8. I’ve long forgotten the details. I really don’t think it is related to the crash. AFAIK streamdetails is only used by the GUI to display media info and shouldn’t have anything to do with playback, or crashing during playback start.

I also tried to export the video database with kodi into a single file and at the very end it came back with an error message the backup finished except 1 file - which is the main XML file, ended up with a zero length file.
How can I look for any errors in the database and is there any tool to repair this at this moment unknown error?
Thx,

I did not manipulate manually the database in any way, started a fresh install and built it with Universal Movie Scraper. Most of my movies main language is Hungarian.
I do not know what is the problem with that movie. I checked in its xml file, and all data is correct for that movie, and definitely should not crash the Vero at all.

Hi Guys,
a small addition to my problem description. I removed the movie from the database, and rescanned it, to be able to get rid of any faulty database entry, however the problem remained the same.
The file plays fine when started from the Settings/Media/Videos…/video share, but ends up with a sad face when started from the Media Library.

My last idea is, to keep the filename, and replace the questionable movie file with a completely different one, to see if it will start to play or not. It is not that scientific solution, but I’m super curious, if the file itself can cause the problem, or it does not matter what I’m playing through this media library entry, it will fail…

I would suggest to try to separate off MySQL in an effort to isolate where the problem lies. Temperedly just rename or move your advancedsettings.xml file, do a set content on your sources with settings that match what they were set at with MySQL active, then update the library, then try to reproduce the issue.