Sound problems on RC build with RP2

I recently upgraded to RC build on my Raspberry PI 2. Everything works just fine except sound.

When I first booted up there was no sound I double checked everything but I couldn’t figure out what was wrong until I tried increasing the volume. Turns out volume was so low I had to increase the volume like crazy to get an acceptable sound.

This was not the case with the Alpha build, I could her everything when my TV volume was around 6-10. now I need to keep it around 22-30, which is not good because every time I switch inputs it’s chaos.

I had a similar issue with MP3 files on Alpha build but it was fine because I wasn’t listening much music on osmc.

I tried increasing the amplifier on sound settings. It helps a little but now it causes sudden changes in the sound volumes, while watching a movie you either hear nothing or it’s crazy loud.

How can I fix this issue? What do you need from me? I check the logs but there is nothing sound related in there, I increased the logging level in advancedsettings.xml file but still nothing.

I keep running the updates hoping it would fix this issue, please help.

Little bit more info.

  • I stream videos
  • I don’t have a sound system
  • it’s straight HDMI connection with TV for both sound and video.
  • I tried HDMI passthrough, it’s even worse
  • I backed app all information from alpha build using Backup application, it copies all configurations, databases everything. Maybe it copied some configurations that it shouldn’t

Hope it helps

Try renaming /home/osmc/.kodi and reboot. This will reset everything, see if the problem still exists. You can then restore a bit at a time from the renamed folder to see where the problem returns. Of course if renaming doesn’t fix it then you can delete the newly created .kodi folder and name the old one back

Great suggestion, just tried that it didn’t fix the issue but it helped me pin point something.

Sound only works properly when it’s set to 100% on kodi. If it goes less then 98% it becomes really quiet and I have to boost up the TV volume. Does that make sense?

Again this was not the case with the previous build. I would usually fix the TV volume on a normal level and use kodi’s volume rocker to manage sound.

Thanks for the help

Also something strange to note. Maximum volume on kodi shown as 0.0 DB is that normal?

I see this hasn’t been checked so far, so -
what lead are you using to connect up your sound?
The RPi2 has, like the B+ a 4 pole connector which provides both video and audio, and you can get some odd effects if you don’t use the right poles.
There are several different types of wire lead on offer, and one which works for an Apple device will for this (if I recall correctly).
Somewhere there was a picture of the wire types with comments

I hope I got that posting right - haven’t tried a pic before

Hey Derek,

Thanks for the info but I’m using only the HDMI connection. I don’t have the audio jack or anything. This problem seems to be a software issue at the moment.

Hard to imagine it’s a software issue when you seem to be the only person reporting it. You say there’s no issue when Kodi volume is 100%? OK, well controlling volume from within Kodi should really be done when you have no other choice as audio quality suffers when Kodi is at anything less than full. Most ppl use their TV or avr to adjust volume.

By software issue I meant a misconfiguration on my end or some missing library etc. it’s not related to the cables or hardware because it was working just fine before the upgrade.

I find it really hard to agree with this, I have a remote for kodi and volume controls worked just fine before this update. Now I don’t want to start using two different remotes just for the sound.

I maybe the only one reporting this but it doesn’t make it any less important.

I think I have the same problem. At first boot I have no sound then when I reboot (without any action) the sound is ok. I’ven’t tested with volume to 100%. I will test tomorrow and tell you.

I’ve tested and I’ve no sound and I’ve to restart to have sound.
I’ve tried with sound at 100% I’ve same problem

Rod can you upgrade to RC2 and see if you are still having the same problem ?

BTW I use analog audio with my Pi 2 and do not see this problem.

Thanks you
it seems tout work now

I still have sound problem on the 2015-06 firmware. You are right there isn’t any problem on RC2, but if you want to have last updates in raspberry 2 you’ll have to be ready to meet sound problem.
Some words about problem: it looks like program correcting of delay between video and sound streams. It happens every 10-20 seconds. When I use other device (PC) to play video (video stored on the NAS) I don’t have any problem.

I don’t have sound either. It seemed to have happened a few versions back. Only now am I getting around to fix it. I am on build Kodi 16.1 and compiled Aug 28 2016. Now you have some else reporting the problem, what’s wrong?

This is an inappropriate posting.

  1. You’re not on an RC build
  2. Last post was a year ago
  3. You’ve given no build details or log for diagnosis