Sound & subtitles out of sync

Back again :wink:

I’ve red a few issue and solutions about my problem, but I think none of them are related to this.
Maybe it’s all obvious and logical, but my technical knowledge is rather limited on this matter.

Problem :

There are a number of TV series that I want to play, were the sound does not match with the actions. The lips are out of sync when speaking etc. The subtitles also do not appear on the screen with these TV series or when they do, they simply remain, but do not continue.

I took my laptop and my old RaspberryPi, they were both working fine. Sound was sync, subtitles were good. So maybe it’s a limitation of the hardware or an other problem but like I earlier said, I don’t know where to start looking. And it wouldn’t bother me if the problem was also with the other hardware, but I would think the vero4k+ should definitely be able to do it.

I pulled my logs here →

I would venture a guess that the issue is actually the low quality rip your playing and it just happens that some players are able to deal with it a bit better. You might try disabling video hardware acceleration or adjust your audio settings to enable passthrough, AC3, and transcode. One of those may get you better playback on these files.

1 Like

I did al those tricks but none helped. I think you could be right about the poor quality rips, because the files in better quality are playing well.

The only other thing I can think that might work around the issue your having is to setup a whitelist (information on that can be found [here]) which will make available the option during playback to change the resolution/refresh rate on the fly. You might have better luck playing these files at 60hz rather than the framerate your currently using.

1 Like

Does simply adjusting the audio and subtitle sync not help? Or is the amount that they are out of sync by not constant?

1 Like

I could do that. But there are indeed cases that the amount is not constant. I especially find it a hassle to have to change those settings every time before watching a movie. :innocent:

Ok, today I reinstalled OSMC completely. I changed again the settings from the hardware acceleration to only HD and this time it worked. So I guess this solved the problem with the subtitles en the sound.

Was this a bad idea to change them or is this okay? I don’t know if they affect anything else.

Using CPU decode for lower resolution content can increase the ability of the unit to play some more problematic rips. It may make the unit run a bit warmer than it would otherwise during playback, but afaik that is normally the only downside to that setting.


Ok, thanks for the feedback !

1 Like