Still got banding

I am using the force 10 bit hotfix, but I am still experiencing banding on my new Sony XF9005 TV. HDR autoswitching is off.

Have you tried this?

You should try @grahamh’s suggestion as forcing 10-bit is deprecated in the next update.


What is coming in the next update thats voids the hotfix?

a better way to detect 10-bit content and switch mode. Please try it and post logs if it doesn’t work.

I should add here that I actually tried Grahamh’s method to remove banding that I noticed since setting up my Vero4K+ yesterday.
I still got banding even after successfully completing his instructions …

I then followed Sams instructions that are contained in the first post on that thread ( being different, and knowing they worked from using them in my old Vero4k) and these did again successfully remove banding for me.

Note I never touched the auto switching toggle nor forced 10bit output.

I don’t know why but that is what it worked for me !!!

Are you using a 4k desktop resolution, perhaps?

What did you try that worked?

If you go to the top of that thread, there are instructions for installing a custom build. The one I linked is a later version and a release candidate, so we would really like to get that working for everybody.

The only bug we are aware of is if ppl have their desktop set to 4k.

My desktop is set to 1080p and it switches to 2160p when I start the movie.

My question was for @SLICKRIC21, really, but thanks for the confirmation.

@grahamh No desktop resolution is set at 1080p

Sorry to hijack the thread I was just trying to help kimdk77.

Basically I had a Vero4k+ with the faulty Gigabit lan. I was using a USB3.0 adapter with it for a few weeks whilst waiting for RMA etc.

I suffered from banding on 4K 10bit HDR so I applied Sams custom instructions on first post page of that thread. Bingo worked perfectly. No banding.
That Vero went back RMA’d last week and I received a new one on Friday.

On the new one this time I applied your fix detailed on post 127 of the thread - as had read your advice to do so- it all updated and fine.

Tested it out and had banding on 4K HDR content.
Note I didn’t enable the HDR auto switching toggle in settings, should I have done so with your fix ??

Anyway I knew Sams fix would work as it did on my old Vero, so I just applied this one instead and again worked perfect with no banding !!!

Hmm, that’s disappointing. Would you mind posting a debug log playing a 4k HDR clip through Sam’s kernel (as you are) and ‘my’ kernel? I’d like to see what the difference is. And if there is any info from your AVR or TV about the signal received, post that?

Following my post 127 should work to install the latest kernel again - it should be

osmc@vero4kp:~$ uname -a
Linux vero4kp 3.14.29-121-osmc #1 SMP Sat Sep 29 05:20:26 UTC 2018 aarch64 GNU/Linux

Then the instuctions in the OP should take you back to kernel 119 (IIRC).

Many thanks.

I will try to do this for you, but it will probably be on Wednesday now.
I will ping u a message when I have done it.


Thanks, we’re trying to get rid of the need to manually enable 10-bit output.


OK, lets explore a way to help you which doesn’t involve commandlines. You have to understand that the hotfix you applied worked for most users so there is something about your setup which is different and we need to find out what that is. The answer may be in Vero, or your TV settings or your AVR if you have one.

We need logs to get a better understanding of the problem. Please see How to submit a useful support request - General - OSMC

And we need to find out what’s changed since you posted this:

Well the last one is easy, I got a new TV :slight_smile: I previously had the samsung ks7005 and I now have the Sony XF9005. The Sony fully supports 10 bit and HDR.

The Vero is Directly connected to the TV.

1 Like