Streaming Audio via Vero from laptop possible?

Hey guys,

Is there a way to route the audio output of my laptop to my receiver via the Vero? Bluetooth or WiFi?

Is this a strange or complicated question?
I just want to use my stereo setup when using a Web player on my laptop, and as I already have the Vero 4K, obviously I’d like not having to buy another gadget.

Well if you laptop supports a2dp that would be an option. But be aware that a2dp support in the current version is kind of broken

I understand from your post that currently my need is not solvable with the Vero 4K?
I am not sure if I want to join the beta tester crew for BT streaming.
Also, are we talking about the same thing?
I want to play something on my laptop, and want the Vero to pass this through via hdmi to my receiver. I do not want to connect BT headphones to the Vero.

Yes we talk about the same. The a2dp implementation allows streaming to and from OSMC

OK. But, as as you and Sam points out in the thread linked above, BT streaming is not working currently, so I’ll just have to wait.
Hopefully there will be a solution soon.

We do plan to bring A2DP back. Hopefully in a less invasive way as well.

Hi Sam, thanks for this info.
You can roll up your eyes now: can you give a rough time frame for this?

When it’s ready :slight_smile:
We are working on it, but these things take time. PulseAudio + Bluetooth are horrible; but unfortunately the new proposed solution is a way off yet.

When we have progress, I’ll make a forum post.


Take your time.
But I wonder, what is the problem. For me as Linux noob, it looks like the audio stream from the laptop via BT should just be like any other source for kodi to be passed through to the receiver?
Ugh, my grammar is deteriorating - good night for now!

Not quite. The problem is with how to pass that to the audio sink.
Have a good one


It (streaming audio from a PC to the Vero4k) works successfully using UPnP / DLNA.

What to do:

  • On the Vero4k: Enable UPnp/ DLNA from Kodi Settings > Services > UPnP / DLNA by checking “allow remote control” (literally translated from the German UI)
  • On the PC (assuming you are running Linux, successfully tested with Linux Mint & Fedora 27): Follow this guide.

Should work equally well using the Raspberry, UPnP / DLNA goes over the network.