Stutter and frame skipping

The frame skipping occurs on multiple videos.

Kodi’s GUI is already set to 1080p - this is the setting under Settings > System > Display> Resolution, right? There are two 1920x1080p modes listed here, but neither of them resolve the problem. I think the frame rate reverted to 50Hz in my last test as every setting got reset to default as mentioned above.

The problem still occurs with “Adjust display refresh rate” set to “Always” or “On start/stop”, which I understand should change the refresh rate to 24Hz or whatever the video frame rate is.

Yes – but as explained there is a bug for smtpe TVs. If the GUI is set to 4K, it may not always switch refresh rate, because it can’t find an appropriate mode for smtpe resolution. I will address this soon. It doesn’t look like the issue here though if you say your GUI is at 1080p.

Let’s focus on one problematic file for now.

  • Can you play the Matrix on the other Vero connected to the other TV? If so, anything different, like display capabilities (4K vs 1080P)?
  • Are you sure the refresh rate is being adjusted? VIC 32 == 1080p50Hz.
  • Can you run sudo apt-get install mediainfo, then run mediainfo on the Matrix file. I would like to see how it’s been encoded.

Sam

Great, thanks for explaining and for your patience Sam.

  • The ‘Matrix’ video (and others) also skip on the other Vero & TV. Settings are all the same, except that audio passthrough is turned off and the audio output is set to PCM instead of HDMI.

  • Checking the TV info shows that the TV refresh rate is adjusting from 50Hz in GUI to playback at 24Hz.

  • mediainfo result as follows:

General
Unique ID : 153154215847308468990370324088727928448 (0x73386DD5A0A73CE1B5355C014D9DFE80)
Complete name : The Matrix (1999).mkv
Format : Matroska
Format version : Version 2
File size : 19.2 GiB
Duration : 2h 16mn
Overall bit rate mode : Variable
Overall bit rate : 20.2 Mbps
Encoded date : UTC 2014-11-18 15:02:05
Writing application : MakeMKV v1.8.14 win(x64-release)
Writing library : libmakemkv v1.8.14 (1.3.0/1.4.1) win(x64-release)

Video
ID : 1
Format : VC-1
Format profile : Advanced@L3
Codec ID : V_MS/VFW/FOURCC / WVC1
Codec ID/Hint : Microsoft
Duration : 2h 16mn
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Language : English
Default : No
Forced : No

Audio #1
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Codec ID : A_AC3
Duration : 2h 16mn
Bit rate mode : Constant
Bit rate : 640 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 624 MiB (3%)
Title : Surround 5.1
Language : English
Default : Yes
Forced : No

Audio #2
ID : 3
Format : TrueHD
Codec ID : A_TRUEHD
Duration : 2h 16mn
Bit rate mode : Variable
Maximum bit rate : 3 345 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 24 bits
Compression mode : Lossless
Title : Surround 5.1
Language : English
Default : No
Forced : No

There are more audio tracks listed, but I have removed them from the output as it was rather long. I can post the info if you need it.

@Sorenson: What about the idea to put the video on a fast (USB 3,0) stick and test this without the local network? Fast Ethernet is not that fast ( 100 mbit) and not all NAS creates a good bandwidth.
With that you would know at once whether your local network is part of the problem or not.

@JimKnopf Thanks for the suggestion but as mentioned above, I have already tried this with the same results - video playback stutters and skips regardless of whether over network or from local USB 3.0 storage, so I don’t think it’s a network issue.

The problem is not consistent, with certain files skipping and others playing back smoothly, so I’m in the process of trying to identify which videos skip and how they are encoded to see if there’s a pattern.

Maybe you could try playing some of the Kodi sample files if they have the same problem. If so, we could establish if it’s only happening with your setup or not.

I still haven’t bought that 4K OLED yet so I won’t be able try it myself.

Haven’t seen that in a while.
Try disabling Amcodec video acceleration and see if it improves (albeit temporarily)

Sam

After disabling Amcodec video acceleration, playback of this file has massive stutter and video is running at about 50% speed. I’m still looking through other files to see which ones skip and which ones play fine, to see how they’re encoded.

I notice there is a new version of OSMC out, but mine seems to be stuck on 17.1-RC2 with no updates available (I’ve switched back to the regular update channel). I’ll check for updates again in a bit, and will test to see if anything has improved.

Beware that as stated in the comments of the latest osmc update, you might still see the version being rc2 even if the update was successful and you are indeed running the very latest version.

The latest version should not show RC2.

The update came through and I’m now on 17.1. Unfortunately, the same videos are still skipping. I’ll report back soon with mediainfo for the offending videos.

Sorry for not coming back sooner. To conclude this thread, I worked out that all offending videos were VC1-encoded Blu-ray MKV files. I have re-encoded all the files to H.265 HEVC, and they now play back without the huge picture jumps.

There are VC1 PTS improvements coming in the May update

Sam

Since transitioning from an Rpi3 to the Vero4k this week I’ve been experiencing the same trouble. Again it’s my rips encoded as:

Video
ID                          : 1
Format                      : VC-1
Format profile              : Advanced@L3
Codec ID                    : V_MS/VFW/FOURCC / WVC1
Codec ID/Hint               : Microsoft

Has there been any further movement on this issue? Can I provide any testing assistance?

Thanks,

There were improvements in the May update as promised but this didn’t fix all clips.

Do you have a sample you can send me that exhibits the problem?

Sam

Gladly. Thanks for looking into it.

I’ll chop something out in mkvtoolnix.
What file size is acceptable and how would you like it shared?

Wow. These are all a match from my library of clean rips. And all are affected.

2001: A Space Odyssey (1968)
A.I. Artificial Intelligence (2001)
Back to the Future (1985)
Back to the Future Part II (1989)
Batman (1989)
Batman Begins (2005)
Battlestar Galactica: The Plan (2009)
Bridget Jones: The Edge of Reason (2004)
Bridget Jones’s Diary (2001)
Burn After Reading (2008)
Constantine (2005)
Enter the Dragon (1973)
Heat (1995)
Inception (2010)
Lost in Translation (2003)
Love Actually (2003)
Monsters (2010)
Notting Hill (1999)
Psycho (1960)
Serenity (2005)
Sex and the City (2008)
Sex and the City 2 (2010)
Swordfish (2001)
The Dark Knight (2008)
The Departed (2006)
The Island (2005)
The Last Samurai (2003)

OK, here’s a 30 second clip from The Departed whilst I’ve got chance. As I say, please advise as to any other samples you require. I hope this is useful to the cause.

Cheers,

Is a bit of an old format are those HD DVD’s ?

Nope. Blu-rays all.
I guess not that unusual if my collection is anything to go by. A studio preference perhaps?