Subtitle Offset Activated with Right Button on Remote

Hi. Client updated his Vero 4K+ to latest March (2020.03-1) firmware. Pressing the right direction button on his remote produces subtitle offset during playback.

Here’s the log

Here’s what it looks like on screen

This same unit experiences another problem when it starts, it doesn’t go to home screen but screen looks like this

No it doesn’t…

2020-03-26 14:09:40.575 T:4069462016 DEBUG: HandleKey: right (0xf083) pressed, action is StepForward

But holding it down does…

2020-03-26 14:10:07.605 T:4069462016 DEBUG: HandleKey: long-right (0x100f083) pressed, action is subtitledelay

As it should when using our new custom keymap. You can find out more information about this here…

I don’t really know what is going on there. Does it act normally in Estuary? If so then you might try resetting your OSMC skin.

1 Like

Thanks @darwindesign.
Tell me if I understood correctly - client pressed too long, that’s why he got subtitle offset instead of skip forward?
Solution to this would either be tapping quicker or turning off the new keymap by going to Settings>System>Input>Peripherals>OSMC RF Remote>Don’t use the custom keymap for this device> [enable] ?

There is a significant window between what is a short and long press so getting that to happen by accident should be difficult. You could turn off the custom map but that will not remove long-press support so if they hold that key down it will activate fast forward instead (Kodi default mapping). If you wanted to make it so the long-press did not perform an action at all you would have to manually add a keymap and noop the long-press action so only the short press is registered.

1 Like

Hi @darwindesign. Your advice on the remote was correct. Solved the problem with client on that issue. Thank you!

What’s left is the home screen going to a screen called elements on bootup. Also, it goes to the same screen when client goes to Videos -> Files as seen on these 2 youtube videos.

  1. Using OSMC skin -
  2. Using Estuary skin -

Going to Videos -> Files also produces the same “Elements” screen.

If you go to settings>player>disks>play DVDs automatically> and set that to disabled does this stop this behavior?

Will try. Thanks!

Solved! Thank you @darwindesign! 2 for 2!

1 Like