System hangs on boot with new OSMC 802.11ac WiFi dongle installed

Try this. Boot up with your working dongle. Once it’s back running, ssh in and:

sudo mv /lib/firmware/mt7610u_sta.dat /lib/firmware/mt7610u_sta.dat.save

Shutdown, and try the OSMC dongle again.

[EDIT] Before you try the above, do you have max_usb_current=1 set in /boot/config.txt?

@bmillham

Thanks for the reply & suggestions.

Sadly, I’m getting the same problem with these changes.

@sam_nazarko any ideas?

Yes, I already posted the solution a couple of days ago. He needs to dist upgrade on staging

I will post a 1 line solution when I’m at my PC

Oneliner here:

However, that just starts the dongle - no connection to my network has been established.

@ogre

Thanks for the input…It seems that I’m getting the same results as you.

System now sees the dongle ok, both 2.4Ghz & 5Ghz. I can get an ip address for 5Ghz but
it seems that it doesn’t actually connect to the network.
It also shows “Status: No Internet”

I can’t ping it, nor can I ssh into it. This may have something to do with channel settings on the
router…pure guess on my part…so I’ll have a fiddle.

One “strange” thing I’ve noticed is that for all the SSID’s it finds, the signal strength is showing the
same for them all… 1 dot … Before the changes I’ve made today & with the other dongle,
various strengths are reported, as you would expect.

Happy to try any further suggestions, logging etc.

Cheers,
TC

EDIT: I’ve now changed back to my older dongle. New software still doesn’t detect 5GHz SSID but
SSID’s are being reported with the various signal strengths as per normal.

What does your /lib/firmware/mt7610u_sta.dat look like?

I’m unsure of what this file is but after saving the file as per your instruction the other day,
there hasn’t been a new one created.

I’ve got to ftp it to my laptop to capture display…back soon.

Edit… here it is

#The word of “Default” must not be removed
Default
CountryRegion=31
CountryRegionABand=7
CountryCode=
ChannelGeography=1
SSID=11n-AP
NetworkType=Infra
WirelessMode=8
EfuseBufferMode=0
Channel=0
BeaconPeriod=100
TxPower=100
BGProtection=0
TxPreamble=0
RTSThreshold=2347
FragThreshold=2346
TxBurst=1
PktAggregate=0
WmmCapable=0
AckPolicy=0;0;0;0
AuthMode=OPEN
EncrypType=NONE
WPAPSK=
DefaultKeyID=1
Key1Type=0
Key1Str=
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
PSMode=CAM
AutoRoaming=0
RoamThreshold=70
APSDCapable=0
APSDAC=0;0;0;0
HT_RDG=1
HT_EXTCHA=0
HT_OpMode=0
HT_MpduDensity=4
HT_BW=1
HT_BADecline=0
HT_AutoBA=1
HT_AMSDU=0
HT_BAWinSize=64
HT_GI=1
HT_MCS=33
HT_MIMOPSMode=3
HT_DisallowTKIP=1
HT_STBC=0
VHT_BW=1
VHT_SGI=1
VHT_STBC=0
EthConvertMode=
EthCloneMac=
IEEE80211H=0
TGnWifiTest=0
WirelessEvent=0
MeshId=MESH
MeshAutoLink=1
MeshAuthMode=OPEN
MeshEncrypType=NONE
MeshWPAKEY=
MeshDefaultkey=1
MeshWEPKEY=
CarrierDetect=0
AntDiversity=0
BeaconLostTime=4
FtSupport=0
Wapiifname=ra0
WapiPsk=
WapiPskType=
WapiUserCertPath=
WapiAsCertPath=
PSP_XLINK_MODE=0
WscManufacturer=
WscModelName=
WscDeviceName=
WscModelNumber=
WscSerialNumber=
RadioOn=1
WIDIEnable=1
P2P_L2SD_SCAN_TOGGLE=3
Wsc4digitPinCode=0
P2P_WIDIEnable=0
PMFMFPC=0
PMFMFPR=0
PMFSHA256=0

Copy that file back into /lib/firmware and reboot.

What version of the Pi are you using? What country are you located in?

You may need to tune CountryRegion, CountryRegionABand and WirelessMode depending on where you are located.

I’m using a RPi 2 and located in Australia.

I still have the file there…just need to rename it , change the dongles & re-boot.

Just to confirm, you do have max_usb_current=1 in /boot/config.txt right?

Yep…first thing I changed yesterday

Ahaa… we’ve made progress of sorts.

I can now both ping & ssh into the rpi

The scan of available SSID’s is a little different. The list is way shorter than previous but the signal
strength indicators all remain at 1 dot. One of the missing SSID’s is my 2.4GHz and judging by the
names of those I am seeing, they are perhaps only 5GHz.

I don’t think that SS reports properly, so I wouldn’t worry about that. I think for some regions that the default configuration only uses 5Ghz.

Good news, we are getting closer :wink:

Have a look at CountryRegionABand, and adjust it to match your router. Here are the possible values:

    0: use 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165 Channel
    1: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140 Channel
    2: use 36, 40, 44, 48, 52, 56, 60, 64 Channel
    3: use 52, 56, 60, 64, 149, 153, 157, 161 Channel
    4: use 149, 153, 157, 161, 165 Channel
    5: use 149, 153, 157, 161 Channel
    6: use 36, 40, 44, 48 Channel
    7: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157,
    8: use 52, 56, 60, 64 Channel
    9: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 149, 153, 157, 161, 165 Channel
    10: use 36, 40, 44, 48, 149, 153, 157, 161, 165 Channel
    11: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 149, 153, 157, 161 Channel

Also since you can now ssh into the Pi, run iwconfig and make sure you are connected at 433.5Mbs.

I’ll look into the router changes. As for ssh into the rpi, I can now describe the connection
as “flaky”, at best. Keep losing session connection & experimenting ping I’m finding
that’s it’s going up & down. ssh has hung at the moment…can’t find iwconfig…is it part
of a package?

Hmm, I thought iwconfig was installed by default.

Try this setting, but I suspect that it may break things again:

WirelessMode=14

If that doesn’t work, try 12 instead.

Also set

CountryCode=AU

CountryRegionABand is value 7 & control channel of 149 on router should be ok if I’m interpreting
the table correctly.

Yes, you read it correctly, 7 will allow channel 149. You may want to change it to a map that closer matches you router, but I don’t think it’s really important.

For me, changing WirelessMode is what got things working. Before I changed it to 14, I had the same problems as you are currently having. Slow pings and dropped connections.

Is that setting “sticky” …? ie I don’t lose it on re-boot… I can’t set it in the .dat file so I just keyed it in
on the command line