System hangs on boot with new OSMC 802.11ac WiFi dongle installed

Is that setting “sticky” …? ie I don’t lose it on re-boot… I can’t set it in the .dat file so I just keyed it in
on the command line

It has to be in the .dat file. You will need to sudo to edit the file.

OK… I’ll have to reboot with the other dongle to get a stable connection. Back soon.

Tried WirelessMode 14 & 12…neither fixed the problem. We’re now back to “Status: No Internet”.

Where are you located?..Don’t want you spending half the night on this.

I’m in the US. Forgive the stupid question, but you are trying to connect to an AC router?

Ok … may not be all that late, time zone depending. Yep… Asus RT AC68U

Try:

CountryRegion=7

And if that helps, maybe try WirelessMode=14 again. Poking around the code, I also found WirelessMode=15 (that should use N or AC only if the comments in the code are correct)

Found this bit in the code, may help with selecting the correct CountryRegion

UCHAR CountryRegion;    /* Enum of country region, 0:FCC, 1:IC, 2:ETSI, 3:SPAIN, 4:France, 5:MKK, 6:MKK1, 7:Israel */

Still no go… Tried CountryRegion=7 with 14 again & 15. It’s interesting that with 14, when I first boot the rpi with my old dongle, the scan displays ( briefly ) the SSID of my 5GHz and then drops it.

Re that code…From what I could find, FCC is USA, IC - don’t know, ETSI is Europe, MKK & MKK1, don’t know and
the rest are self explanatory.

Anyway, I am going to thank you for all the time you’ve given me for this and take a break. At the very earliest, it’s
heading towards 9:30pm for you; the latest, after midnight.

Cheers for now,
TC

Sorry I wasn’t able to get things working, but I think we are on the right track. It’s just figuring out the correct combinations of settings.

It is getting late here, 12:30AM, so I am off for the night.

I’ve tried to run debug & capture the log/s. Here are 3 files that I think are the logs. If they
are he right ones, may help.

Well, I tried the upload option but was told the file types were wrong. Now, how on earth am I
to give log files to help if I can’t upload them…!!!

I can’t use the normal http://etc etc/log-file-name as I can’t get internet connection with this dongle.

Very frustrating.

It’s all easily explained on the wiki in this link.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

It may be easily explained but in practice , if you can’t connect to the network, it’s not easily done.

grab-logs relies on an available network which is not
available when I use the OSMC dongle running debug.

MyOSMC can save logs to the /boot (windows readable) partition on the SD card.

@teejcee, have you tried the other CountryRegions?

Or, maybe try this, comment out the CountryRegions line (just put a # at the start of the line), and make sure you have CountryCode=AU set.

I’ve been looking through the drive code, but haven’t gotten any more clues yet.

As to logs, what I’d like to see is dmesg output. But without the network, you won’t be able to get that. Maybe after booting with the OSMC dongle you could remove it and put in your working dongle. Maybe the network will come up, and then you can get the logs.

{EDIT| just read @ActionA s comment, I didn’t think about saving the log files to /boot, so you could try that.

@ActionA & @bmillham

Ahaaa /boot so that’s where the upload is… helps when you know where to look…

let me take a look…back soon.

Edit… found it ok but it’s a txt file & not allowed to upload to here

I might be able to get grab-logs to work. I’ve been fiddling with the settings in /lib/firmware/mt7610u_sta.dat and the value for WirelessMode and the connection is a little more stable now.

Just copy/paste to paste.osmc.io after you paste then click save on the top right, now copy the url from the address bar of your browser

@teejcee, Something I should have asked you yesterday… did you do this before trying out the dongle:

First edit your /etc/apt/sources.list: Change this line

deb http://apt.osmc.tv jessie main

to

deb http://apt2.osmc.tv jessie main

(You have to sudo to edit sources.list)

Then:

sudo apt-get update
sudo apt-get dist-upgrade

That will make sure you have the correct latest version of the driver.

Ok…I’ve managed to get a stable connection with debug running.

http://paste.omsc.io/ejupijuvot

Not sure what you’ll find given that’s it’s working, albeit a little flaky.