Test Edimax EW-7822UAC and NETGEAR A6200

There are more WiFi improvements coming in the September update



Sounds good Sam,
any clue on the date?

These are the test results with the newest update (2015.09-1):
2.4GHz 66.1 Mbits/sec
5GHz 97.0 Mbits/sec
I think something’s wrong here, these speeds were higher before the update.
I’ll have to check what’s going on.


Hi…correct me if I’ve misread but are you getting an EW7822UAC to work @ 5ghz on an RPI2?

If so, would you mind posting a how-to please.

I’ve got both an EW7811UAC & an EW7822UAC nd cannot get either to detect & use 5ghz. The strange thing is that the 7811 used to work mid last year but it appears updates have stopped it for whatever reason. I haven’t addressed the issue until now , with other stuff “on my plate”.

debug log file http://paste.osmc.io/jokoxuvibi may assist?

Thanks in advance for any assistance.

Hi TC, yeah it was working when I did the tests and it’s still working.
Basically I didn’t do anything special.
Just pluged it in, went into MyOSMC network and enabled the wireless adapter.
In the list on the right there were both 2.4 and 5ghz networks.

I don’t use wireless with my RPI2 since wireless speeds are not even close to the one on my Windows 7 laptop.
Basically the linux drivers are crap, @sam_nazarko fixed them a little bit, so you’ll get better performance than on the Openelec.
At the same time RPI2 hardware is slow by itself so the whole thing is a bottleneck too.

The adapter works for sure, I’ve set it up for my parents and would have heard from them if something stopped working :slight_smile:

The only thing I can think about is potentially your router?
There are “channels” that the router uses and they might not be completely compatible with your wireless adapter.
Changing them might help out.

But if everything worked before and it doesn’t right now it might be your OSMC.
I would suggest backing up your data and installing a fresh copy of OSMC, check if it’s working then!

Thanks vdb86…I’ll look into the channel settings. I know that they’re currently set for “Auto”, so I’ll see what I can do with different settings.

A fresh install of OSMC isn’t such a big deal if i comes to that.

I’ll post my findings.


To be honest I’d go straight to a fresh install, if that doesn’t work out then try out your router.
Usually router manages to set up everything as it should be set up.

The bottom line is everything should be working just fine, we just have to figure out why it’s not working :smiley:

Thinking about it this morning, I reckon you’re on the right track. I’ve had a few “power disconnect” shutdowns
that generally don’t play well with these systems. Plus , I’ve had no luck lately with my TV remote
suddenly not working as CEC. It’s a Panasonic Viera. May fix this as well.:grin:

A re-install it is…I’ll post results


I’m pretty sure a reinstall will be a step in a good direction.
This software is generally good but sometimes things just happen.

I hope it will solve your issues!

Hey…that was quick…!!! Are we in close-by time zones? I’m in Sydney.

Not even close, I’m in Belgrade :smiley:

Well…there you go. Anyway, I’m still working on the problem. Had grandchildren to contend with today wich
took up a lot of my time.

Hi…back on the job again after many problems that I won’t go in to.

Anyway, after many reinstalls, my system still refuses to see 5GHz ssid. Just the 2.4 GHz.

It’s definately enable on the router…this laptop is using it.

I’ll keep searching for an answer & try whatever I can find.


Hmm, did you format the card before installing OSMC?
Not sure if OSMC installer formats it before it installs OSMC.

It should be working without any problem!
I guess the next step would be to check the router setting (channel).
The usb dongles are set to some channels which are supposed to be used in a country they are being sold, so you might want to play with that a bit.

To be honest I don’t know what you could do if this doesn’t work, unfortunately I’m not a linux guy so I can’t tell you type this into the console and see what it gives you.

I have a comment based on recent experience:
If the router is set to use a channel which the dongle cannot ‘see’, then you won’t get the option of selecting that network. I found this on another piece of equipment when it stopped working, and the router proved to have auto-selected channel 1 (which i thought it had been using for some while), and then things started working again when I made a router manual selection of channel 4.
By-and-large the channel numbers are more restricted in the USA than in Europe (notably at the high-number end).

@vdb86 & dandsmith

Thanks to you both for your input but I’m giving up.

I have tried every combination of channels for 5GHz on my router ( Asus RT-AC68U ) but the rpi2/osmc refuses
to acknowledge it’s presence.

2.4GHz will have to do

If anyone has other ideas, they’d be welcomed by me.


Unfortunately I’m out of ideas :frowning:
It should work, especially with everything that you did!