[TESTING] Bluetooth audio streaming (A2DP)


I have had the same issue with PulseAudio as I had here.

In addition to this OSMC became completely unresponsive and the only way I could get it to respond was to stop and start the mediacenter using this method https://osmc.tv/wiki/general/starting-and-stopping-kodi/

Once I solved the unresponsive issue, the only way I was able to get audio restored was to stop the PulseAudio service and reboot OSMC as I did before. Has anyone else experienced something like this?


I use Kodi remote iOS app on iPhone to change the volume of A2DP sound from OSMC going to bluetooth speaker.
It’s a homemade bluetooth speaker, and I didn’t put a volume knob on it :wink:


Hi all,

I recently bought what I believe to be the OEM version of the OSMC USB bluetooth dongle (LogiLink Bluetooth Micro USB 2.0 Adapter) since that’s what was easily available around here.

I then disabled the RPi3 BT as per the instructions from earlier in the thread (dtoverlay=pi3-disable-bt should also work in config.txt) and rebooted. However even with the Bluetooth dongle plugged in I’m not getting the Bluetooth menu under My OSMC.

I guess that means the dongle isn’t the same as the OSMC dongle after all and hence missing the driver, correct? Or what else could I have done wrong?



Correct. That dongle is not an OSMC dongle.

You can check if your dongle is faulty by trying it on a PC. If it isn’t and it’s not detected in Linux then that means there is no support for it.

You might be able to get it to work but we can’t support this dongle or provide any advice on it. There are so many different dongles out there and some companies even produce multiple variants which makes it impossible for us to make a recommendation for every region.


Thanks for the quick reply, much appreciated.

Next step: Buying the official dongle. :wink:


Checked with two different speakers on Vero 4k and worked seamlessly out of the box!


Have had issues with audio stuttering/dropping out streaming Bluetooth audio from iPod touch to OSMC.

Logs located here: https://paste.osmc.tv/uyigevukih

Tried a few things from earlier in this topic:

  1. Added dtparam=audio=on to Pi Config
  2. Turned Audio Passthrough off.

Neither of these things helped… Can anyone help me out? I have got the official OSMC Bluetooth dongle and this is really frustrating.


Did you put the line


in config.txt to ensure its using the Bluetooth dongle and not the onboard bluetooth


It’s a raspberry pi 2 so no onboard Bluetooth dongle.


There is audio shuttering on both Bluetooth headphone and TV speaker trough HDMI after installing a2dp-app-osmc package on Vero 4k. It doesn’t get fix even after removing that package, due to dependencies which are not going to be removed even by apt-get autormove command.


On Vero 4K run:

sudo apt-get remove --purge pulseaudio and reboot.


Fixed after purging pulseaudio.


Hi Sam,

Would something like this work for stuttering/audio dropouts on a Raspberry Pi 2?


Purging PulseAudio has not fixed my issues with audio stuttering/dropouts. Absolutely nothing I have tried has any effect. This is so frustrating.


PulseAudio is needed for BT audio streaming. My suggestion to Danial was to purge it as it’s not quite ready for prime time on Vero 4K yet.


Thanks Sam, I did go through the install procedure at the top of this topic after purging PulseAudio.


So I seem to have been playing stutter free tonight. Whereas this morning it was really bad. The only difference is that this morning I was trying to stream the audio over bluetooth immediately after playing a video from my PC to OSMC using DLNA/UPnP. Is it possible that this could have interfered and caused the stuttering problem?


Hi @sam_nazarko: I now received the official dongle from you yesterday but I’m still having issues:

Bluetooth now shows up in the Networking menu right away and the RPi 3 (onboard BT is disabled) can also see my headphones (Sony MDR-ZX770BN) but the connection always fails regardless of what I do. Which logs would you need to figure out what’s going on?

For all: Here’s a side-by-side comparison of the official dongle (on the left) and a dongle I had bought locally since it had exactly the same design. The official dongle is recognized right away whereas the other one isn’t. So I guess it really is important not to judge a dongle by its cover. :wink:



It’s possible that the headphones require a pin code, such as 0000. There are a couple of different options, including the option to Trust and Pair (IIRC off the top of my head correctly).

Alternatively, it can be paired with the command line using bluetoothctl

We’re improving the Bluetooth GUI in the near future.



I installed this last night for the purpose of streaming audio from an iPhone to OSMC, it at first worked great. This morning though things changed a bit, I’ve searched this thread and elsewhere online but I haven’t been able to find help on this. I have my Rpi hooked up to HDMI for movies and TV shows and I also use HiFi Berry to a receiver for music. After installing A2DP my ALSA device is no longer listed as being my HiFi Berry, but now is Bluetooth stream to Speaker. I haven’t been able to select HiFi Berry as my audio out since installing A2DP, is there a way to select HiFi Berry as my ALSA device instead of Bluetooth stream to speaker?