[TESTING] Debian 10 Buster


After some hard work, it is now time to test Debian 10 (Buster) for all currently supported devices. We need feedback before we can release this as a stable update. The more testers we get, the quicker we can get this out of the door as a regular upgrade.

Known issues (will be added as discovered / reported)

  • TBC

Solved issues

  • TBC


Please note that the only way to downgrade after installing this is to reinstall OSMC; unless you really know what you are doing. Please take a backup of any important data before testing.

To test this update:

  1. Ensure your system is up to date via My OSMC.
  2. Login via the command line
  3. Edit the file /etc/apt/sources.list
  4. Change all references of the word ‘stretch’ to ‘buster’
  5. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot or update via My OSMC -> Updates -> Manual Controls -> Check for Updates now (recommended).
  6. Your system should have have received the update.

Please note that Vero 4K/4K+ users also have the opportunity to test an improved video stack which is not yet included as standard. More details on this can be found here. Issues specific to this improved video stack should still be reported and diagnosed in the other thread as not to obstruct this thread.

We are looking forward to your feedback




So the update went off without issues no broken packages, will update this post if anything occurs

the only issue i got is with hyperion.ng spamming my syslog with

usbfs: process 606 (LedDeviceThread) did not claim interface 0 before use

not really OSMC related but worth mentioning

Do I need to install this first before improved video stack update?

You can do it in one go as it is explained in the 4.9 thread.

If you are already on 4.9, it must be done in one go.



Update went successfully but having issues with docker. I have removed docker stretch but have this when trying to install buster:

osmc@HTPC:~$ sudo apt-get install docker-ce docker-ce-cli containerd.io

Reading package lists… Done
Building dependency tree
Reading state information… Done
containerd.io is already the newest version (1.3.7-1).
docker-ce-cli is already the newest version (5:19.03.13~3-0~debian-buster).
Recommended packages:
cgroupfs-mount | cgroup-lite pigz libltdl7
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/14.4 MB of archives.
After this operation, 68.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package docker-ce.
(Reading database … 46303 files and directories currently installed.)
Preparing to unpack …/docker-ce_5%3a19.03.13~3-0~debian-buster_armhf.deb …
Unpacking docker-ce (5:19.03.13~3-0~debian-buster) …
Setting up docker-ce (5:19.03.13~3-0~debian-buster) …
Job for docker.service failed because the control process exited with error code.
See “systemctl status docker.service” and “journalctl -xe” for details.
invoke-rc.d: initscript docker, action “start” failed.
● docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Sun 2020-09-20 10:30:21 BST; 31ms ago
Docs: https://docs.docker.com
Process: 8254 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
Main PID: 8254 (code=exited, status=1/FAILURE)
dpkg: error processing package docker-ce (–configure):
installed docker-ce package post-installation script subprocess returned error exit status 1
Processing triggers for systemd (241-7~deb10u4) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

osmc@HTPC:~$ sudo dockerd --debug

INFO[2020-09-20T10:35:45.029129479+01:00] Starting up
DEBU[2020-09-20T10:35:45.032409020+01:00] Listener created for HTTP on unix (/var/run/docker.sock)
DEBU[2020-09-20T10:35:45.035398229+01:00] Golang’s threads limit set to 10260
INFO[2020-09-20T10:35:45.037581187+01:00] parsed scheme: “unix” module=grpc
INFO[2020-09-20T10:35:45.037723187+01:00] scheme “unix” not registered, fallback to default scheme module=grpc
INFO[2020-09-20T10:35:45.037943270+01:00] ccResolverWrapper: sending update to cc: {[{unix:///run/containerd/containerd.sock 0 }] } module=grpc
INFO[2020-09-20T10:35:45.038066562+01:00] ClientConn switching balancer to “pick_first” module=grpc
INFO[2020-09-20T10:35:45.044229979+01:00] parsed scheme: “unix” module=grpc
INFO[2020-09-20T10:35:45.044449479+01:00] scheme “unix” not registered, fallback to default scheme module=grpc
INFO[2020-09-20T10:35:45.044718729+01:00] ccResolverWrapper: sending update to cc: {[{unix:///run/containerd/containerd.sock 0 }] } module=grpc
INFO[2020-09-20T10:35:45.044954562+01:00] ClientConn switching balancer to “pick_first” module=grpc
DEBU[2020-09-20T10:35:45.050336854+01:00] Using default logging driver json-file
DEBU[2020-09-20T10:35:45.051006104+01:00] [graphdriver] priority list: [btrfs zfs overlay2 aufs overlay devicemapper vfs]
DEBU[2020-09-20T10:35:45.051221729+01:00] processing event stream module=libcontainerd namespace=plugins.moby
DEBU[2020-09-20T10:35:45.102060979+01:00] backingFs=extfs, projectQuotaSupported=false, indexOff="" storage-driver=overlay2
INFO[2020-09-20T10:35:45.102262979+01:00] [graphdriver] using prior storage driver: overlay2
DEBU[2020-09-20T10:35:45.102429229+01:00] Initialized graph driver overlay2
WARN[2020-09-20T10:35:45.113113062+01:00] Your kernel does not support cgroup memory limit
WARN[2020-09-20T10:35:45.113318395+01:00] Your kernel does not support cgroup cfs period
WARN[2020-09-20T10:35:45.113535354+01:00] Your kernel does not support cgroup cfs quotas
WARN[2020-09-20T10:35:45.113638312+01:00] Unable to find blkio cgroup in mounts
WARN[2020-09-20T10:35:45.113711604+01:00] mountpoint for pids not found
DEBU[2020-09-20T10:35:45.115501895+01:00] Cleaning up old mountid : start.
failed to start daemon: Devices cgroup isn’t mounted

1 Like

@ Sam : thank you so much for the hard work and the buster test release. what are the main advantages stretch - > buster ?

I tried to upgrade to Buster. Everything went fine till reboot. After intializing system modules show blue screen and after bad smile. Cannot grab logs, cant ssh. I tried it directly from VERO, but it seems to have problem with internet connection.

Can you connect using ethernet (wired)?

You could write it do boot with grab-logs -C and then copy to USB stick

yap it helps, thanks.
here is uploaded log. Seems problem with mali driver.

  1. You were on Kernel 4.9 but didn’t activated the new repositry

deb http://apt.osmc.tv videoimprovevero main

deb http://apt.osmc.tv videoimprovevero49 main

  1. I would comment out the buster-devel repository as it currently would not have packages

  2. Ethernet should still work, can you connect to Ethernet?

Omg, i forgot to change it, my fault… I activated ethernet in connman. Now booted to kodi right.


Then correct it, update again and you should be all done.

I did it manually in command line. Thanks.

Updated an RPi 3+, works smooth as common.

Unfortunately, it’s hard to say – you don’t mention what device you’re using or provide full logs.

Hi @sam_nazarko
Is this compatible with the Raspberry Pi 4 by any chance? If yes, can I use the imager to install the older version and then change the sources as above? If not, is there a blog or specific location to watch for updates on the RPi 4 progress? I’m surprised that it’s been this long and still no builds for the RPi 4.

Thanks in advance

No – it’s not yet compatible.

But moving to Buster is needed and beneficial for enabling Pi 4 support.
When the support is ready, there will be a testing thread here and some communications on the blog.