[TESTING] Debian 11 Bullseye

Just from some stuff I digged online (like kodi github) and from the fact it works on x86 and on the firestick (even though I’m not sure the stick is running in 64bit mode). Anyways, It might have nothing to do with it…

Can you point me to an image I can used which has it? I’m surely interested in checking if it solves the issue…

I see this testing thread which is closed. Is this the video stack you are referring too? AFAIU, it’s already part of the latest release (which I tested and is still not working). Am I missing something?

No – I’ve sent you the details.

Thanks… I will give it a try

I’m interested…

Wow, they are really slow at pushing an update. The changes that needed to be made can be found [here]. As you can see the changes have been merged but there is no current build there so I just manually tweaked the current add-on. What follows is what I did that worked for me using a Windows PC.

Grab a copy of the cached add-on zip from Kodi at…
~/.kodi/addons/packages/script.plex-0.3.4.zip
and copy it to your PC and then unzip it. If you have SAMBA server installed in OSMC then you can just open Explorer and type in…
\\192.168.x.x\osmc\.kodi\addons\packages\script.plex-0.3.4.zip
(replacting the ip address) and then just drag and drop the script.plex folder over to somewhere on your PC. Next install notepad++ if your don’t already have it. Open Notepad++ and File>open folder as workspace and select the script.plex folder you pulled from the zip file. Double click addon.xml and modify the version number on the fourth line to 0.3.4.1 and then save and close that file. In the workspace pane right click on the script.plex folder and select find in files. In the dialog box that comes up tell it to find “.isalive()” and replace “.is_alive()” and click “replace in files”. Close the workspace and quite Notepad++. In Explorer right click on the script.plex folder and select “compress to zip” and name it “script.plex-0.3.4.1” and then copy this zip file somewhere that you can access from within Kodi (like the osmc home folder). Finally you just need to go to the add-ons section of Kodi, tell it to “install from zip file” and point it to where you saved that zip.

One final note, don’t bother trying to directly edit ~/.kodi/addons/script.plex as that method doesn’t work.

Thank you !

quick note for mac users: you can access the .zip via cyberduck. Login as root / [your password], make all files visible (view -> show hidden files, or command-shift-R) to get to the .kodi folder.

You can batch change the files using BBedit, howto is here.

Drop the .zip anywhere convenient, and you might then want to login via terminal, navigate to wherever you dropped the zip file, and chown osmc:osmc script.plex-0.3.4.1.zip

1 Like

Spending a little time with logs, the original logs I’ve uploaded missed the error, which is:

2022-06-27 19:12:01.283 T:17566    INFO <general>: Creating InputStream
2022-06-27 19:12:01.331 T:17566    INFO <general>: Creating Demuxer
2022-06-27 19:12:01.606 T:17566    INFO <general>: Opening stream: 0 source: 256
2022-06-27 19:12:01.606 T:17566    INFO <general>: CVideoPlayerVideo::OpenStream - Creating codec: 27
2022-06-27 19:12:01.606 T:17566   ERROR <general>: CDVDVideoCodecAmlogic::Open - InstanceGuard locked                    
2022-06-27 19:12:01.606 T:17566    INFO <general>: CVideoPlayerVideo::OpenStream - could not open video codec
2022-06-27 19:12:01.606 T:17566    INFO <general>: Opening stream: 1 source: 256
2022-06-27 19:12:01.606 T:17566    INFO <general>: Finding audio codec for: 86056
2022-06-27 19:12:01.607 T:17566    INFO <general>: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder eac3
2022-06-27 19:12:01.607 T:17566    INFO <general>: Closing stream player 3
2022-06-27 19:12:01.607 T:17566    INFO <general>: Opening stream: 2 source: 256
2022-06-27 19:12:01.908 T:17576    INFO <general>: CVideoPlayerVideo::OpenStream - Creating Codec: 27
2022-06-27 19:12:01.909 T:17576    INFO <general>: CDVDVideoCodecAmlogic: using Amlogic decoder H.264/MVC
2022-06-27 19:12:01.909 T:17576    INFO <general>: DVDVideoCodecAmlogic: Opened Amlogic Codec

So it appears that kodi is trying to play the next file too soon.

From a cursory search, it seems like a known issue Issue 20021. However, this was not something I had experienced prior to the Bullseye build. Could there be something to be done in OSMC?

Happy to provide further logs as needed.

That’s interesting, I will have a look!

@sammyrc34, can you post a complete log which shows that error? Or better: create a new log, but enable debug logging and also enable video component logging. That would show in detail what happens. I wonder why that was working before?

Until I have debugging enabled, here’s a log showing the error:

logs

Thanks for the logs and your investigations :+1: . That issue which you’ve linked above helped a lot. There really is a race condition. It has nothing to do with that mentioned m_opened flag but it’s in that area. I suppose my recent refactoring has changed the timing and now that race condition leads to a crash more often than before.

I’ll try to fix it and keep you informed. If possible, it would be great if you could upload a debug log when you get that error again. That would be very helpful.

Using the image for the Vero 4k in first post to re-image my vero via a SD card.

On the screen it stated “Please Stand By” then a few moments later the OSMC splash screen shows then the screen goes blank. Waited for about 30 mins with screen still blank. is this expected for successful install as now when reboot with or without SD card it is the same as above.

I can ssh into the device.

Can you post the log file from the SD card?

Thanks. Here is the log from the SD card.

I’ve subsequently re-imaged the SD card and tried again and this time it installed successfully.

After installing from fresh image, do I have to update the /etc/apt.sources.list file as well to test?

No. You should find everything is set to bullseye. The bullseye repo is being kept up to date with bullseye-devel until bullseye is released formally.

Thanks

@sammyrc34 This should now be fixed by @tanio99 and you should receive an update shortly which resolves the issue. It would be good if you could confirm if this was the case.

Thank you @sam_nazarko and @tanio99. My apologies for not responding earlier. I attempted to reproduce with the debug log but ran out of time before setting off on a holiday. I’ll apply the update and test in a couple of weeks when home again. Thank you again.