[TESTING] Debian 11 Bullseye

Let me know how you get on.

Update just completed with no issue
Seems quite snappy. Very nice job!

1 Like

A very lengthy install! :slightly_smiling_face: But I’ve run a few test clips, and no obvious problems so far. :+1:

1 Like

So far so good here. I’m now running the Git build from 20220512-osmc, and the operating system is showing OSMC 2022.05-1 (kernel 4.9.113-66-osmc). I’ve tried a few different videos with different codecs and resolution as well as music, running a couple addons I use frequently, and checking Live TV. I’ve got it on my main TV, so I’ll be able to do more testing tonight when the spouse and I sit down to watch TV for the evening.

Question about the bullseye-devel branch. Should we keep accepting updates from it during this testing, or should I remove the osmc-devel.list file from sources.list.d? Since this is on my main unit now, I’d rather not be getting even more development updates unless they’re specific to this testing.

I only ask because I got prompted to do updates this morning (which I did).

1 Like

Just installed bullseye. Upgrade went smoothly, but I seem to have duplicate remote keypresses which weren’t present before. I hear the “click” twice (or sometimes even 3 times) but pressing up/down in the main menu for instance, sometimes only moves the cursor once. I use this as my main TV and if I press Guide, the guide briefly flashes up before disappearing again (due to the second phantom press I guess).

For context, I use an MCE RC6 remote; I had the rc6-mce-lircd config selected. I use the associated IR receiver that came with it, and blacklist meson_ir in modprobe.d. I found this the most reliable setup as the internal receiver didn’t seem to respond very well to this remote. This has worked very well since I got the device, until now :slight_smile:

I tried swapping out the RC6 config for a Samsung TV remote in My OSMC with the same results.

Not sure how to start debugging this, what information can I give you? I’m sceptical its my configuration as it worked great until before the upgrade, wondering if there’s something changed in lirc, perhaps I need to tweak some repeat delay?

Just to confirm, this is only affecting IR remotes, the OSMC RF remote is absolutely fine. I just use my own IR as I like having more buttons (direct button to TV Guide in particular) :slight_smile:

If you don’t want updates, then turn off automatic updates. But each update you will get on devel will be an improvement :stuck_out_tongue:

If you remove the devel list, you’ll get debian updates on version 11 (Bullseye) but not osmc ones. I doubt there will be any osmc updates on devel not specific to this testing. From testing so far, it looks like Bullseye will be in the main repo ‘real soon now’.

1 Like

I tested briefly earlier and had the same double input using a RC6 remote and a FLIRC usb.

That’s good to know. Honestly, I didn’t want to accidentally get a very early Kodi Nexus build on this and have to reformat it. Any time I put the devel branch on my main unit, I risk my spouse becoming Very Upset, thus I am taking my life into my own hands here. :laughing:

We are nowhere near Nexus roll-out. I think a testing thread for nightlies might appear soon-ish.

1 Like

Can anyone please state the correct content of
/etc/apt/sources.list.d/
and
/etc/apt/sources.list
after the update?
My Raspy got bullseye today - but without altering the apt sources within the last months…

Firefox reports that the links aren’t safe because they are in http://. You can prefix them with https://

I can also confirm havok with lirc IR remotes. (I use a custom lirc.conf designed for a JP1 programmable remote).
In my case it’s not just doubled, it can be 3-4 “clicks” being picked up.
I’ve tried bumping up the gap to rediculus numbers, but that does not seem to have any effect.

Hi,

two days ago I updated my Vero 4K+ to the May release through the “My OSMC” UI.
I was running the (by then) latest version before that (March release?).
Anyway, the May update rendered IR control unusable for me: every time I press a button on my remote, it bounces and is interpreted by the systems as a series of multiple button presses, eg. I press “Right” once and Kodi sees 3-4 “Right” events immediately.
This happens for all buttons I tried and makes navigating the UI impossible.

I am using the osmc-remote-lircd.conf and I have not changed anything.
It’s also definitely not caused by the remote itself.

Not sure if this helps: I had (from my point of view) the exact same issue two years ago, too, and it was fixed at some point: IR woes with vero 4K+ - #10 by _sebastian

Sebastian

@_sebastian moved your post here as you ended up on the Development Version of OSMC and the remote issue was here already reported.

1 Like

I was able to get it working correctly by killing eventlirc, and running lircd directly:

# sudo killall /usr/sbin/eventlircd
# sudo lircd --device /dev/input/event3 --driver devinput

noting that you can double-check the input device via
# ir-keytable

Thanks Randall, at least in my case, that’s not working though.
Killing eventlircd causes Kodi to stop reacting to IR commands (as expected) and launching lircd afterwards does not change that.
I also noticed that after a reboot ir-keytable for me shows Driver: meson-ir which does not seem to be a valid choice for lircd’s --driver option.
I’m using the Vero 4K+'s builtin IR functionality via the included extension IR header.

Sebastian

It will be removed after 14 days automatically.
I will push updates regularly to both the development and stable repositories, so it doesn’t matter which one you stay with now.

Nothing has changed in terms of LIRC, eventlircd or the IR modules.
Can you reproduce the issue with the built-in (meson-ir) receiver?

update went fine on one Vero, on another I initiated the download via My OSMC, and in the top right corner there was some info about a download in progress, that disappeared leaving the My OSMC icons on the screen, and then…nothing. Just the My OSMC screen sat there. Left a while, nothing happened. System is responsive, tried again after a reboot, same thing. Is a log needed or should I attempt to force via the command line?