[TESTING] DVB improvements for Vero 4K take 2

Unfortunately, no working DVB-S device for me yet (Terratec Cinnergy S2 USB Box), same non-TV behavior as before.

Hi,
I have a Vero 4k ( OSMC 17.6.0-45) and a AverMedia DVB Dongle, which was working perfectly on Rapsberry 3 and OSMC.

Do I need to update to a Nightly build to have more chance to have this working ?
Thanks

We will add support for more dongles to the stable version of OSMC soon, but for now, yes.

I don’t know if it will be working, but after update to latest nightlies and following the instructions ahead, OSMC now recognize my dongle.

For information: AverMedia AverTV Volar Green (A835)'s chip seems to be: Afatech AF9033.

1 Like

@sam_nazarko I have the official Vero Stick and with this update im still not seeing DVB-T2 under TV adaptor.

Anything I can try?

P.S. this was output of dmesg

osmc@osmc:~$ dmesg | grep -i dvb
[    4.560765] usb 1-1.4.2: dvb_usb_v2: found a 'OSMC Engineering DVB-T2' in warm state
[    4.637031] usb 1-1.4.2: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[    4.637063] dvbdev: DVB: registering new adapter (OSMC Engineering DVB-T2)
[    4.638016] dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.
[    4.660596] usb 1-1.4.2: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[    4.660614] dvbdev: dvb_create_media_entity: media entity 'Realtek RTL2832 (DVB-T)' registered.
[    4.660732] usb 1-1.4.2: DVB: registering adapter 0 frontend 1 (Panasonic MN88473)...
[    4.660741] dvbdev: dvb_create_media_entity: media entity 'Panasonic MN88473' registered.
[    4.711158] rc rc0: OSMC Engineering DVB-T2 as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-1/1-1.4/1-1.4.2/rc/rc0
[    4.711264] input: OSMC Engineering DVB-T2 as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-1/1-1.4/1-1.4.2/rc/rc0/input4
[    4.711625] usb 1-1.4.2: dvb_usb_v2: schedule remote query interval to 200 msecs
[    4.720341] usb 1-1.4.2: dvb_usb_v2: 'OSMC Engineering DVB-T2' successfully initialized and connected
[    4.720463] usbcore: registered new interface driver dvb_usb_rtl28xxu
[    4.730019] rc rc0: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 0
[   19.451594] usb 1-1.4.2: DVB: adapter 0 frontend 0 frequency 0 out of range (174000000..862000000)

That’s what it should say. Now have you followed the steps here: Watching live TV with a USB DVB tuner or network TV tuner

Thanks for your works.
Been using it for few days, everything related to pvr works perfectly.

While I didn’t find the time to test again with the OSMC DVB stick myself, but assume it is working in the meantime.

What about plugging two of these sticks (for parallel recording and watching different stations) into the Vero 4K? Should I expect any issues there, for instance in terms of overlapping USB IDs or any other bugs that prevent me from attaching more then one Panasonic MN88473 chip?

Thx
Andreas

I think two adapters will work fine. The real issues seem resolved now

Sam

Good news is that my Evolveo Venus Dual DVB-T aka Afatech AF9033 aka IT9135 now works. Not fully tested yet but at least it is correctly detected by OSMC and TVHeadend.

Bad news is that I have just received a brand new original OSMC DVB-T Stick and only the Realtek tuner is detected, no Panasonic. Deleting all content in .hts/tvheadend/input/linuxdvb/adapters makes no difference.

Logs are here: https://paste.osmc.tv/ebuwafofoz

Any ideas?

Did you try a cold boot?

Yes, I did. I disconnected the Vero from power but the result is the same.

Did you order recently?
I think you may have received a dongle we weren’t quite ready (2nd generation) to put on the market yet.

If you give me your order number I can check.

Sam

I got it sort of working for Finland, but every time I reboot the Vero4k, it looses the Panasonic adapters and gives an error “May 22 12:06:49 Vero4k tvheadend[1210]: linuxdvb: unable to open /dev/dvb/adapter0/frontend1”. The only way out is to delete the adapters folder in /home/osmc/.hts/tvheadend/input/linuxdvb and reboot again.

Are you using the latest TVHeadend?
Make sure nothing else is grabbing the adapter

Right now I can confirm that it is also working with two DVB-T2 sticks plugged in parallel. Meanwhile, two related questions came to my mind:

  1. Anyone having an idea of typical or minimum required DVB-T2 SNRs as shown in TVHeadend? If I remember correctly, in my case it was something around 6 dB, which doesn’t seem to be much, whereas I’m not even sure where / how it is measured exactly?

  2. With timeshift enabled in TVH, does this also work with the HTSP client in OSMC? I haven’t tested it yet, but also didn’t find any hints if this should be working or not in general.

/Andreas

Unfortunately measurement across adapters isn’t unified from my own personal experience, so I wouldn’t treat the readings as too important.

Timeshift should work but has always been problematic with TVH due to the nature of how timeshifting works.

@sam_nazarko Since I still didn’t have any luck using my Terratec Cinergy HTC USB XS HD (as we talked about in another thread), I figured I’d give the official OSMC T2 dongle a try, when I read that it also had a DVB-C tuner built-in. So I ordered one recently and finally had a chance to try it out today.

TVHeadend shows all 3 tuners:

  • Panasonic MN88473 #0 : DVB-C #1
  • Panasonic MN88473 #0 : DVB-T #1
  • Realtek RTL2832 (DVB-T) #0 : DVB-T #0

but when i try to scan for channels (using the correct frequencies, QAM and symbol rate), no channels appear. This is what an excerpt of the log looks like - everytime it scans for new muxes:

2018-06-18 20:54:11.586 mpegts: 450MHz in unknown - tuning on Panasonic MN88473 #0 : DVB-C #1
2018-06-18 20:54:11.586 subscription: 0343: "scan" subscribing to mux "450MHz", weight: 2, adapter: "Panasonic MN88473 #0 : DVB-C #1", service: "Raw PID Subscription"
2018-06-18 20:54:14.457 linuxdvb: Panasonic MN88473 #0 : DVB-C #1 - poll TIMEOUT
2018-06-18 20:54:16.586 mpegts: 450MHz in unknown - scan no data, failed
2018-06-18 20:54:16.586 subscription: 0343: "scan" unsubscribing

I also tried with w_scan, and the result there is:

w_scan -f c -c DK
w_scan version 20161022 (compiled for DVB API 5.10)
using settings for DENMARK
DVB cable
DVB-C
scan type CABLE, channellist 7
output format vdr-2.0
WARNING: could not guess your codepage. Falling back to 'UTF-8'
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
        /dev/dvb/adapter0/frontend0 -> "Realtek RTL2832 (DVB-T)" doesnt support CABLE -> SEARCH NEXT ONE.
        /dev/dvb/adapter0/frontend1 -> CABLE "Panasonic MN88473": very good :-))

Using CABLE frontend (adapter /dev/dvb/adapter0/frontend1)
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.10
frontend 'Panasonic MN88473' supports
INVERSION_AUTO
QAM_AUTO
FEC_AUTO
FREQ (42.00MHz ... 1002.00MHz)
SRATE (1.000MSym/s ... 7.200MSym/s)
-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    73000: sr6900 (time: 00:01.080)         signal ok:      QAM_AUTO f = 73000 kHz S6900C999  (0:0:0)
            Info: no data from PAT after 2 seconds
            deleting (QAM_AUTO f = 73000 kHz S6900C999  (0:0:0))
[...]

and after scanning, ends up saying

ERROR: Sorry - i couldn't get any working frequency/transponder
Nothing to scan!!

Where I live (with my Danish TV provider Parknet), we have unencrypted access to the DVB-C channels.

What can I try from here? I already did what you suggested in the original post and updated to the latest dist, but to no effect.

I haven’t tested with DVB-C before.
Did you test the DVB-T2 functionality to see if that works?

Sam

@sam_nazarko Ok. Don’t I need an antenna for DVB-T (or T2) to work?
Anyway, tried to scan DVB-T with w_scan, and this is what I got (removed the “blank” scanning lines):

osmc@osmc:~$ w_scan -f -t -c DK
w_scan -f -t -c DK
w_scan version 20161022 (compiled for DVB API 5.10)
using settings for DENMARK
DVB aerial
DVB-T Europe
scan type TERRESTRIAL, channellist 4
output format vdr-2.0
WARNING: could not guess your codepage. Falling back to 'UTF-8'
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
        /dev/dvb/adapter0/frontend0 -> TERRESTRIAL "Realtek RTL2832 (DVB-T)": good :-)
        /dev/dvb/adapter0/frontend1 -> TERRESTRIAL "Panasonic MN88473": very good :-))

Using TERRESTRIAL frontend (adapter /dev/dvb/adapter0/frontend1)
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.10
frontend 'Panasonic MN88473' supports
DVB-T2
INVERSION_AUTO
QAM_AUTO
TRANSMISSION_MODE_AUTO
GUARD_INTERVAL_AUTO
HIERARCHY_AUTO
FEC_AUTO
BANDWIDTH_AUTO not supported, trying 6/7/8 MHz.
FREQ (42.00MHz ... 1002.00MHz)
-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
Scanning DVB-T...
Scanning 8MHz frequencies...
474000: (time: 00:01.300)         signal ok:    QAM_AUTO f = 474000 kHz I999B8C999D999T999G999Y999 (0:0:0)
        Info: no data from PAT after 2 seconds
        deleting (QAM_AUTO f = 474000 kHz I999B8C999D999T999G999Y999 (0:0:0))
482000: (time: 00:04.740)
554000: (time: 00:22.990)         signal ok:    QAM_AUTO f = 554000 kHz I999B8C999D999T999G999Y999 (0:0:0)
        Info: no data from PAT after 2 seconds
        deleting (QAM_AUTO f = 554000 kHz I999B8C999D999T999G999Y999 (0:0:0))
562000: (time: 00:26.730)
714000: (time: 01:08.150)         signal ok:    QAM_AUTO f = 714000 kHz I999B8C999D999T999G999Y999 (0:0:0)
        Info: no data from PAT after 2 seconds
        deleting (QAM_AUTO f = 714000 kHz I999B8C999D999T999G999Y999 (0:0:0))
722000: (time: 01:11.730)
Scanning DVB-T2...
474000: (time: 01:49.000)
[...]
ERROR: Sorry - i couldn't get any working frequency/transponder
 Nothing to scan!!

Anything else I can do or try?