[TESTING] Kodi 18 (Leia) builds for Raspberry Pi


Thanks for the report. I’ve checked the build and you are right, it’s missing.

I will include it in the next nightly.


Hi There
Love your work

After Build 17.8-144,

I have 2 x pi3’s
one with ‘usb Sound Blaster X-Fi Surround’ and ‘iQaudio’ devices both not displayed/working.
Something to do with ALSA I’m guessing.

any ideas how to fix



Guessing it’s something to do with the upgrade to Stretch.

What does this command show:

sudo lsusb

You might need to install usbutils:

sudo apt-get install usbutils


Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 009: ID 2001:3c1a D-Link Corp. DWA-160 802.11abgn Xtreme N Dual Band Adapter(rev.B2) [Ralink RT5572]
Bus 001 Device 007: ID 041e:3237 Creative Technology, Ltd
Bus 001 Device 006: ID 0bda:5411 Realtek Semiconductor Corp.
Bus 001 Device 004: ID 0bda:5411 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The upgrade went fine it was working, but after the 17.8-144 update stopped working.
The problem is very similar to 'riker1’s problem

Tried reinstall with no success. cant update past 17.8-143 without losing sound devices


Sorry trying to be a bit clearer

Sound Devices aren’t displayed when updated to 17.8-144 onwards
Only Hdmi, Analogue, HDMI and Analogue are Listed

ALSA audio output not available in KODI unless root

Checking back on 144 there were some ALSA changes:

AESinkALSA: change name to ALSA (PR:13170, 1 commit, 1 file changed)
AE: drop null sink (PR:13169, 1 commit, 4 files changed

Will do some more digging.

Can I use Netflix on OSMC?(post 4)

Thank you


Similar issues with Libreelec. They have posted a patch for this which I will include in the build.

Will only be included in 17.8-152 as 151 already under way.

ALSA audio output not available in KODI unless root



17.8-151, 22 Dec 2017: Based off OSMC commit (e0574bc7) and newclock5 (1483f3)

Temp remove game.libretro
Fix script to include inputstream.rtmp

[cleanup] silence compiler warnings (PR:13221, 2 commits, 2 files changed)
fix: poweranagement & linux storageprovider build without dbus (PR:13229, 1 commit, 2 files changed)
[weather][refactor] kill g_weatherManager global (PR:13227, 6 commits, 20 files changed)
[pvr] no delay on switch to previous channel with key 0 (PR:13232, 1 commit, 3 files changed)

Fix multithreading issues (PR:169, 2 commits, 4 files changed)

Mime-Type / gzipped EPG download (3d7d559)
Update changelog and version (742fcf1)

Includes latest addons: inputstream.adaptive (fcf6695, +1), inputstream.rtmp (c772497), peripheral.joystick (33b43ce), pvr.argustv (1aa4ddc), pvr.demo (744d8ef), pvr.dvblink (4ac2f2d), pvr.dvbviewer (c2275e1), pvr.filmon (17e8193), pvr.hdhomerun (8b931e8), pvr.hts (2f39155), pvr.iptvsimple (cbd4f5a, +2), pvr.mediaportal.tvserver (8f11874), pvr.mythtv (8f214cd), pvr.nextpvr (11dfdbb), pvr.njoy (f7a9913), pvr.octonet (c4af00a), pvr.pctv (7b1c634), pvr.stalker (fad6ed4), pvr.teleboy (e431126), pvr.vbox (1ed3fd2), pvr.vdr.vnsi (0ec3e77), pvr.vuplus (b090f73), pvr.wmc (920ade6), pvr.zattoo (742fcf1, +2), vfs.libarchive (568a2a1)


Hi all.
I’m having update issue. Any help would be highly appreciated.
apt-get dist-upgrade (also with -f) fails:

Content of my sources.list:

Sytem logs:


Have you upgraded to Stretch?


root@osmc:/etc/apt# cat /etc/debian_version

root@osmc:/etc/apt# uname -a
Linux osmc 4.9.29-10-osmc #1 SMP PREEMPT Mon Oct 9 02:18:18 UTC 2017 armv7l GNU/Linux


Update to Stretch first


These are the instructions for updating OSMC to stretch.


@ActionA and @sam_nazarko:
Could you please provide the valid content of sources.list for performing upgrade to Stretch?
Just for testing of the upgrade procedure I left only:
deb http://apt.osmc.tv jessie-devel main in sources.list

But apt-get dist-upgrade returns an error:
E: The package rbp2-mediacenter-osmc needs to be reinstalled, but I can’t find an archive for it.

Any hints?


The link I provided above provided clear instructions.

deb http://ftp.debian.org/debian jessie main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv jessie main

deb http://apt.osmc.tv jessie-devel main

This is where you should start to get to stretch.


@ActionA ok, so now I have the content of my sources.list as above, but still no luck with updating:

root@osmc:/home/osmc# apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: The package rbp2-mediacenter-osmc needs to be reinstalled, but I can’t find an archive for it.

Also no luck with updating using webinterface.
Any other hints?


Did you first do an apt-get update?