[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

Any update on 3D MVC being re-enabled in the latest test or official build?

We need to release Buster first.

Difficult to confirm that. In the first log it seems you have not whitelisted any 1080 modes. Guisettings says your desktop resolution is 4k23.9Hz but it was 720p when Kodi started. Then since you didn’t turn on debug logging I can’t see when you changed the desktop to 4k or what happened when you tried to play that video without the GUI set to 4k. If 1080p wasn’t whitelisted, it’s not surprising it didn’t play as 1080p.

That should not happen but again, without debug logging it’s difficult to see what happened when you tried to play it with 1080p23.9hz whitelisted.

I recommend you don’t whitelist the ‘VESA’ modes. That may be part of the problem.

Here’s a full debug log: https://paste.osmc.tv/vabezoxapo
First with the 1080p 23.98 whitelisted, then with it removed from the whitelist.
with it in the whitelist it plays at the correct framerate but with wrong colors, with it removed from the whitelist kodi doubles the framerate and plays it in hdr.

(yeah, I have the gui set to 4k at the moment, I usually run it in 1080p, but that doesn’t make any difference, the problem is the same, removing the whitelist doesn’t make any difference either, but it does play in hdr upscaled by kodi to 4k without doubling the framerate).

It looks like we are sending the right signals

Jul 19 04:14:57 osmc-Vero4K kernel: hdmitx: video: Colorimetry: bt2020nc
Jul 19 04:14:57 osmc-Vero4K kernel: hdmitx: video: HDR data: EOTF: HDR10
Jul 19 04:14:57 osmc-Vero4K kernel: hdmitx: video: Master display colours:
                                    Primary one 0.2650,0.6900, two 0.1500,0.0600, three 0.6800,0.3200
                                    White 0.3127,0.3290, Luminance max/min: 1000,0.0000
Jul 19 04:14:57 osmc-Vero4K kernel: hdmitx: video: Max content luminance: 851, Max frame average luminance: 96

What may be confusing your display is you have the quantisation range set to full. There’s normally no need for that. Try setting it to limited.

2 Likes

Just a quick message to say I am currently testing this kernel and am experiencing no problems whatsoever. I’ve been running it without any issues whatsoever for a couple of weeks, the main reason being Wireguard compatibility.

For Wireguard to work, I had to install the wireguard-dkms package, and with this, even wg-quick works flawlessly.

Media playback: no issues whatsoever. I only play 1080p tho.
I think I only had one sad face in Kodi, but that was just around the time that I restored the Kodi backup so that could’ve triggered the sad face for some reason, but no issues at all after that.

The next (4.9) kernel will have Wireguard support included.

Sam

1 Like

Well, like I wrote, I’ve got it up and running with no issues whatsoever with your current version! (So I’m super pleased with this already) It was an absolute no-go on stable (kernel 3.*).

Do you mean it will have Wireguard compatibility in the included (default) repositories?

Do you expect any issues by the way for testers like me when updating/upgrading or falling back to stable when this becomes mainstream?

It just means the kernel module will be included for now. Userland won’t be bundled by default – at least not yet.

Yes – it’s possible you won’t be able to update smoothly to Buster. I’m still trying to work out an update path.

any news on an official build with the 3D feature?

1 Like

When it’s ready, it will become part of the stable update channel.

Yes, i know, but

  • it is a lot to do
    or
  • it is nearly ready
    or
  • do we get another testbuild

The vero “nerves” with update information, so it would be cool to see at least another/newer testbuild

1 Like

There will of course be some more test builds

Sam

I get this as well, when trying to start the video or when stopping it. I get the same thing over SMB, SFTP or Simple IPTV addon. I also tried turning off automatic refresh rate adjustment and some plugins just in case, but it still happens, even when I try using the interface slowly.

I also would get a bad link when uploading log, something like “paste.osmc.tv/< html >”, so I’m sending it to you this way
1.12 MB file on MEGA

If you want me to help out by testing stuff I can. Thanks for your effort

Hi Sam, if you could give an indication when the 3d functionality can roughly be expected it would be very helpful as requested by querty1000. I personally have no idea when I can watch 3d movies with this great piece of technic. Really appreciate your support and help!!

1 Like

I don’t have a firm ETA, sorry.
My wish (and this is purely speculation) is for mid September.

There is a lot of work behind the scenes and we keep moving forward.

Sam

4 Likes

Sam, I’m new here and have never even seen the OSMC interface before yesterday when i installed it on a Pi3B. It worked great for me…similar to LibereELEC, but with less tweaking required to get 3D-MVC to work. Basically none actually. I actually didn’t even see many of the settings I saw in the LibreELEC build. I am running it through a Denon Atmos/DTS-X capable receiver to a 1080, 3D projector and t just worked. Awesome!

I also want to say that your support seems to be great based on the threads I have seen. Thank you for that! Not all products have the actual developers in the forums!

However, I just purchased a Vero-4K yesterday in my never ending quest for a box that can “do it all” and in reading this thread it is making me wonder if it is fully functional. Does it play 3D-MVC now or is it waiting for a new build to work fully? Things like “version of Kodi” or other behind the scenes things are beyond my knowledge. frankly, i hate Kodi and even on my Pi OSMC install I immediately installed the “Plex for Kodi” add on and use it that way. I simply tolerate Kodi because it’s the only non-proprietary platform that will play 3D-MVC that I’m aware of at all.

Will this Vero-4K be fully functional when I get it in playing 3D of any format I throw at it?

Thanks again for the cool stuff!

You need to follow this thread

1 Like

You just need to install the 3D MVC Kodi build and you will be able to play this content.

I have to wonder whether an OSMC device is really a logical choice for someone who hates Kodi. :thinking:

The short answer to that is “not yet”.

It is possible to play 3D material on the Vero, but only if you install a test version of the software. This isn’t difficult - instructions can be found in this thread, or you can just ask for more advice if you’re struggling - but the test version is likely to be a little less stable than the standard software in some other ways, and may get in the way of future updates in the short term; and while 3D playback in the test version works well most of the time, there are a few titles where it isn’t quite perfect.

Sam has said that the eventual aim is to introduce 3D playback to the standard software, but he is being careful not to make any definite commitments about when. Perhaps mid to late September, but perhaps not.

This is very much speculation on my part, but it is possible that the maybe-in-september-if-we’re-lucky version will still have some slight playback issues on a few 3D titles. We’ll see.

EDIT: I don’t know if using a Plex server as a file source would cause any problems in 3D. I’m general, probably not, but I know Plex does some weird things with subtitles - I wouldn’t want to promise that 3D subtitles will work correctly from a Plex source. I mean, they might well work, but I’d advise checking.