[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

I’m also having a problem with the Harmony. Right now my harmony select/ok button doesn’t work. All others seem to be working fine.

This is a known issue with the current test build. Fixes for it are currently being worked on and I expect them to be in the next test build.

1 Like

Thanks, in haste, I did. Fixed by re-running commands.

Re: making it intentionally difficult to assess test builds, I hear the reasoning, but one can make a compelling argument the other way as well. nVidia with Shield TV, Zidoo, etc. all provide ways for anyone to test beta builds of f/w or s/w releases. One shouldn’t have to be a command-line expert to assess the functionality of a media player, and still offer valuable inputs as an A/V expert. Just my 2 cents.

1 Like

We normally do make it easier. But this is an invasive set of changes and we need a high level of signal to noise and good quality testing.


So far so good for me but I have the issue that I can’t find the button that brings up on screen stats… dropped frames etc ( using 4k+ remote)

It used to be the 3 line button pressed twice during playback I think

1 Like

Long press the Info button, then click OK before you close the info screen.

1 Like

Thanks that’s exactly what I wanted to know :relaxed:

I’ve updated both a Vero 4K and a Vero 4K+ and have run into no issues so far (I’ve subsequently had a few HDMI-CEC issues on my older LG OLED, but I don’t think that’s related to this update, and the newer TV is working just fine with CEC controls).

I’m getting occasional jerky playback while watching an NTSC DVD remux of Star Trek: Voyager in software mode. I tried capturing some logs, but after the necessary double reboot, playback was mostly smooth, so there may not be anything useful in here:


I suspect it’s going to be a pain to reproduce this. :confused:

2 posts were split to a new topic: Network issue with new device using previous backup

Happenes again. Left my Vero 4k on overnight with TV off. Switched on TV and no display again. Reboot doesn’t work but @tanio99 's advice to leave it on for a longer time worked.

My question: Anyone else experiencing this? Or is it just me?

I’m rather busy this week. I’ll come back to you next week.

1 Like

Just bumping this, 4.9 Buster still has noticeable VC-1 video stutter. My test material is direct mkv import from blu-ray 1080/50i source. The stutter is not there on 3.14.

Also, I still find that a Pi with hardware playback and user-selected disabling of deinterlacing beats the Vero for resolution on native progressive material that has interlaced encoding.

Those that reported issues with LIRC / IR remotes should be able to update again and find the issue resolved.

Tested on Buster… working thx :slight_smile:

Tested on Vero 4K+ and working. Thanks!

1 Like

I can confirm LIRC is now fixed on mine as well. Thanks!

1 Like

I have found a problem with 3D Frame Packed output and 3D iso files that are encoded with VC-1 3D codec. I have the 3D Version of Clash of the Titans, and on playback with this upgrade, the 3d movies starts out okay, but any further command (such as chapter skip or restarting the movie) is executed only after a 40 to 50 second delay. Other NON-VC-1 3D files play fine. Has anyone else seen this problem?

Logs available at https://paste.osmc.tv/ihuqohupah

I’ve seen a very long pause after skipping on both “Avatar” and “Valerian and the City of a Thousand Planets”, but only when playing from an ISO, not from an MKV. Not sure if that’s the same issue.