[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

@CaptainMoody I tried my reproducer with “Lock HDMI HPD” either on or off, it doesn’t change anything.

Sorry to get your hopes up.
Did you reboot after changing the setting?

Yes, I did. Thanks for the suggestion though!

Well after changing that setting and three solid days without a single drop out on live or recorded TV we’ve had so many tonight we’ve given up and watched Netflix :thinking:

Some new logs showing this would be helpful

Since version 19 I experience issues with Bluetooth, only for putting the device on from suspend. The mentioned article below gives “G” the toggle command to put it into suspend and to take it off. I first thought it was an upgrade of the harmony app itself, although no firmware was updated on the device itself. After the update to version 20 of 4.9 the issue remains, so I took a better look into it.

It always worked, but since I got issues. I re-paired the device according the instruction and it worked again, only not for the activity to put it on. It seems that “G” or suspend is only working to put it into suspend and not take it out of suspend. I experienced several other things, but the only way to get it off from suspend is pressing OK.

As a workaround, i changed from 1 button to on/off (suspend) to 2 button and that seems to be working, although putting into suspend and then press OK leaves the power menu in front That could be worked away while pressing back, which can be automated as well.

Could there have been something changed with the Bluetooth info since version 19? If so, then we might change the procedure a bit. Maybe some others with Harmony are having the same issues?

Bluetooth hasn’t changed in the builds that you’ve referenced.

Just to clarify: are you using the suspend option in the power menu?

Sam

Ok, then it has to be something else, maybe something in Kodi

Yes, I use suspend from the powermenu via the mentioned command in the article.

meanwhile i have a workaround:
start : to resume from suspend I added the commands OK followed by BACK
stop : “G” to put it into suspend

On other devices there also was the problem to correctly power on or off the box over blutooth. I also have an Odroid C2 that is not able to power up by blutooth. I think the problem ist that the box does not power the blutooth while it is powered off. Also there was no ability for a wake up on blutooth feature. At first I also tried to use the suspend function and tried to turn it on and off by a power toggle. The problem was, that the harmony has no option to really scan the actual power on or off situation. So if the device got to sleep or powers down for some reason, the Harmony powers it off instead of on.
The only satisfying way was to combine the RC6 Infrared profile of the harmony with the blutooth profile. So I was able to combine the best of both.
I use Blutooth to control the system. There is no lag with blutooth and it is overall way better than IR. Also I programmed the power on and off of the RC6 Windows MCE Kodi Remote start and stop the device. There is no wake on blutooth but a wake on IR. So you do not have to use the suspend mode with power toggle.
I will try this workaround with the Vero 4K+. I´ll tell you if that works. Could be a usable workaround.

Edit: tried it. The Vero 4K+ does not seem to have a wake on IR feature

The mentioned procedure worked for nearly 1,5 year.

I’ve managed to create the workaround to get it back working, so step 4 in the powertoggle part does include seperate command for resume from suspend, which pressing “OK” seems to establish. But the original procedure was better the same button-press. But i guess something has been different in kodi with that Bluetooth command sending the second resume/suspend.

Both BT and IR wake up are possible, but would require some bootloader changes.

We recommend you use the suspend mode instead.

Yes I remember the wakeup for the odroid C2 was possible by bootloader modification. I will use the suspend mode instead. By the way, I tested this improved video stack build for Vero 4k+ for some hours now. I am very happy with it. In my case (Panasonic Plasma TV and Sony Projector) it works like a charm with 3D.MVC. Until now I could not find any file that is not playable on my NAS. I´ll will continue testing and will write here if I find something odd. Thanks for all your hard work. You made my Kodi experience much better with this.

Is that a default key mapping? I am sure it was an unassigned key when I was looking for a key to use for a reload skin command…

No, in this case the key G of the Bluetooth remote is mapped to the system command “suspend” . You have to modify that in the key map file or use an addon to connect the key to the function. Normally G is unassigned.

1 Like

Ok. That’s what I thought. The convo was indicating to me at least it was a default mapping.

See the mentioned article, it lead you step by step.

Having problems with old 3D MVC movies that don’t appear to use the full 1920 frame and have black bars down the sides. I think this is causing it as other 3D MVC videos play fine in stereoscopic for me. Player says it is “side-by-side” when the picture is wrong, but playing one that works it says “hardware”.
Problem video example mediainfo GeneralUnique ID : 1288115069031668766347211299 - Pastebin.com
Image displayed is Pasteboard - Uploaded Image
Log https://paste.osmc.tv/gehiduvoso

Sorry for coming back to you a bit late. I’m currently looking at that issue and I can reproduce it. Is this the only video showing that issue? If not, can you upload logs for the others (2 or 3 would be enough)? I don’t need the videos, just the logs.

The issue happens randomly, usually every day, apparently when the video stream from Tvheadend is corrupted (most likely because the TV signal gets corrupted). The video I uploaded was a recording from Tvheadend when such a corruption occurred.

I’ll send you logs whenever the issue occurs again. Thanks for investigating!

That’s exactly what I’ve suspected. Just send me the logs when it happens again. Thanks!