[TESTING] Vero 4K / 4K + video improvements


No. I get only one skip but I think it was because I had a dodgy cluster on my disk at one point.

Is it being rendered at 4kp60Hz?


Defo not continuous, they occur when i bring up the info box to find out if they’re occurring which i assume is normal, but even if i don’t do that i normally get one or two of them through playback.

The v4k+ says 4kp60Hz, the TV is a LG c7 and doesn’t have detailed info but its being picked up as 4k HDR and bt.2020

Also just to note this is literally the only file i’ve noticed such skips on


I’m facing a strange problem with latest kernel (121): everytime I reboot the system (for example after an update, or with sudo reboot), everytime a 4K@24hz movie ends and automatically the system goes back to the GUI, a black screen appears with “no signal or input” message from the TV. I don’t have this issue if I shutdown the system and start it again. The system is perfectly reachable through SSH session and responds to every command (that’s the way I’ve rebooted it).
I’ve highlighted every supported mode in the whitelist and I’ve set 4K@60hz as GUI resolution. I think it could be something related with the automatic frequency/resolution switch, that’s my guess. I’m going set the GUI to 1080@60hz just to see if something happens. If not, I’d restore to default my system before any further test.


Known issue. Please set your GUI to 1080p until we can track down what’s causing this.


Thank you grahamh!


@grahamh As mentioned in the other thread here are my logs showing that I still have banding with your kernel (installed from post 127 of this thread), but have no banding with Sams kernel (installed from 1st post in this thread)

My equiptment is Vero4k+ > Denon x2400 > Phillips 65PUS7601.

Sams kernel = https://paste.osmc.tv/urasaqeput
No banding on 4k HDR files.

Grahamh kernel = https://paste.osmc.tv/utapatuzes
Banding on 4K HDR files.

I did NOT enable HDR auto switching in Kodi settings
Test clip is a file called “The world in 4k HDR10” that is a 60fps clip.
I also tested several 24/23.976fps 4K HDR Movies and they had banding on your kernel (Sams kernel was ok), but for the sake of clean logs I didn’t include those in these test logs.
I have enabled a 2 sec pause on display switching for preference (don’t like audio starting with no picture)

Hope this helps.

I am now switching back to Sams kernel on the 1st post as it works 100% of the time with no banding.


Oppps Hang on……

I have just checked what kernel I am on and it says,

Linux VERO4K 3.14.29-119-osmc #1 SMP Wed Sep 5 19:09:21 UTC 2018 aarch64 GNU/Lin ux

I should still be on your Kernel !!!


119 was in staging. The wget gave you a different kernel numbered 119. Then staging was bumped to 121 with futher tweaks.

The log you describe as Grahamh kernel is the first 119 (Sept 5th).


ok can you please post instructions on how to get to the 121 kernel, I followed your instructions in post 127 and obviously it didn’t work :frowning:


something like

sudo apt-get install --reinstall vero364-image-3.14.29-121-osmc


osmc@VERO4K:~$ sudo apt-get install --reinstall vero364-image-3.14.29-121-osmc
Reading package lists… Done
Building dependency tree
Reading state information… Done
Reinstallation of vero364-image-3.14.29-121-osmc:arm64 is not possible, it cannot be downloaded.
The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


cat /etc/apt/sources.list?


osmc@VERO4K:~$ cat /etc/apt/sources.list

deb http://ftp.debian.org/debian stretch main contrib non-free

deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free

deb http://apt.osmc.tv stretch main

deb http://apt.osmc.tv stretch-devel main



Checking with Sam. Something’s not right.


Ok, so its pretty clear here that I never actually had your 121 kernel installed in the first place.
Sorry for the wild goose chase !!

Look forward to testing it if/when I can get in installed, in the meantime I will go back to the 119 Kernel as I can install that one easily.

Thank you


Just checking - did you sudo apt-get update before that reinstall?


I just copied the whole line as you posted it.

sudo apt-get install --reinstall vero364-image-3.14.29-121-osmc

I’m quite sure its me who had done something wrong here, that’s why installing Sams 119 kernel works as its just all copy/paste and job done, no assumed knowledge !!
I am a very basic user here !!!


yes, but issue sudo apt-get update first to refresh the apt cache.

Sorry, I took you for a power user :wink:

Having said that, if you did follow post 127 first it should have worked so lets see…


:joy: Give me 2 mins and I will redo it all now I have the knowledge !!


osmc@VERO4K:~$ uname -a

Linux VERO4K 3.14.29-121-osmc #1 SMP Sat Sep 29 05:20:26 UTC 2018 aarch64 GNU/Linux

So it looks like I finally go the 121 kernel installed, however sadly I still have banding in some of the 23.976fps 4k HDR movies.
The 60fps test clip seems ok however.

logs inbound


If you could list the names of the files you played, we can find them quickly in the logs.

ie: which worked and which didn’t.