[TESTING] Vero 4K / 4K + video improvements




:roll_eyes: Oh No !!!

Basically I need to be able to use 10bit 4:4:4 to get no banding, any time I set either 8bit/12bit and 4:2:2 I get banding


Thanks for sticking with it. That’s been very useful. Stick to 119 then and we’ll at least build in an option to block 422 output if we can’t run that issue to ground.


Ok no worries, thanks for your help and patience with me


Another thought: have you tried all the HDR Picture styles and whether HDR upscaling has any effect?

And I can’t recall if you tried without the AVR.


Do you have another TV to test with temporarily?


@Grahamh Yeah I’ve done all that in the past. It can’t fix banding, some HDR modes it looks worse than others but it’s always there.

The reason I got my first Vero4k last year was because my Shield TV had banding.
The Vero4k didn’t band.
At some point early this year an update introduced banding and I was one of those users that had to force 10bit output in the rc.local file (or something like that) to remove it again.

Same thing when I got my Vero4K+, so I was delighted to see that the 119 Kernel removed it with no input needed from me.

My setup must be very susceptible to banding, probably my Denon AVR idk.

As I mentioned earler I need to disable “allow 4:2:2” in my XB1X settings otherwise that bands in 4kHDR games and Netflix.

I’ve not had chance yet to retest my Roku+ but I’m sure best results come from 4:2:0 mode and not 4:2:2 mode.

My Phillips TV is set to Ultra HDMI mode 4:4:4/4:2:2 on HDMI 1 (the one connected to my AVR) if I recall correctly setting it to 4:2:0 mode results in HDR mode not engaging on my XB1X .

The Denon is set to ‘bypass’ so no picture processing occurs and it is also set to ‘HDMI Enhanced’ which is the mode which allows10bit 4:4:4/4:2:2/4:2:0.
Setting it to ‘HDMI standard’ limits it to 8bit modes and as I recall again means that HDR mode doesn’t engage in my TV

I tested all these modes extensively in the past

I’ve not tested without the AVR yet no. It’s going to be fiddly.
I do have another TV to test but I’m not sure what that would show us ?


OK, I think we need something similar then.


Why don’t we add a colour space option?
We can make ‘Auto’ the default but provide an option to force a different colour space.

Auto doesn’t set any attr, but a manual selection does.


Or a selection of colour spaces that are allowed like with video modes in Kodi 18.
Makes it abit more universal and probably helps those with a projecter etc.


Quick update I have just ran all the tests without my Denon AVR in the loop.

The results are exactly the same.

Only 4:4:4 10 bit mode doesn’t band - all others showed the same results as when connected via the DenonAVR.

Further to this I set my TV’s HDMI mode to 4:2:0 and re ran the tests just to check.
I had banding again and when checking found that my output was limited to 4:2:2, I am unable to set 4:4:4 mode when TV is set like this it just wont apply

So i’m back to where I was basically.

Anyway thanks to all for your input, I will be sticking with Kernel 119 for now as it works a treat. I have also confirmed I have my TV in the correct HDMI mode and that my AVR isn’t the cause of my banding (things I have often wondered)


I have played with my new Vero 4K+ for a few days now and installed the 121 build

osmc@Vero4Kp : ~ $ uname -a
Linux Vero4Kp 3.14.29-121-osmc #1 SMP Sat Sep 29 05:20:26 UTC 2018 aarch64 GNU/Linux

I have a LG C8 with an Onkyo TX-NR646 AVR. I have no issues when watching UHD files.

The Martian looks great for me. To make sure I know what banding looks like, I forced to 8-bit with echo 4228bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr. That resulted in very clear banding.
I confirmed that it was displaying 8 bit with: cat /sys/class/amhdmitx/amhdmitx0/config

After rebooting the device, the banding in The Martian was gone again.

Even with no banding, my AVR displays the input as 24 bit. With a 60fps clip (The World In HDR 4K Demo), it displays 30 bit. But I have read in this thread that the AVR is most likely incorrect.

My TV can also display info about the input. Notably about The Martian it reports BT.2020 whether I forced 8 bit or not. So the TV is incorrect as well.

I thought I gave you my feedback. Build 121 is working perfect for me up to now.


Are these tests built into the Leia beta builds or do they have to be installed as well?


If it helps anyone I’ve test both the 119 and 121 kernel, my Vero 4K+ is connect directly to my Sony KD55XD8005 TV.

I’ve tried various HDR test clips including SLICKRIC21’s Martian clip and both kernels play fine without any banding. The 119 kernel reports the colour space as 444 and the 121 kernel reports 422.


If it’s useful my setup: Vero 4k (not+) > Marantz SR7011 > Samsung UE55KS7000
(with Premium Certified HDMI Cables: https://www.amazon.co.uk/gp/product/B01MDTOA8R/ref=oh_aui_detailpage_o06_s00?ie=UTF8&th=1 )


Linux osmc 3.14.29-119-osmc #1 SMP Wed Sep 12 21:28:17 UTC 2018 aarch64

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
PQ colour range: limited
audio config: on
3D config: off

My Amp reports:

and with:

Linux osmc 3.14.29-121-osmc #1 SMP Sat Sep 29 05:20:26 UTC 2018 aarch64

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV422
Colour range: limited
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

My Amp reports:

and with:

Linux osmc 3.14.29-119-osmc #1 SMP Wed Sep 5 19:09:21 UTC 2018 aarch64

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
cd = 4
cs = 2
audio config: on
3D config: off

My Amp reports:

With all three the TV reports:

These are all with SLICKRIC21’s Martian clip.

I get banding on 121. I don’t on the Sept 12 119 (I can’t recall if present on the earlier one sorry).


Thank you. We clearly need to have to have an option to force 444 pixel format.

Could you please post cat /sys/class/amhdmitx/amhdmitx0/rawedid in case there’s something we can hook onto in that to switch to 444 automatically.


On Linux osmc 3.14.29-119-osmc #1 SMP Wed Sep 12 21:28:17 UTC 2018 aarch64 that command returns:

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/rawedid

This is on Krypton OSMC 2018.08-2 btw, during the martian clip once more.

Do you want the output with the other kernels?


That’s fine, thanks. The EDID should not change between kernels.



I have problems with my Pioneer VSX 932 receiver on VERO 4K Leila builds.

I can’t use 3840x2160p 60Hz and 3840x2160p 59,94Hz resolutions ( I try to change it in Settings–> Display)

My receiver tries to swith but with no result :frowning:

Maybe someone with this or other receiver could check this and give me some feedback.

Bes regards


Did you whitelisted the resolution (that’s needed in Leia)?
Also it is recommended to keep GUI on 1080p and enable “Adjust refresh rate”