[TESTING] Vero 4K / 4K + video improvements


Settings->Player->Videos->Adjust display refresh rate.

Settings needs to be set to at least Standard at bottom left to see that option.


With “Adjust display refresh rate” set to “On start / stop” there is NO banding, in 1920x1080p 50Hz and also in 3840x2160p 60Hz.

When I reset back to “Off” the banding is there again.


That’s the expected behaviour… Set to “Off”, there’s no HDR, colorspace, chroma or bit-depth switching happening either.


Not true for HDR. I get HDR switching with that setting off as well.

First time I’ve heard anyone mention that setting related to banding on these forums.
If it really is expected, why would that setting not be enabled by default ?


I have hdr autoswitch on and it enables hdr on tv. I have changed hdmi cables from vero to avr and from avr to tv and still have banding. What I noticed is that like 1 of 20 times it works ok, always with refresh screen rate on start/stop. On Xbox X i never noticed banding on hdr games through same avr. What is the fix to try from shell? I have read too many threads, many old and this new and dunno what to test.

Btw tv says its 2160p HDR bt2020


AFAICT the banding you are getting here is because the output is 8-bit. For me it is very reproducible with Vero plugged into the TV but oddly not when playing through my AVR - with that I get no banding. We have been working on getting 10-bit autoswitching with first the HDR autoswitch setting and now this testing kernel.

ATM it will autoswitch as long as the video is being played at a different resolution from the gui, so with the GUI at 1080p60, 4kHDR should autoswitch, but playing 4k to a screen that only supports 1080p means it might not switch refresh rate or bitdepth.

Thanks for your feedback.


Is there some setting that changes the UI resolution, but not the video playback resolution ?

When I switched to 1920x1080, I did it in Settings->System->Display.
When I then play the 4KHDR10 video, the video is also played at 1080p, not 4k, and banding is still there (Adjust display refresh rate=Off).


Tested kernel from first post and worked perfect 5 of 5 tries. Seems working ok for me


Sam just Emailed me and suggested that I test this Kernel to fix a problem I was having with setting 10 bit HDR output from Vero 4K+ not being persistent. With this new kernel installed it seems that my problem has been solved. I will continue to do testing.


Glad to hear this.



I’d just like to report that my problem with LiveTV stuttering was not related to this test kernel. After reverting I still had the same problem. After reading other threads on this forum I played around with a few settings. Specifically I have set the H/W acceleration to ‘always’ for all codecs, switched off the fallback framerate in PVR settings, and set “Adjust Display Refresh Rate” to always. Things now seem better - I occasionally get a brief stutter when starting a channel, but after that the stream seems to stay pretty stable.


This needs to be on start/stop or always for videos to play at a higher resolution than the GUI.


Yes, just tested, with Adjust display refresh rate=On start / stop, the video plays at 4k while the UI is 1080.


Tested the new Kernel briefly yesterday on an up-to-date Vero 4K but reverted more or less immediately due to audio (passthrough to AVR) completely missing.

A known issue for the test Kernel or something dumb on my side probably?


I’ve been running this test kernel for a few days now and had no issues whatsoever so far. Switching between 1080p 8bit SDR and 4k 10bit HDR works flawlessly so far and all audio is getting passed through to my AVR as well.


Thanks for your continued work on this Sam (and team!). Just thought I’d confirm that this kernel resolves banding issues I was having on my Panasonic OLED with a remux of the 4K HDR release of ‘The Boss Baby’. :grinning:

EDIT: On closer inspection, I’m having a few issues - see post below.


Edit: How do I disable this? I do believe I had this enabled previously.


Did you edit rc.local?
Did you enable HDR autoswitching?

If it looks good now, you’re fine.


Yes, I followed instructions in a previous thread months ago and edited rc.local for 10-bit - having this edited, would it cause issues? HDR auto-switching is disabled.

Actually… something isn’t quite right post-kernel update. My TV is now reporting 10-bit files (as reported by MediaInfo) as 8-bit - previously they would be correctly reported at 10bit. And on closer inspection banding is now definitely present whilst playing the remuxes of the 10-bit 4K HDR files for ‘The Boss Baby’ and of ‘Blade Runner 2049’. No banding was present previously when the TV correctly reported the files as 10-bit.

I’m guessing this is because of it now being seen as 8-bit, and not 10-bit, by the TV?


Reverting back, as per instructions in the original post, and 10-bit files are correctly reported as 10-bit by TV and banding is gone.

One issue remains though, All 8-bit SDR files are reported at 10-bit by the TV. Odd.