Transmission Access Denied

I’ve read the few threads about the 403 error trying to access the transmission client thru the web, I’ve edited the settings.json file, nothing works. So I’ve either edited the wrong file or I don’t know what’s wrong.
The settings.json file I’m working on is at /home/osmc/.config/transmission-daemon/Settings.json

Is this the right one?

Here’s the file itself…

    "alt-speed-down": 15,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 15,
    "bind-address-ipv4": "",
    "bind-address-ipv6": "::",
    "blocklist-enabled": true,
    "blocklist-url": "",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "/media/NASDRIVE/Torrent_complete",
    "download-limit": 100,
    "download-limit-enabled": 0,
    "download-queue-enabled": true,
    "download-queue-size": 5,
    "encryption": 1,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/media/NASDRIVE/Torrent_inprogress",
    "incomplete-dir-enabled": true,
    "lpd-enabled": false,
    "max-peers-global": 200,
    "message-level": 2,
    "peer-congestion-algorithm": "",
    "peer-limit-global": 240,
    "peer-limit-per-torrent": 60,
    "peer-port": 51413,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": true,
    "preallocation": 1,
    "prefetch-enabled": 1,
    "queue-stalled-enabled": true,
    "queue-stalled-minutes": 30,
    "ratio-limit": 2,
    "ratio-limit-enabled": false,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "",
    "rpc-enabled": true,
    "rpc-password": "{46949fbf39bfeec6dc9d4bff9f40c3f52219a4260yk9yGNo",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "transmission",
    "rpc-whitelist": "*.*.*.*",
    "rpc-whitelist-enabled": false,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",
    "seed-queue-enabled": false,
    "seed-queue-size": 10,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": true,
    "umask": 7,
    "upload-limit": 100,
    "upload-limit-enabled": 0,
    "upload-slots-per-torrent": 14,
    "utp-enabled": true

Any ideas?


I did that, no difference. I can start and stop the service, but I’m not sure it’s reading the file. I’ve made a few changes, but no difference. Is the settings.json file I’m working on in the right folder?

Depends which user the transmission daemon is running as. If it’s osmc then that’s the right file.
ssh into your pi and run ps alx | grep trans
You should get two lines of output, one for transmission and one for the grep command.
The second number on each line is the user, in my case both are 1000 so grep and transmission are both running as osmc.
You might be running as root, or transmission-daemon. The ps command will tell you which.

I’ve got 1000 on both lines.

So transmission-daemon is running as osmc.
Does it load the right file if you run transmission-daemon from the command line (as osmc) or maybe try adding
-g /home/osmc/.config/transmission-daemon
to the command line to force it to look for the file there?

tried sudo systemctl start transmission.service -g /home/osmc/.config/transmission-daemon/ and I get invalid option… probably not doing this right…

sudo nano /lib/systemd/system/transmission-daemon.service
and add the -g /home/osmc/… on the end of the ExecStart line

That file appears to be empty. I did the sudo nano /lib/systemd/system/transmission-daemon.service and it’s empty, nothing there. Come to think of it, the first time I edited the Settings.json file for transmission, that one was empty too…

Sounds like you don’t have a full installation. Where did you install from?

From the app “store” within osmc.

1 Like

Ah, in the app store version the service file is called transmission.service (different to the debian jessie version, don’t know why) so
sudo nano /lib/systemd/system/transmission.service
and add -g /home/osmc/.config/transmission-daemon/
to the end of the ExecStart line

OK, weird thing. Stopped the service. Did as you wrote, found the file, added the string at the end even though there was already something there (–logfile or something…) And then exited. Still didn’t work. I get the same error. And now, when I sudo nano /lib/systemd/system/transmission.service… there is nothing there anymore. It’s empty. I guess I didn’t edit or save properly? Or I didn’t add the string correctly…?

Might be worth removing transmission and starting again, something wierd going on.
sudo apt-get purge armv7-transmission-app-osmc
and then reinstall with
sudo apt-get install armv7-transmission-app-osmc

you should stop transmission then edit Settings.json and then fire it up again :smile:

sudo systemctl stop transmission
Edit the settings.json
sudo systemctl start transmission

oh btw
its not



(beware of little s and big S in settings.json)

Allright! Finally got it working. I purged and then re-installed, not thru the store though…dunno if that was the issue… Might have been the big S little s too :smile:
Now if I can find a way to get flexget on it… or to setup a watch folder…
Thanks everyone!

(Added: Nevermind, just found the watch folder setting…works…now flexget…)