Transmission and Sickrage doesn't run at machine startup

Hi,

You probably have more success over at the sickrage forums, good luck.

Just out interest what prevents you from reverting the ownership of sickrage folder to pi:pi

sudo chown -R pi:pi /opt/sickrage

and starting the sickrage as pi:pi

User=pi
Group=pi

?

Thanks Tom.

1 Like

I installed sickrage in 15 minutes and it worked with just one extra line. I followed the instructions on the thread I linked to exactly. I didn’t try to change one thing, and it worked first time. It starts at reboot and I can access the web interface.

Instead, you did not follow the instructions in the thread exactly. You have created a new user, sickrage. You have placed your files in /opt. You did not use the correct ExecStart line until Tom suggested it to you. There are probably other things I don’t know about. And you don’t seem to have read the logs, since I’m sure there will be some kind of error shown there.

Sorry about that. I had reasons for doing that. First, the user was created some months ago, with the first install I did following the intructions of this forum. Second, I choose that directory because I have Transmission and Couchpotato there (as this instructions says) and I’m trying to get things ordered. I used the correct ExecStart the first time I try it, but it did’t work. I just try it AGAIN when Tom mention it and it worked, srprisingly, I don’t know why. There is a lot of variables I’ve been changing during the process. And I don’t know what logs must I to read. If you beleave I can access some logs, please, just mention it.

Further more, I change de user and other things ONLY after the default installation with your settings was tested unsuccesfully. After get the same timeout error, I decide to come back to /opt/ because reasons exposed.

Further more, When I see that your service have osmc:osmc, I think, obviously, it should be changed in a Rpi without this groups and users.

I was doing all my best, all my effort trying to follow your recomendations, as can be seen in this thread. If it is not enough, sorry, is my best. At the end, trying to not abuse of your time and help, I went to SickRage forum and kindly I said good bye.

This settings returns the timeout error at reboot. Thanks again :slight_smile:

Hi,

systemctl status sickrage.service & journalctl -xn will give you more info.

Also as dilthedog suggests, I would follow the thread provided and install sickrage to /home/pi/.sickrage and revert to provided systemd unit file, with the 1 line suggested change.

[Unit]
Description=SickRage Daemon
After=multi-user.target

[Service]
User=pi
Group=pi
Type=forking
GuessMainPID=no
ExecStart=/usr/bin/python /home/pi/.sickrage/SickBeard.py -q --daemon --nolaunch --datadir=/home/pi/.sickrage

[Install]
WantedBy=multi-user.target

I’ve added dilthedog’s suggestion to the unit file:

Thanks Tom.

1 Like

Thank you for the abstract. Tryed again, following exactly the steps in the tutorial linked, I get timeout error when I do explicit command sudo service sickrage start. In order to be completely clear: I skip two first commands (install dependencies) because I performed them yesterday.

The terminal ouput of the process is this: Sickrage Install - Pastebin.com

Including a systemctl status sickrage.service and journalctl -xn at the end.

In this output can’t be seen sickrage.service setup, but it is exactly (copy pasted) as yours in the previous message.

Unless better idea, my next step will be a Raspbian + Sickrage installation from scratch in a new SD card.

Hi,

grep sickrage /var/log/syslog

may provide more info.

Thanks Tom.

1 Like

Not much:

May 28 07:58:50 raspberrypi systemd[1]: Configuration file /etc/systemd/system/sickrage.service is marked executable. Please remove executable permission bits. Proceeding anyway.
May 28 08:00:31 raspberrypi systemd[1]: sickrage.service start operation timed out. Terminating.
May 28 08:00:32 raspberrypi systemd[1]: Unit sickrage.service entered failed state.
May 28 08:33:47 raspberrypi systemd[1]: sickrage.service start operation timed out. Terminating.
May 28 08:33:48 raspberrypi systemd[1]: Unit sickrage.service entered failed state.
May 28 12:11:20 raspberrypi systemd[1]: sickrage.service start operation timed out. Terminating.
May 28 12:11:20 raspberrypi systemd[1]: Unit sickrage.service entered failed state.

I’ve removed executable permission bits with

pi@raspberrypi:/etc/systemd/system $ sudo chmod 644 sickrage.service

with same results (timeout).

That’s your best plan. Your system clearly has some extra “baggage” that is causing problems.

I just installed Raspbian onto a fresh SD card and then installed Sickrage. It all works 100%.

http://paste.osmc.tv/pocanotuza.vhdl

1 Like

In conclusion to this thread I would like to post my last research:

To install Raspbian from scrach and Sickrage (nothing more) in a Raspberry Pi1 results in a timeout issue.

To instal Raspbian from scrach and Sickrage (nothing more) in ANOTHER Raspberry Pi1 (maybe the first was defective) results in a timeout issue.

To install Raspbian from scrach and Sickrage (nothing more) in a new Raspberry Pi3 work without problems.

So, it seems that Rpi1 have no enough resources to run Sickrage.