Troubles with huge file playback/cache?

Hi I have just hooked my server from a powerline LAN to a Gigabit Cat7 Lan and tried to stream UHD content (2 > 60 gig files).

While one of the files streamed pretty decently, the other one began to stutter after a few minutes. The first file is 64gig and the second is 71gig. This should not be a problem with a GB-Ethernet, should it?

I have noticed that there is no “grey part” of the progress bar, which I think means that there is no cached content.

I have read in the forum that Vero4K has an optimized cache already, but is there anything I could tweak in the settings?`

Would you require a log?

Thanks as always

Georg

You just need to make, or add to .kodi/userdata/advancedsettings.xml with

<advancedsettings>
    <cache>
       <buffermode>0</buffermode>
    </cache>
</advancedsettings>

to make Kodi return to its normal cache behavior for local files. If you want you can also add “<memorysize>” and “<readfactor>” arguments if you wanted to override those.

Should also be noted that even with Gb power line adapters, its extremely unlikely you’ll get anything close to Gb speeds.
They can vary greatly, only way to properly test is iperf3 and see what speeds you’re actually getting in the real world.

I only know this because I learnt the hard way, and in the end pulled cat6 everywhere I needed it.

that is what I did. cat6 it is. how do I do the iperf?

ssh to the vero and then in the commandline iperf3? do I need arguments or a server (I know I should “man” :-))

Thanks

Georg

There is a how-to for that…

You can try and mount the share by using autofs and see if you get better performance from that.
After you have mounted the shares you still need to add them to the library the usual way:
Add Source -> Root File System -> /mnt/xxxxx

Thanks, I know the advancedsettings.xml, I just think to remember that Sam once wrote that fiddling with the settings there will be somewhat counter-productive.

As for the buffermode tag, why would I not use “1” (buffer all filesystems) instead of “0” (buffer all internet filesystems)?

Thanks

Georg

1 Like

if you’re using cat6 where does the powerline come into it?

Just install iperf3 on the vero4k and on the server, then on one machine run:

iperf3 -s

on the other machine run:

iperf3 -c (IP address of first machine)

then flip the commands around to see the speed in the opposite direction, alternatively just add:

-R

to the end of the second command.

Some setups don’t cache optimally so the Vero is set by default to use a fairly large buffer. Setups will vary so it is a bit of a YRMV thing. Cache “0” will only buffer something like 20MB on LAN and for some setups that may not be enough. By using cache “1” it allows you to set your own for LAN traffic. the settings for “memorysize” is what essentially changes a ‘network buffer’ into a ‘video cache’ if set large enough. The “readfactor” is kind of confusing but is kind of like how many seconds of video do you want to pull from your network at maximum speed, with that being capped by the memorysize.

I had used the powerline setup, now I am wired.

However iperf3 only gives 94 MBit… Strange, as I was of the opinion that all my devices (including the hp Microserver 40NL) have a Gigabit interface.

The two switches certainly say they are gigabit, the router is gigabit, anyone has an idea how to find the device that is responsible?

Still, should 100 MBit not be enough for a a 71gig movie (2hr movie = 35Gig/hour?)

You’re on the boundary. Quick calculation: Let’s call it 36 Gig in 3600 seconds. That’s 10 MB/sec. There’s no bandwidth slack to fill up the buffer.

I can’t help with that buddy, although im sure one of the smarter networking folk on here will chime in with some advice.
It does seem to be the cause of your problem though, and saves wasting time with Kodi buffers and settings.

I know there was an issue with some of the early Vero 4k+ devices, although im sure that @sam_nazarko replaced all the faulty devices.

Most switches have lights that are different colors depending on their connection speeds. That would be a good place to start. With gigabit your wires use all four pairs. If you are missing any of the eight conductors then your connection will normally fall back to 100mb (which only needs two pairs). If you have new wiring you did yourself you may need to run some kind of continuity test on your work.

Since we don’t know your network configuration, it’s hard to give detailed advice.

If the Vero4K (I assume it’s a plus) is on a different switch from the HP server, move the V4K over to the HP server’s switch. Then run iperf3. If you get ~930 Mbps, work outwards.

Substitution is also a useful technique: try different cables, ports, even switches, etc.

You can also install ethtool, which should show you the state of the eth0 interface on the V4K.

First to avoid us running around chasing ghosts. Is your device a Vero4k or 4k+?

Secondly install ethtool and share the output.

Lastly 100Mbit are a corner case, but if you use autofs as described above it might be ok

Hi, sorry, no, it is an “old” 4k. I just checked the specs of the old one again :scream::hear_no_evil::speak_no_evil:

Sorry the 4K has only fast internet. I made a fool of myself…

Still, many thanks for your help.

I guess I’ll be buying a 4k+ in return (before brexit :smile: )

Well using autofs should still make that files play fine with 100 Mibt.

While surely @sam_nazarko would appreciate a new order of a 4k+

1 Like

Thanks

And how would I use autofs? Would I have to install that on my server (FreeBSD) as well?

Thanks again

Georg

No, no need to change server side just on the client as was pointed to you in this post.

A USB gigabit ethernet adapter may be a viable option as well.