Turn off ATV or not? How to properly do it?

I am very new to OSMC on ATV1 (been using it for only 3 days by now)… I can install OSMC correctly (I guess) and use Kodi within.

But something that has been completely blowing this experience away is when I turn off the machine (accidentally sometimes and sometimes not). For the third time I feel like I have to completely reinstall everything again because OSMC will simply not load (again) after trying to turn it back on…

From what I understand, it is essential not to mess up with the way one turns off the ATV and I have read the read here before posting.

So for this particular time, I did this:

  1. use the “Power off system” button from Kodi;
  2. wait until I see the “the system has been halted” message on screen;
  3. pull the plug or whatever.

Now I plug it again and wait for something to happen. But nothing happens, the ATV just blinks until the end of days; TV even displays “no signal”; I cannot even establish an SSH connection with the device.

So, what am I doing wrong? Can we, or can we not attempt to power off the ATV running under OSMC?

You are shutting it down correctly

Did you install OSMC on to a USB or the internal drive?

If it’s USB, try another stick
If it’s HDD, try USB

@sam_nazarko Thanks for the tips! (And thanks for confirming that I am not misunderstanding instructions).

In my case it is an HDD install of the 2016.01 version (I really tried other newer versions but for some strange reason, they all result in 1080p HD video streaming lagging behind the audio, this version seems to do the job properly). Is this version known for “shutdown” problems?

Anyway, I will try one last time on HDD, then switch to USB if it does not work…

Well, I have reinstalled OSMC HDD (2016.01). Have been purposely turning it off 2 or 3 times. The system even crashed once and had to savagely unplug and plug it back in; did the “read here before posting” thing. Been working fine for now, hope it stays that way for a long time now.

If it crashes, or you pull the plug, the /boot filesystem may not be mounted cleanly as rw. Run mount and check the mount options, if it is showing ‘ro’ then you will need to unmount the partition, run ’ sudo fsck.hfsplus /dev/sda1’ (assuming /dev/sda1 is your /boot partition) and remount it ‘sudo mount -o force,rw /dev/sda1 /boot’. Otherwise, any OS updates will not work, because the new kernel image will not be saved on /boot.


PS. Oh! I just saw this sticky post - more detailed and eloquent than mine above. :slight_smile: