Tvheadend and OSMC TV dongle on Vero 4K in ITALY

I’m not at the pc so i can’t verify but i think it was the REALTEK one after I tried the Sony one but with no luck
Wich is the correct one to select?

I checked and it is REALTEK RTL2832

THE found ONLY ONE channel in only one mux so I think that the tuner works.
Maybe the problem is the MUX list for Italy that is outdated/incomplete?
I can exclude an antenna problem considering that it is the same antenna and the same cable that
feed my TV with all the channels existing in my area.

Very likely. You may have to set up each MUX manually.

The Sony will give you DVB-T2 as well as DVB-T. You should disable the Realtek to use the Sony. You may have to manually remove the Realtek conf file to get that to work:

sudo systemctl stop tvheadend
rm ~/.hts/tvheadend/input/linuxdvb/adapters/*
sudo systemctl start tvheadend

Then enable only the Sony in the web interface.

Many thanks!!!
I solved with your command line and other instructions.
For the records the Italy MUX list is ok since all the channels are present.
Very clear also the linked post, I followed all the instructions but at the end on KODI interface of Vero 4K I don’t find how to start the Tvheadend HTSP Client interface…
Now I miss 2 things:

  1. I would like is to set the PVR to use a USB disk connected to Vero 4K
  2. I would like to setup an xmltv EPG source but I miss any howto source

Thanks a lot again

EDIT: I didn’t activate the TV on the KODI interface… now I can see it but when I select a channel there is the message: " TVheadend HTSP Client no free adapter available"

Try shutting down Vero and re-starting it to make sure the dongle is registered by USB before TVHeadend starts.

Your USB disk should show up under /media/. I recommend labelling the drive so that it’s easy to recognise. Then enter the path in the Recording tab in the TVH webui, eg


I’ve not used xmltv but others in here do. I think you just enable it in EPG Grabber Modules in the webui.

BTW, the DVB stick takes quite a lot of power so you should use a powered USB drive or a powered USB hub.

I’ve made a deep restart (unplugged and re-plugged vero 4K) but I have no idea how to verify the timing of the USB registration…

I don’t know how can I check the directories on Vero 4K … i mean how can I browse its content to see the correct naming to use…

Both DVB stick and USB disk are connected to a powered usb hub.

Thanks again for your support

It should just happen. Is the stick now showing up in the TVH webui and the tuner enabled?

You need to access Vero by SSH

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Then if you type
ls /media

you should see something like this (example from my TVH server)

osmc@vero4tv:~$ ls /media
  README  'Seagate Backup Plus Drive'

If you copy and paste that output here (from Putty, just highlight the text to copy it) we can advise what to do next.

this is the output
500gb_25 README

Yes and yes

Thanks a lot again!

Ok so just put
/media/500gb_25/TVRecordings/ in Recording System Path in Recording->Digital Video Recorder Profiles->(default)->Parameters in the TVH webui.

I see DVB-T2 is rare or non-existent in Italy so the Realtek tuner should work as well as the Sony.

Thanks for all instructions.
Now after a power on/off it worked but the vision is not fluid because there is like an occasional freeze frame during the vision.
Now after a restart returned the
“TVheadend HTSP Client no free adapter available” so it stopped working.

Any idea?

I can’t confirm this since in my case Realtek didn’t find any channel while the Sony one found 137 channels

This is likely to happen if the vero output resolution is different from the broadcast. I’m guessing your SDTV is the same as in UK - 576i. If you put 576p in your whitelist and let your TV do the conversion from that to 1080p or 2160p it should work better. If you can get logs grab-logs -A and post the resulting url here we can check your settings.

The logs might show us why that’s happening. To make sure the stick is properly initialised on a reboot it needs to be powered off then on. Try plugging the stick direct into one USB port of the Vero and connecting the USB hub with the HDD into the other.

Here the link

followed this direction so now I have:

  • USB1 of Vero4k → TV Dongle
  • USB2 of Vero4k → powered USB hub with → usb disk and → remote dongle
    For now no more “TVheadend HTSP Client no free adapter available” message.

Thanks. I suspect what’s happening is Vero is choosing 4k25Hz to play the TV stream. I recommend you set up a whitelist and include 576p and not 2160p25. Have a look here:

Thanks for the support but:

  1. Followed all the directions: it starts without errors but after a while freeze frames returns…
  2. Another very simple thing that i would like to do is to set some favorites but I didnt’ find a simple and quick way to do it…
  3. I would like to set an XMLTV EPG source for DTT but I have not found how to do it

Have look here

You can re-order the channels to put your favourites at the top of the list/EPG and there’s a ‘group manager’ (settings->Live TV) so you could make a group of your favourites.

Please turn on debug logging and get logs while you play a channel

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks but I don’t understand what I have to do… the “guide” start with:
"Enable the first line that says “Internal: XMLTV: /usr/bin/tv_grab_wg++ is a wrapper grabber around WebGrabPlus+
If you don’t see that line in tvh, its probably because the wrapper isn’t installed. It is easily created though via nano or whatever (needs sudo to write in that directory).”

I am stopped there…

I’ve never set this up. Maybe you should ask the people who have on the Kodi forum, or ask @narcisgarcia.

here the url

Thank you. First what I say above about 576p is probably irrelevant. The TV you are playing is all 1920x1080. You only need to whitelist 576p if playing SDTV channels (or DVD rips).

I can’t see anything in the logs to explain the freezes. But something odd - your TV streams have ac3 (Dolby) audio and you have enabled passthrough but the audio is being decoded in software. Have you maybe turned off passthrough in the OSD?

BTW you also need to turn off ‘TrueHD capable receiver’.