TVHeadend Few Issues

So I have finally set this up, 2 out of the 3 OSMC tuners works (need to check cabling just disabled it for now)

So ive been trying to set up xml EPG as a back up and to extend range as per the bellow

but i cant get this command to work “docker exec -it -u abc tvheadend /usr/bin/tv_grab_uk_tvguide --configure”

The next thing is how do you get the picons to work, the TVheadend is on one 4k box, but im streaming to another vero 4k in another room,it shows links on web page

I can record to default folder, but i want to record to external HD, ive tried putting /media/nameOFhd/thenFolderName, even setting file permissions but it cannot record to this path

Last thing is from kodi, is it possible to select “Top Gear” and record series and not individual, i know WMC could do this but only found this on web page for TVHeadend

Also in the below should these show as fail, i did manually force them to try again and could get all but the last one to OK?

Just rebooted the server and now nothing plays but i only see this



Have you installed Docker?

I’m not sure I’d recommend using Docker to install TVHeadend or an EPG. OSMC is a Debian based system so you can run those binaries natively. I suspect the Docker method is recommended for more minimal systems like LibreELEC.

You can do this in TVH’s web interface. Not sure about Kodi. All Kodi does is instruct TVH to schedule the recording via the API.

How’s the drive formatted? TVHeadend should give you some kind of error if the recording is failing.

Where are you in the UK? It’s possible that your muxes have changed. See [HowTo] Retune TVHeadend DVB for UK Freeview digital switchover for some guidance.

Turn off the Vero at the mains for a minute.
Boot again, and show us what TV adapters shows. You want to use the Sony ones rather than the Realtek tuners so you can tune in to DVB-T2.

I assume you’re using a USB hub hence you’ve connected 3 tuners. Is it externally powered?


No i havent installed docker didnt know what it was or recomended, just wanted to add that tvguide as a epg,

Yeah i was hoping it would be done through kodi, parents wont have a clue with webpages, on wmc u slick the program and theres record once/series.

The drives formatted to NTFS i can see it on laptop (thats USB stick i`ll be using untill i get another plug socket)


Near leeds so Emley moore, only

So its not like the Realtek are for normal digital and sony are for the HD channels?

Yeah so there connected

USB1 - 7 port belkin mains powered hub, 3 x TV Tuners, remote dongle
USB2 - USB Stick 32gb but will be external powered HD once i sort another plug socket

See Kodi/TVH Series Record - Tvheadend. It looks like it is doable.

I haven’t used a web based EPG in some time – I find the OTA EPG to be sufficient, but some others may be able to chime in. I’d avoid the Docker route.

You can format the drive with any format that the Vero can read and the laptop will be able to access it. I’d recommend ext4.

Not quite. Just select Sony for everything, and it will work.

The tuners are power hungry. Try removing one working one; shut down and boot up and see if the other one starts working. That would indicate the hub isn’t providing enough power. Also check the obvious like cabling etc.


Cheers Sam,

Tried turning Kodi off and on at the wall plug, but still sees same 3 realteks, i`ll try restarting hub, it was a cable that had come off as the coax cables quite stiff from the junction box, it either pushes a aerial out or the usb, going to get some small usb extentions to prevent it.

Yeah i thought the EPG would just be a case of add new but doesnt seem option to just add one

How would i go about formatting the drive to ext4 from terminal?

If you have already picked the Realtek tuners, you’ll need to clear the tuner cache and reconfigure TVHeadend.

The easiest way might be to just set TVH up again.

Do this:

sudo apt-get remove --purge armv7-tvheadend-app-osmc
rm -rf /home/osmc/.hts
sudo apt-get install armv7-tvheadend-app-osmc

Now pick Sony tuners when configuring.

Run sudo mkfs.ext4 /dev/sda on the Vero. Note: I’m assuming you only have one disk attached, and you’re happy for that drive to be formatted. No data will be preserved.

You will likely need to stop it from being mounted first. Run sudo umount /dev/sda1. It might be easier to format it on a PC with a LiveCD like GParted.


I did the lines then it showed


but on reboot im back to the 3 realteks

Ive formatted the drive and created the folders, what would i put in TV Headend for the folder


Does a shutdown bring the Sony’s back?
Might be an issue with reboots.

That’s what you’d put (as you wrote above)



will try when im next down stairs, does vero4k have wake on lan?

Unfortunately not.


That would have possibly changed during format. Actually easiest would be to give the drive a proper label, then it will be automounted under that label

sudo e2label /dev/sda recordings

Then reboot

Yeah i think the weird name was because it was just a USB stick, put HD on now and its working with correct labelling

I still cant get the picons to work though, is it because the client cant access the directory?

http: CLIENT IP : HTTP/1.1 HEAD /imagecache/37 – 404

Since im now only using the Sony controller, dont know if its that or something ive missed i no longer have EPG data for the HD channels, Ive seen i can map this manually to the SD ones but do i need to?

But on reboot of the Vero4k with the tv adapters, it either shows the adapters but when you select a channel to play, it says “no input source available”, or just shows the realtek adapter again.

unplugging the kodi and re powering gives same result, unplugging USB hub and reconnecting only works if kodi is also unplugged to get the sony chipset working again

Starting to suspect it could be power related.

Have you seen: Getting Picons Working in TVHeadend and Kodi - Jamie Jones


at minute i only have 1 tv adapter plugged into the usb hub

Yeah i tried to get my head round it, So where would file:///picons/%C.png be located


then i just add the icon files in there?

You can’t reference SMB paths directly from TVHeadend. If they’re stored externally, you’d need to mount a share in /etc/fstab first.

sorry sam, what i mean is is that where the folder would be, im just using smb as i can browse and drag the png files into there

Not using the SMB link in the TVHeadend “file:///picons/%C.png” thats what im using in tvheadend

Right, I see.

It’d likely be file://home/osmc/picons/%C.png


Cheers sam, It now displays picons in tvheadend, and rebooting kodi got them to update on there

So do you think its the USB hub thats not powering correctly (only 1 adapter on it)? OR when the kodi has done a reboot the hubs staying on so something doesnt come back?

Does the OSMC powered hubs do the same?

Sam, did you really mean to use sda and not sda1 for the mkfs? Not using a partition can freak out some disk tools on other OSes, though Linux shouldn’t care.

I’ve found that using partitions is always better than not using them, if only for my sanity.

It’s easier than walking him through using parted.