Unable to connect to Samba shares

what does testparm -v give you on OSMC?

Sorry my mistake. Suggest to remove it and just do testparm -v | paste-log and give URL

This should be more manageable:

Load smb config files from /etc/samba/smb.conf
Processing section “[osmc]”
Processing section “[automount template]”
Can’t find include file /etc/samba/smb-shares.conf
Loaded services file OK.
This warning is printed because you set one of the
following options: SO_SNDBUF, SO_RCVBUF, SO_SNDLOWAT,
Modern server operating systems are tuned for
high network performance in the majority of situations;
when you set ‘socket options’ you are overriding those
Linux in particular has an auto-tuning mechanism for
buffer sizes (SO_SNDBUF, SO_RCVBUF) that will be
disabled if you specify a socket buffer size. This can
potentially cripple your TCP/IP stack.

Getting the ‘socket options’ correct can make a big
difference to your performance, but getting them wrong
can degrade it by just as much. As with any other low
level setting, if you must make changes to it, make
small changes and test the effect before making any
large changes.


Press enter to see a dump of your service definitions


Looks still all good :frowning:

Last check on the Win10 open PowerShell and get
Get-WindowsOptionalFeature –Online –FeatureName SMB1Protocol

FeatureName : SMB1Protocol
DisplayName : SMB 1.0/CIFS File Sharing Support
Description : Support for the SMB 1.0/CIFS file sharing protocol, and the Computer Browser protocol.
RestartRequired : Possible
State : Enabled
CustomProperties :
ServerComponent\Description : Support for the SMB 1.0/CIFS file sharing protocol, and the Computer
Browser protocol.
ServerComponent\DisplayName : SMB 1.0/CIFS File Sharing Support
ServerComponent\Id : 487
ServerComponent\Type : Feature
ServerComponent\UniqueName : FS-SMB1
ServerComponent\Deploys\Update\Name : SMB1Protocol

Ok so you even have SMB1 still enabled. I am now really out of ideas what is going wrong.

Could it be a different problem with my desktop then? And when it’s working properly, shouldn’t Windows discover it by itself?

Really no idea anymore. As mentioned “discover it” depends on browsing capabilities which have been removed with SMBv1 removal. But yes as that is still active for you it should see it

Just for fun… Try this on your Pi:

$ sudo apt-get install smbclient
$ smbclient -L -U osmc

Looks like it installed libarchive13 smbclient. I can give you the whole output if you like.

Should I restart it now?

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.2.14-Debian]

    Sharename       Type      Comment
    ---------       ----      -------
    osmc            Disk      OSMC Home Directory
    IPC$            IPC       IPC Service (Samba 4.2.14-Debian)
    usb             Disk      Auto-mount Volume
    boot            Disk      Auto-mount Volume
    exhdd           Disk      Auto-mount Volume

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.2.14-Debian]

    Server               Comment
    ---------            -------
    OSMC                 Samba 4.2.14-Debian

    Workgroup            Master
    ---------            -------
    WORKGROUP            OSMC

So it seems that the SMB server is running properly and shares can be seen. So I’d say that something is up with the Win10 system. You don’t have any other systems you can test from?

Well all working as expected

Ding ding ding! Works from my laptop. So yeah, problem’s gotta be my Win10 machine. Can’t imagine what it would be though.

I don’t have Windows (haven’t run it for years…) Hopefully someone with WIn10 has some ideas at this point. At least we know that it isn’t a problem with OSMC.

Thanks a lot for your help man! I really appreciate it!

No problem. And another silly question… (I’m good at those), have you rebooted the Win10 system? Any recent changes? Disable AV software?

Rebooted just now, no luck. Also completely disabled Kaspersky’s and then tried, still nothing. Changes? Recent Windows 10 update, but laptop has the same update and can also connect.

Fixed it! The solution I found is to add Windows Credentials in the Credentials manager for the Samba share!


1 Like