Unusable / constant buffering since 2021-12.1 / latest Widevine

It needs a bit more than what nba20 posted :wink:

My .kodi/userdata/advancedsettings.xml looks like this:

<?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
    <network>
        <disablehttp2>true</disablehttp2><!--stutter problems on livestreams-->
    </network>
</advancedsettings>

Afterwards don’t forget to restart media center (reboot your Pi or run sudo systemctl restart mediacenter)

1 Like

Hi michield, thanks, I copy-pasted your settings.
Sadly still exactly the same buffering problem…

Omg… about one hours ago i have tryed to see “Atalanta - Inter” on Dazn.

i have an rpi2 whit current osmc build… i use the Dazn from Maven85 GitHub repo and i my personal user/password.

Until today i use dazn whitout any issue… today it’s not works… i have try to open some video from dazn various livestream and also some on demand show (like some documentary and some highlights of passed match) but i have same issue reported here.

all video goes in buffering immediately after some seconds and i can see the buffer reach only the 10% and all video it’s unplayable.

for some test i have test the widevine whit another addons… using “Mediaset Play” and open the livestream of “Italia 1” and here no issue.

Found by google this thread…

now i have also i add the “disable http2” tag on my advanced setting file.

later can i restart my pi2 and i can retry to open some other video from dazn and see if this help also me to resolve the issue.

if yes… thanks in advace…

wait some my feedback later… thanks again.

edit

added “disable http2” not resolve my issue.

dazn it’s completely right now unwatchable on my rpi2…

edit 2nd
i have also tryed to re(install) by inputstream helper…
reboot my pi2 not resolve… all dazn content it’s unwatchable how i report upper here :frowning:

Have you tried reporting the issue to the developer of this add-on and providing them with some logs?

I have tryed to look the debug log and apparently there’s no important info when the buffering issue it’s reproduced.

This trouble reminded me a lot of the recent problem with youtube addons:

My question it’s… it’s this issue it’s related only to Rpi devices or it’s affect all devices ?

In the last few minutes I have tried the same addons on my PC (windows 10 x64 whit kodi 19.3 installed whit a total clean installation):
I have download inputstream.helper… download the cdm… open the “Highlight” of a Serie A match (in this test “Atalanta - Inter”) and on windows kodi version there’s no issue… the video it’s works flawlessy.

On Vero ? It’s works whitout trouble ?

Hi FaustoGSR,
No, I’m on a Vero 4K+ and my inputstream.adaptive add-ons (Netflix, VRT Nu) are absolutely unwatchable.
Nigel92 proposed up/downgrading inputstream.adaptive, but I haven’t succeeded so far, getting the following error:

2022-01-16 21:20:32.535 T:5445    ERROR <general>: CAddonInfoBuilder::Generate: Unable to load 'zip://%2fhome%2fosmc%2finputstream.adaptive-19.0.2-Matrix.zip/inputstream.adaptive-19.0.2-Matrix/addon.xml', Line 0
                                                   Failed to open file

The zip isn’t corrupt (it shows the contents via the Kodi file browser), so unclear why it doesn’t install…

@eph I know it’s my device it’s completely different but i thinks you can’t update/downgrade the inputstream.adaptive because it’s if i remember it is an integral part of kodi itself and it’s not like a normal addons.

Anyway on current osmc build for raspberry pi2 the inputstream.adaptive it’s the 19.0.1… while on kodi that I have installed on pc also whit kodi 19.3 but it’s contain the 19.0.2…

I was having the same problem which started about one or two weeks ago after I updated widevine to the latest version. Constant buffering in all Kodi (matrix osmc raspberry pi 3b) add-ons with which I used to watch tv channels (retrospect, Ziggo, kpn-iptv and Webbie player which has buffering problems in all channels except non commercial ones).

I solved the problem by restoring an older version of widevine using inputstream helper.

The buffering problem must be related to widevine, but only the latest version.

1 Like

Good evening.
I’ve had the same trouble as all of you since today, with the recent combination of the 2021-12 OSMC latest update (I’ve done it 3 days ago) AND the Widevine update today. The tip with advancedsettings.xml seems to be functional, but I’ve also downgraded the Widevine library and used the prev release. That’s always hard to see that you don’t have choice for some updates like Widevine (otherwise nothing may work) and when you do it, it’s worse after… the glitches with sound and stream were horrible, it was so surprising because of its suddenness… and every glitch went off after downgrading and rebooting with the advancedsettings mod. But the question is : how much time before a new problem ? Problems are despite recurrent, without doing anything than updating from the official repositories… ouch. Angry mode.

What Widevine version did you downgrade to to make it work again?
Can anybody please tell me how to downgrade Widevine CDM without local backups of older versions (clean install of latest OSMC)…
Like this my Vero is unusable to me :frowning:

I think I restored, using the inputstream helper, the CDM widevine library version 4.10.2391.0 (14268.67.0) and after that I disabled the inputstream helper to prevent it from updating the library.

I should add that after about one hour of watching a channel the sound starts trailing the image. This problem I seem to be able to solve by restarting the player.

Hi. Sorry without a previous install, there’s no way to downgrade to previous version. Previous releases are kept in cache after each Windevine upgrade. You can then easily choose to return to a previous release inside plugins parameters, using the inputstream helper or the Disney+ plugin for example. But you can also download a lib (I’ve already found links for that for Libreelec for example), or ask someone to give files to you. I don’t know if the lib file is sufficient or no. Perhaps the whole cdm directory is useful, really don’t know.

Disable the update of library is not a full solution. Ina week, a month or one year, your Widevine will be obsolete without any notification (don’t know, depends on Google desideratas), and nothing will work suddenly (direct streams, netflix, disney etc)

It’s really discouraging. However much I like OSMC and my Vero, this makes me consider getting an Android box.
Had one before (Wetek), was happy to first migrate to OpenELEC and then leave that behind me. But at least the streaming apps would work without breaking randomly… :confused:

consider when you buy an android box and if you want to use netflix at 4k you need to buy a box whit official certification or you can obtain the similar issue also whit an android box like your current vero 4k.

remember also one thing… usually kodi it’s not be considered a good place for supporting infact all addons you found it’s usually developed by single and very generous members of kodi community…

I know, and I’m very grateful to those good people without who those add-ons effectively wouldn’t exist.

Still getting desperate with the broken Widevine…
@sam_nazarko , I understood Widevine was now supposed to work “out of the box”, as mentioned here: Widevine add-ons stopped working from 01/09

Is anything possible to get the latest version up and running…?

Thanks in advance…

We’ve made the changes to support newer versions of Widevine and this is still the case. But there’s not much we can do about its performance unfortunately.

Resetting widevine to a former version solved the the issue for me as well. Thanks to Inputstream Helper Add-on: no problem :slight_smile: Thanks to all the contributers! Also: widevine is an external dependency, so I believe it’s hard to predict when and why new issues arise…

I have no clue how to downgrade, without a local previous backup. Could somebody please share a working Widevine backup?

Thanks in advance!!

Distribution of Widevine binaries is subject to a complex legal agreement and we cannot facilitate this on our forum.