Unusable / constant buffering since 2021-12.1 / latest Widevine

Resetting widevine to a former version solved the the issue for me as well. Thanks to Inputstream Helper Add-on: no problem :slight_smile: Thanks to all the contributers! Also: widevine is an external dependency, so I believe it’s hard to predict when and why new issues arise…

I have no clue how to downgrade, without a local previous backup. Could somebody please share a working Widevine backup?

Thanks in advance!!

Distribution of Widevine binaries is subject to a complex legal agreement and we cannot facilitate this on our forum.

I’ve read that somewhere in 2022 Widevine L1 support/certification would be added for Vero devices. Can someone shed some more light on this subject?

Will this alleviate issues like in September 2021 or the ones mentioned in this thread (as perhaps some more decoding magic can be done with hardware acceleration than by software)? I understand it won’t help users on other hardware platforms (than the Vero devices) though.

Is it more likely to see such a release in December or during the next quarter? Not trying to rush it or pin anyone on a date, just curious about the progress of this awesome feature I’m looking forward to ^_^.

I might be way of base here, but as I’ve understood it Vero4k(+) is under process to get some license, I don’t know at what level or any cost involved, but the part that gives me a reluctance to go all out just pay tons of money to have HW decoding. It’s the content providers that chose which licenses that would validate the use of their services.

I the case of Netflix, the have accepted Android, WEB-browser with certain abilities. Where they can lockdown the gui into a “Netflix experience”. That will never happen on Kodi running opensource OS, even if google went ahead and licensed OSMC Vero4k(+) for 4k resolution, hw-decoded h265 streams, with “Video standard *” here and “Audio standard *” there, Netflix would never accept it since, it’s not providing the Netflix-experience GUI. And Netflix have had yhis stance long enopugh to impact other content providers to have simular reasoning to shut down client D and let client E go ahead a flourish.

1 Like

i have used this:

Need to connect to your device by SSH and download this .so… the strange situation on my Pi2 because i had some backup of same version of library but only this apparently resolve my issue…

1 Like

The last we heard from Sam, he was experimenting with getting Widevine L1 working, but things were still at quite an early stage, and it was quite possible those experiments would ultimately not be successful. Widevine L1 support has certainly not been announced. It might happen; if it does, we don’t know when.

Even with Widevine L1 (as I understand it) the main difference you’ll see is the enabling of hardware acceleration on Widevine videos, meaning you’ll be able to play 1080p videos comfortably on Netflix. Access to 4K or HDR streams on Netflix requires not only Widevine L1 but a device that has been certified by Netflix. It is possible (but certainly not guaranteed) that a future OSMC device might acquire such certification; but the Vero 4K(+) definitely cannot.

I’m not sure what the situation would be with other add-ons.

With newer hardware, we plan to burn in Widevine L1 and HDCP1.4, HDCP2.2 keys.

This can only be provisioned at factory and can’t be done over the air. So we could do this with newer Vero 4K+ devices but not ones out in the wild.

This does have other implications though - secure boot is probably needed. And just supporting Widevine L1 doesn’t mean we get access to everything. There are additional certification requirements.

2 Likes

For me this worked.

advancedsettings.xml

<advancedsettings version="1.0">
<network>
<disablehttp2>true</disablehttp2>
</network>
</advancedsettings>

Reboot

Disable http2 is not working for me.
I need downgrade widevine from 4.10.2391.0 to 4.10.2252.0 at vero4k+

I had the same problems on my RPi2, after a Widevine update.

.kodi/userdata/advancedsettings.xml didn’t exist. I went ahead and created it just to test the proposed solution, deactvating http2. Rebooted, didn’t work.

Downgrading the Widevine from the GUI (Addon-browser–> Netflix–> manage dependencies → Widevine reinstallation), then rebooting worked for me (for now ;-))

I am also having this issue with NLziet. The http2 fix is not working for me. Will try to downgrade Widevine as well now.

I downgraded to 2252.5 but that did not fix this issue. Is only 2252.0 old enough? Seems I lack that backup :frowning:

Same here with the TV Vlaanderen App.
Buffering all the time.
I got the 4.10.222252 .so on my harddisc but I have no clue where to copy it.
Anyone got the right ssh copy command so I can upload it to my Vero4k+ box?

It should be stored:

/home/osmc/.kodi/cdm/libwidevinecdm.so

I’m unsure if you can transfer it to location by network transfer easily, since kodi folder is a “hidden” folder, so unless you transfer protokol allows or have settngs to allow hidden folders you are stuck to copy it to osmc home folder, use ssh to access device shell, and run:

cp ./"your_libwidevine_file_name" ./kodi/cdm/libwidevinecdm.so

Note that my NLZiet is now working with the 2252.0 Widevine, but my Twitch is now broken. I assume Twitch needs a newer version.

So this is also not a great solution, even temporary :frowning:

I agree, not a optimal solution, but it’s the only one available. There is always updates to the software based decoder, made by google. And then there are the content providers that decide which level of widevine and which functions it is supposed to support.

Most hardware manufactures elect to lock down the OS to provide the “safe space” google needs to approve your device for hw-decodeing, this rimes hard with “OpenSourceMediaCenter”. But apparently there are talks about coming OSMC devices being qualified for HW-libwidevine. Don’t know enough to say more but. For now Software decoding is limiting, in not just CPU on you hardware, but to a lot of constant functions increments, which leaves the ContentProviders a bit in limbo, which version to set as minimum.

I managed to tranfer it, but this version is a little bit ‘less worse’.
Still unusable sadly enough.

I also experience a tutter every now and then when streaming youtube video’s.

Steaming movies from my NAS works nice.

Is there a way to do a speedtest?

I downgraded to Widevine 4.10.2522.5 and it works. I tried also to disable http2 but it was not enough - sound was sometimes still little bit quicker. https://github.com/CastagnaIT/plugin.video.netflix/issues/1321

Its seems on my rpi4-8GB it works with latest widevine.

Vero4k+ settings:
Kodi 19.3 on arm architecture
Inputstreamhelper 0.5.9+matrix1
Inputstream Adaptive 19.0.1
Widevine cdm 4.10.2391.0

Rpi4 8GB settings:
Kodi 19.4 on arm64 architecture
Inputstreamhelper 0.5.9+matrix1
Inputstream Adaptive 19.0.3.1
Widevine cdm 4.10.2391.0

So Isuppose Inputstream Adaptive needs an upgrade.