Update Installation Error

I have a Vero 4K and i tried to manually update it over the osmc menu. After the download information in the right upper corner it says “Update Installation error” “Write to support forum”.
So? What next??

Logs, please.


It seems that quite a few people have looked at the log but I’m guessing that nobody has found anything wrong in it. And neither have I.

If you know how to SSH to the Vero 4K, you could try to run these commands and see if an error is reported:

sudo apt-get update
sudo apt-get dist-upgrade

If that works, the original error was possibly a result of a temporary network problem.

1 Like

I tried “apt-get update”, and got this at the end

Err:7 http://ftp.fau.de/osmc/osmc/apt stretch Release 
By resolving ?ftp.fau.de:http? something bad happend (-5 - No address to this host name).
E: The repository 'http://apt.osmc.tv stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

“apt-get dist-upgarde” says:

0 updated, 0 new installed, 0 uninstalled und 0 not updated.

And by the way, i also cannot update addons! No Packages found even if the addons panels says there are updates!

It looks like it might be a DNS problem.

What’s the output from running these commands:

cat /etc/resolv.conf
host ftp.fau.de

Can you also try ping

“cat /etc/resolv.conf” returned the IP of my Router (Nameserver: Router IPAddress) and
“host ftp.fau.de” returned:

;; connection timed out; no servers could be reached

ping. returns working pings!

Is there a problem with listing the output from running cat /etc/resolv.conf? Since “no servers could be reached” it might be a syntax error for all I know.

I tried a ip lookup from ftp.fau.de … it seems to be

i’ve checked my router which running suricata, but the ip ist not blocked!
and pings working on that ip


Are you able to ping ftp.fau.de or google.com

Thanks Tom.

“ping ftp.fau.de” returns:

ping: bad address 'ftp.fau.de'

“ping google.com” returns working ping signals

but “ping” (the ip from ftp.fau.de) returns also working pings

Ok, i think i made some progress. I’ve changed the default DNS Server on my router from default of the provider to and now i got pings from “ftp.fau.de”!!
Maybe the DNS server from my provider is lame :-/

sudo apt-get update

runs now without errors!

And the updater of osmc menu works also.