Updating Vero needs input I cannot give

Checking for an update on my Vero after the 2015.12-1 installation gave an update. But on the installation process I get this message:

I CANNOT give any input with my remote on this field, so I am stuck in the update process. I wanted to see a movie tonight, no go I suppose. The update process of the Vero device is terrible in many cases. What can I do to use my Vero as a “set-and-forget” device???

You don’t have any usb keyboard you could plug in for a second I suppose?

You can disable updates in myosmc afaik.
If not, just don’t update.

Did you mess manually with the samba config file as it seems as it has a problem with that file?

We’re aware of the issue and attempting to bring a workaround for those who might be affected in short order. Sorry for the inconvenience and thanks for your patience!

This is a problem that was not caused by us, but by the Debian Samba package maintainers who out of the blue added a “high priority” question in their package configuration causing this prompt.

We are just as annoyed about this as you I can assure you and I’ve spent a couple of hours tonight (before we had even seen any reports on the forum - I saw the problem occur on my own system first) working out a long term solution for this which has just been pushed out as an update.

To work around it in the meantime I recommend that you log in remotely via SSH, and run the following commands:

sudo systemctl stop manual-update

(this will stop the currently stalled update process, although you won’t see a change on the screen)

sudo apt-get -f dist-upgrade

This will start a new update process but in your SSH session, you will see the same message appear, just choose no (or yes, it doesn’t really matter) and the update process will continue. When it is finished type reboot.

The update that we have pushed out will prevent the same problem happening again in future.

1 Like

I have got no clue who “Debian Samba package maintainers” are and tbh I don’t care. I bought a flagship OSMC device that still does not live up to the promise. Updates should be checked and double checked. I recommended this device before it was out to some people I know, because it should be EASY. For them SSH means shush or something (in dutch).

In my experience so far most updates, and I really mean most (!), fail to succeed the 1st time. Mostly it requires many restarts, I get strange screens hanging in the OSMC boot and many times I have to reconfigure the audio and/or video settings to get it working again (many times audio output device is set to optical after update in stead of HDMI, and video is many times with the wrong resolution or refreshrate. I know a little bit about computers, but nothing about Linux. The very last december update I mentioned the result in this thread, no reply whatsoever for this flagship owner. Now I have to get in terminal again to get things done. Again, Vero just does not live up to the promise and so we should buy a Vero2??

I have strong criticism as you notice. But for a normal user this device is just…, well, let me not write that down. It was expensive but came with a promise. I am disappointed.

I will do what DBMandrake wrote, thanks for the help. But is is just not what I want to do with my Vero.

There was no reply because there were no logs, and you seemed to resolve the issue. It was still read and a note was made of it. it certainly seems like a one off on this forum.

And they are. The issue was caused by a package that you installed via OSMC’s App Store. Some of these applications (Samba) are effectively third party, and it’s not our fault if there’s an issue with these. With that said, this issue won’t be occurring again. But you may have noticed the lack of posts around this issue. This is because not many people use the Samba server. If you’re running server based packages on your device, you’re using it a little bit outside of the expected use case, so you are expected to occasionally perform some minor administration.

This very much sounds like a corrupt or faulty installation, and you should consider a reinstallation.

Reading a forum like this, making logs and uploading them, really, even knowing what logs are was NOT the idea of the Vero. It was marketed as an easy device even my mother could handle.

Sorry, I wasn’t expecting “some minor administration”. I didn’t even know it was 3rd party and really, it shouldn’t matter to the end-user. I use a very standard installation of Vero with only another skin and 2 or 3 items from your store. No plugins, add-ons or anything in Kodi. Never did strange things with the Vero (in fact, hardly using it because the old Apple TV served me better) and always updating the official way.

And this one is really important: It is not about who’s fault it is, it is about who is responsible! And the people who are responsible should talk to the “guilty” people, but as a customer I don’t want to know about that.

Unfortunately, that is not possible for me. I only have a late 2008 Macbook and no cardreader, nor willing to invest in one. If there is a way to reinstall on the Vero itself I would like to know.

Btw, the commands from DBMandrake worked; I am on 2015.12-2 now.

By the way, now that I have your attention:

The screen I get many times after updating OSMC is this one:

I don’t know what causes this screen but it usually takes many cord unplugging before it returns to "normal"and I can set the options right again.

There is, provided it is bootable. If you ever need to do so, you can do it with a 1 liner, but having an SD card reader is a ‘safer’ option.

That’s good to hear. This issue is addressed and your device will show 2015.12-3 on the next update.

I am sorry this issue occurred and I can understand the frustration. If you didn’t have the Samba server installed, you would not have experienced this issue. The issue was actually caused by Debian, which is what OSMC is based on. Unfortunately providing an expansive system can sometimes mean that individual packages break, or behave unexpectedly. This is what happened today, and we will raise this with the Debian team. We have also taken steps to make sure this won’t happen again.

OK – that’s certainly odd. What resolution are you running at? Does this screen appear after the update, during the update, after a reboot, etc?


Good to hear it is possible. Could you tell me how to do it?

I am at 2015.12-3 now, good work.

Perfect, lessons learned than!

I have Vero connected via HDMI to my Marantz SR7005 HT-receiver. My TV is a 720p/50Hz Panasonic oldie. The screen appears (not now, but many tines after an update) after the reboot needed by an update. I believe I also got sometimes after a normal reboot, but my memory lacks sometimes.

Sure but I would really not recommend doing this unless you definitely find a need to:

This may be caused by the EDID changing suddenly when the device reboots. I would recommend:

  • Editing /boot/uEnv.txt and setting resolution to 720p and not 1080p. This alone may be enough to stop it switching at boot.
  • Trying mxc_hdmi.ignore_edid=1 if the above fails may also help


Oké, will try that tomorrow. First some sleep, kids will wake up in 3-4 hours from now…
I also sometimes connect my 1080p projector to my receiver. Will the first option prevent my beamer from outputting 1080p? And if yes, will the 2nd option be better for me?

The first option would be better if connecting to a 1080p device later. It does not prevent resolution changes, it just means the Vero will start in 720p.


Really my last post :wink:
My uEnv.txt looks like this:
mmcargs=setenv bootargs console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24,bpp=32 dmfc=3 consoleblank=0 loglevel=2 osmcdev=vero

Should this be 1280x720M@50 in my case? I really don’t understand the “M” in this line.

I also notice that the "modified"date of this file is 01-01-1980?

I did – if you use the first option, then Vero will start in 720p, read your projector’s 1080p EDID and switch the resolution. If you use the second option, the EDID, and request to switch, will be ignored.


The installer runs without network connectivity, so it doesn’t have a proper datetime when it generates uEnv.txt on the fly. This is not an issue.


Oké, changed the file and rebooted. All fine. Now hopefully no more annoyances. Thank you and good night.

Same problem here. Thank goodness this post exists, or I would’ve been completely stumped! :confused:

P.S. @sam_nazarko I also use, and rely, on the Samba add-on daily - so hope it will be sticking around
(though I’m sure I could do it manually, if push came to shove, but would prefer not to! :wink: )

After the steps listed, OSMC doesn’t boot past the splash screen (from TV’s perspective) and I could only ssh to it again after unplugging power.

Any ideas where to start investigation?

Provide us with the URL that grab-logs -A spits out

And maybe before try
sudo apt-get update
sudo apt-get dist-upgrade

Found something in startup logs about display manager being not found, so ended up installing fresh copy. This reminded me how I love linux :slightly_smiling: