Upgrade to kodi v18


#1

hello,

I am trying to install netflix addon on kodi, my current version is 17.8-396, I read that netflix works only on kodi v18, so I tried to follow this [TESTING] Kodi 18 (Leia) builds for Raspberry Pi , but I can’t find the v18 there.
Did I miss something?

thanks,


#2

17.8 branch is OSMC speak for testing 18, try the instructions here to get netflix running


#3

ah ok. Then the netflix addon should work on it, right?

I have this error when I try to play a video.

16:16:51.391 T:1918369792 NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.netflix/?action=play_video&infoLabels=[REDACTED netflix URL]
16:16:51.391 T:1918369792 NOTICE: CVideoPlayer::CloseFile()
16:16:51.391 T:1918369792 NOTICE: VideoPlayer: waiting for threads to exit
16:16:51.391 T:1547105008 NOTICE: CVideoPlayer::OnExit()
16:16:51.393 T:1547105008 NOTICE: Closing stream player 1
16:16:51.393 T:1363145456 NOTICE: thread end: OMXPlayerAudio::OnExit()
16:16:51.463 T:1547105008 NOTICE: Closing stream player 2
16:16:51.464 T:1300640496 ERROR: OMXPlayerVideo: Got MSGQ_IS_ERROR(-1) Aborting
16:16:51.464 T:1300640496 NOTICE: thread end: video_thread
16:16:51.492 T:1547105008 NOTICE: Closing stream player 3
16:16:51.656 T:1918369792 NOTICE: VideoPlayer: finished waiting
16:16:51.657 T:1267725040 NOTICE: Creating InputStream
16:16:56.577 T:1267725040 NOTICE: Creating Demuxer
16:16:56.580 T:1267725040 NOTICE: Opening stream: 1 source: 256
16:16:56.665 T:1267725040 NOTICE: Creating video thread
16:16:56.666 T:1267725040 NOTICE: Opening stream: 2 source: 256
16:16:56.770 T:1267725040 NOTICE: Creating audio thread
16:16:56.771 T:1267725040 NOTICE: Opening stream: 4 source: 256
16:17:18.054 T:1881142000 ERROR: CAESinkALSA - snd_pcm_writei(-5) Input/output error - trying to recover
16:17:18.054 T:1881142000 ERROR: CAESinkALSA::HandleError(snd_pcm_writei(1)) - snd_pcm_writei returned -5 (Input/output error)

I installed netflix addon from this repository: https://github.com/kodinerds/repo/raw/master/repository.netflix/


#4

Hi @v0l

I’m not sure about the error message you get, perhaps @joakim_s can help you with that, but I got the Netflix addon from

Mark


#5

tested the addon from this repo as well and I got a different error

17:03:34.741 T:1917546496 NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.netflix/?action=play_video&infoLabels=[REDACTED]
17:03:34.742 T:1426060016 NOTICE: Creating InputStream
17:03:40.005 T:1426060016 NOTICE: Creating Demuxer
17:03:40.009 T:1426060016 NOTICE: Opening stream: 1 source: 256
17:03:40.143 T:1426060016 NOTICE: Creating video thread
17:03:40.144 T:1426060016 NOTICE: Opening stream: 2 source: 256
17:03:40.191 T:1426060016 NOTICE: Creating audio thread
17:03:40.191 T:1426060016 NOTICE: Opening stream: 7 source: 256
17:03:40.499 T:1426060016 NOTICE: OMXClock using audio as reference
17:03:40.579 T:1819276016 ERROR: COMXCoreComponent::DecoderEventHandler OMX.broadcom.video_decode - OMX_ErrorStreamCorrupt, Bitstream corrupt
17:03:40.645 T:1917546496 NOTICE: Display resolution ADJUST : 640x480 (640x480) @ 59.94 - Full Screen (17) (weight: 14.400)
17:03:40.647 T:1917546496 WARNING: OnMessage: Suspiciously long time to handle GUI_MSG_PLAYBACK_STARTED (5.80s)

I also tried to change the config.txt like:

gpu_mem=256
gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
gpu_mem_256=112
sdtv_aspect=1
gpu_mem_512=144
arm_freq=1000
core_freq=500
over_voltage=2
sdram_freq=500


#6

This thread may provide clues.


#7

If you followed that guide(alternatively used the installerscript) you should have a working netflix. Did you get asked for credentials? Did you get asked to install Libwidvine?

“For Pi’s you got to run in MMAL, omxplayer will not work.” quoted from the Netflix install thread.


#8

got it, disabling omxplater hw support it works.
thanks