Vero 4+ & Benq Projector: No 4k

Was wondering if anyone else has had issues with 4k+ and a Benq 4k projector?

I simply cannot get it to output in 4k so don’t know if it is a fault or I am doing something wrong.

Same cable and projector work fine with other 4k sources such as UltraHD Blu-ray, Netflix etc. but not with Vero 4k+ which refuses to go above 1080p.

If I set the resolution of the interface to 2160p it blanks for 10 seconds then goes back to 1080p with the projector unable to lock onto a source. If I leave that setting at 1920x1080 and after selecting a 16s delay on switching when I play a 4k media it switches to 1080p but with HDR10. So it is “seeing” the HDR10 OK but not the 4k.

I thought it might be the cable but it is 100% reliable with everything else but to be sure I connected up (with everything dangling off the ceiling) via a 1m 8k certified cable with identical results. So I don’t think it is the connection.

The projector is a W1720.

Any ideas?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks, hopefully log can be found at

I enabled logging, rebooted twice, then tried switching to 3840x2160 resolution which defaulted back to 1920x1080. Then tried playing a 4k file which played in 1920x1080 with HDR.

Turn off ‘Force RGB output’ in Settings->System->Display.

Additionally we do not recommend you set the UI to 4K. Please note the following…

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

To be fair, the user isn’t proposing to use 4K for the GUI, but curiously has the resolution set to 1080i. That can sometimes happen if vero is turned on with only an AVR connected.

If turning off RGB doesn’t work, setting 422 output would be my next suggestion.

It’s fixed! Thanks. What actually did it was switching the user interface from 1920x1080i to 1920x1080p.

Once I did that, when I played a 4k file it switched directly to 2160p HDR 24fps (for 24fps material) and back to 1080p again when exiting which is what I understand it should do.