Vero 4+ doesnt wake up when connected to soundbar

You probably have it set to Shut Down, which the device won’t be able to wake from. You could set this to Suspend.

Its set to suspend in power savings options.

I tested SSH, that works. But the box is unresponsive and not showing any hdmi-signal. Im out of my league here…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Enable HPD Lock under Display settings and reboot. Does this help?

Sam

Hpd lock was allready enabled. Is there somethings in the cec-adapter settings i should look at?

Yes, make sure it’s not set to shut down when Tv has shut off or changes input.

Its set to ignore. I also set it to “Connected to AVR” and “HDMI port 1”. No change in behaviour.

Then suggest to upload logs as described by @darwindesign
Enable Debug Logging, wait for the problem to happen, login via SSH and then upload grab-logs -A and share URL.

Here are the logs: https://paste.osmc.tv/uluvireyob

The problem is easy reproduced, when i turn of the soundbar and the tv and turn them back on again the Vero does not wake up. Even tho i just restarted the Vero.

Looks like you used -a instead of -A.
Please upload with -A after the Vero doesn’t wake-up.

I was not aware that it was case sensitive :stuck_out_tongue:

Logs created with -A : https://paste.osmc.tv/owekojemet

Ok, we once more have to clarify what is “not wake-up” because in the logs there is nothing shown that the Vero went into “standby”.
Was the red LED on?

Also suggest you set the GUI to 1080p instead of 4k.

Wondering what for you installed all the Wayland and X11 packages? Did you install the X Desktop?

The gui to 1080? Why is that? I tought that this setting was for “everything” ie the vero will output 1080p no matter what.

I dont know what those packages are. I might have done some experimenting in the past, but im not sure.

Red light is not on. When i say “doesn’t wake up” i mean that the vero is not outputting a signal. I turn of tv and soundbar and when i turn them back on, the vero does not “wake up”/output a signal/anything.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

You installed a bunch of packages last September that are not useful for the normal Kodi operation of OSMC.

Start-Date: 2019-09-04  18:56:59
Requested-By: osmc (1000)
Install: libjson-glib-1.0-0:armhf (1.2.6-1, automatic), libxdmcp6:armhf (1:1.1.2-3, automatic), libsoup-gnome2.4-1:armhf (2.56.0-2+deb9u2, automatic), libcroco3:armhf (0.6.11-3, automatic), libpangoft2-1.0-0:armhf (1.40.5-1, automatic), glib-networking-services:armhf (2.50.0-1+b1, automatic), libxcb-xfixes0:armhf (1.12-1, automatic), armv7-transmission-app-osmc:armhf (2.9.4-1), libgdk-pixbuf2.0-0:armhf (2.36.5-2+deb9u2, automatic), libproxy1v5:armhf (0.4.14-2, automatic), dconf-service:armhf (0.26.0-2+b1, automatic), libcairo-gobject2:armhf (1.14.8-1, automatic), glib-networking:armhf (2.50.0-1+b1, automatic), libgtk-3-common:armhf (3.22.11-1, automatic), libxcb-present0:armhf (1.12-1, automatic), libgtk-3-0:armhf (3.22.11-1, automatic), libpixman-1-0:armhf (0.34.0-1, automatic), libdbusmenu-glib4:armhf (12.10.2-2, automatic), librsvg2-common:armhf (2.40.16-1+b1, automatic), libxrender1:armhf (1:0.9.10-1, automatic), dconf-gsettings-backend:armhf (0.26.0-2+b1, automatic), libnatpmp1:armhf (20110808-4+b1, automatic), libxcursor1:armhf (1:1.1.14-1+deb9u2, automatic), libthai-data:armhf (0.1.26-1, automatic), libindicator3-7:armhf (0.5.0-3+b1, automatic), libegl1-mesa:armhf (13.0.6-1+b2, automatic), libxcb-shm0:armhf (1.12-1, automatic), libepoxy0:armhf (1.3.1-2, automatic), libappindicator3-1:armhf (0.4.92-4, automatic), gsettings-desktop-schemas:armhf (3.22.0-1, automatic), libxcb-render0:armhf (1.12-1, automatic), libminiupnpc10:armhf (1.9.20140610-4, automatic), libx11-6:armhf (2:1.6.4-3+deb9u1, automatic), glib-networking-common:armhf (2.50.0-1, automatic), libsoup2.4-1:armhf (2.56.0-2+deb9u2, automatic), libgbm1:armhf (13.0.6-1+b2, automatic), libxshmfence1:armhf (1.2-1+b2, automatic), libwayland-client0:armhf (1.12.0-1+deb9u1, automatic), fontconfig:armhf (2.11.0-6.7+b1, automatic), libxau6:armhf (1:1.0.8-1, automatic), libatk1.0-0:armhf (2.22.0-1, automatic), libxcomposite1:armhf (1:0.4.4-2, automatic), adwaita-icon-theme:armhf (3.22.0-1+deb9u1, automatic), libpangocairo-1.0-0:armhf (1.40.5-1, automatic), libxcb1:armhf (1.12-1, automatic), libatspi2.0-0:armhf (2.22.0-6+deb9u1, automatic), librsvg2-2:armhf (2.40.16-1+b1, automatic), libxi6:armhf (2:1.7.9-1, automatic), libxinerama1:armhf (2:1.1.3-1+b3, automatic), libwayland-egl1-mesa:armhf (13.0.6-1+b2, automatic), libjson-glib-1.0-common:armhf (1.2.6-1, automatic), libxrandr2:armhf (2:1.5.1-1, automatic), libdrm2:armhf (2.4.74-1, automatic), libcolord2:armhf (1.3.3-2, automatic), shared-mime-info:armhf (1.8-1+deb9u1, automatic), hicolor-icon-theme:armhf (0.15-1, automatic), libxfixes3:armhf (1:5.0.3-1, automatic), libthai0:armhf (0.1.26-1, automatic), libx11-data:armhf (2:1.6.4-3+deb9u1, automatic), libgdk-pixbuf2.0-common:armhf (2.36.5-2+deb9u2, automatic), libdbusmenu-gtk3-4:armhf (12.10.2-2, automatic), libxdamage1:armhf (1:1.1.4-2+b3, automatic), librest-0.7-0:armhf (0.8.0-2, automatic), libatk-bridge2.0-0:armhf (2.22.0-2, automatic), gtk-update-icon-cache:armhf (3.22.11-1, automatic), libatk1.0-data:armhf (2.22.0-1, automatic), libcairo2:armhf (1.14.8-1, automatic), libpango-1.0-0:armhf (1.40.5-1, automatic), libxcb-dri2-0:armhf (1.12-1, automatic), libxcb-dri3-0:armhf (1.12-1, automatic), libdconf1:armhf (0.26.0-2+b1, automatic), libwayland-server0:armhf (1.12.0-1+deb9u1, automatic), libx11-xcb1:armhf (2:1.6.4-3+deb9u1, automatic), libxcb-sync1:armhf (1.12-1, automatic), libxext6:armhf (2:1.3.3-1+b2, automatic), libdatrie1:armhf (0.2.10-4+b1, automatic), libwayland-cursor0:armhf (1.12.0-1+deb9u1, automatic)
End-Date: 2019-09-04  18:57:44

Ok just to avoid misundertstandig, it means Vero didn’t go into standby but somehow your TV doesn’t get the HDMI signal. I suggest first you change to 1080p and maybe delete the packages you installed if your don’t need an X Environment.

Changing to 1080p didnt help. I will look at those packages and uninstall them.

After installing what i think are the packages you mentioned and setting the gui to 1080p, the problem is still there.

However: Now i get a message saying “failed to initialize cec-adapter” when i reboot.

Logs after last reboot: https://paste.osmc.tv/onerufejip

I would assume “uninstall”, while I don’t see any install/uninstall steps in your apt.log

Ok, maybe @sam_nazarko or @grahamh can take a look at your logs.
But one thinks still pops up, why did you set limited colour range, did you had a problem that you fixed with that?

Yes, i meant uninstall. I just needed to google some bash commands before getting them all removed, since i couldt find them in the gui. The logs are from before i tried the bash commands.

I think limited color range was set because it was recommended in the gui? Something about if you connected your vero to a tv you should use limited color range, and if you were connected to a pc monitor or such you should use full?

Here are the logs after some uninstalling: https://paste.osmc.tv/petocegizo

Something i did must have done the trick! Its now “waking” up when i turn off and on the tv and soundbar.

Gonna leave it for a few hours just to see if the problem is still there.

Thanks so far for the help!