Vero 4K+: 4K films not playing / Potential SMB issue

If that’s the share name you used in the Kodi-based mount, it’ll be the same for a kernel-based mount.

That could be a version issue. Until kernel 4.13, the default SMB version was 1.0. Try adding vers=3.0 to the command line options.

As you can see all “shares” that are provided are HTHD, Macintosh HD1, Movies and myhomefolder

For your problem with HTHD try adding vers=3.0 as @dillthedog wrote.
Alternative let us switch to autofs as it might be more informative what is going wrong.
Last suggest to stick using IP.

Thanks for the guidance, but still no success:
I tried both the long & short commands, and with vers=3.0 specified, I get the old ‘Input/output error’. With vers=2.0 or vers=1.0, I get the same ‘Operation not supported’ error.

LONG COMMAND:
osmc@HTPC-2:/$ sudo mount -t cifs //192.168.1.10/HTHD /mnt/new2 -o rw,iocharset=utf8,username=myusername,password=****,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=3.0

mount error(5): Input/output error

osmc@HTPC-2:/$ sudo mount -t cifs //192.168.1.10/HTHD /mnt/new2 -o rw,iocharset=utf8,username=myusername,password=****,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=1.0

mount error(95): Operation not supported

SHORT COMMAND:

osmc@HTPC-2:/$ sudo mount -t cifs -o username=myusername,vers=3.0 //192.168.1.10/HTHD /mnt/new2
Password for myusername@//RM-MacMini/HTHD: ****

mount error(5): Input/output error

osmc@HTPC-2:/$ sudo mount -t cifs -o username=myusername,vers=1.0 //192.168.1.10/HTHD /mnt/new2
Password for myusername@//RM-MacMini/HTHD: ****

mount error(95): Operation not supported

Will stick with the IP address as the ‘server’, and HTHD as the ‘share’ going forward…that’s a couple less variables to toggle. ‘new2’ is an existing & empty folder within the mnt directory.

I’m open to trying autofs again, but being able to mount from the command line seems like an initial requirement. Is there a different command line syntax I can use to test autofs (vs. appending the auto.smb.shares file?

To get more diagnostic information, run mount with the -v option.

Here’s with the diagnostic option. I ran with and without vers=3.0.
Just ran the shortened command line to keep it simple.

osmc@HTPC-2:/$ sudo mount -v -t cifs -o username=myusername,vers=3.0 //192.168.1.10/HTHD /mnt/new2
Password for myusername@//192.168.1.10/HTHD: ****

mount.cifs kernel mount options: ip=192.168.1.10,unc=\192.168.1.10\HTHD,vers=3.0,user=myusername,pass=********

mount error(5): Input/output error

WITHOUT VERS=3.0:

osmc@HTPC-2:/$ sudo mount -v -t cifs -o username=myusername //192.168.1.10/HTHD /mnt/new2
Password for myusername@//192.168.1.10/HTHD: ****

mount.cifs kernel mount options: ip=192.168.1.10,unc=\192.168.1.10\HTHD,user=myusername,pass=********

mount error(95): Operation not supported

You might try using nounix,sec=ntlmssp

Well debugging option for autofs is explained in the thread sudo automount -f -v -d
More than happy to help you with that. Alternatively you also can try with smbclient.

What are the permissions on /mnt/new2?

ls -ld /mnt/new2

Permissions on mount folder:

osmc@HTPC-2:/mnt/new2$ ls -ld /mnt/new2
drwxr-xr-x 2 root root 0 Nov 25 20:18 /mnt/new2

I tried adding the nounix & sec=ntlmssp to the command line:
(I didn’t get an error this time, but not sure it actually mounted anything.)

osmc@HTPC-2:/mnt$ sudo mount -v -t cifs -o username=myusername,nounix,sec=ntlmssp //192.168.1.10/HTHD /mnt/new2
Password for myusername@//192.168.1.10/HTHD: ****

mount.cifs kernel mount options: ip=192.168.1.10,unc=\192.168.1.10\HTHD,nounix,sec=ntlmssp,user=myusername,pass=********

osmc@HTPC-2:/mnt$ cd new2
osmc@HTPC-2:/mnt/new2$ ls -a
ls: cannot access ‘’: No such file or directory
ls: cannot access ‘’: No such file or directory
ls: cannot access ‘’: No such file or directory
ls: cannot access ‘’: No such file or directory

mount and df -h would give you indication if and how it is mounted.

SUCCESS!!

I tried the nounix & sec=ntlmssp options in the original, longer command line, and successful mounting was achieved. I can now see the folders from HTHD in my mounted folder. What do these options do?

osmc@HTPC-2:/mnt/new2$ sudo mount -t cifs //192.168.1.10/HTHD /mnt/new2 -o rw,iocharset=utf8,username=myusername,password=****,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,nounix,sec=ntlmssp,vers=1.0

(vers=3.0 doesn’t work)

Thanks all! Now I need to see if I can get the high bitrate films to play successfully with the server drives now mounted outside of Kodi. If fstab works, then I may still go back and try autofs.

Google is your friend here but basically the one tells it not to use Linux specific stuff and the other forces an older security protocol. I don’t know if you actually need both but a bit of googling turned up those two needing to be used connecting certain Mac OS versions with certain Linux builds. Now that you got it working I would suggest to switch your credentials over to a file so if needed you can output logs without that password showing up.

Just a FYI, there is not a performance difference between the two.

You might be interested in this to force your existing library to use the system mount without having to dump and rescrape.

I did a bit more trouble-shooting and confirmed the following:
The ‘sec=ntlmssp’ option is not required. The magic (missing) option required for connecting to a Mac server was the ‘nounix’ option.

Both the short & long command lines do work with the added arguments.
I was mistaken when I previously stated the short argument didn’t work…In both cases, after mounting the server, the first directory listing (ls -a) generates:
ls: cannot access ‘’: No such file or directory
But performing another directory listing (ls -a) immediately following works just fine, and shows all the mounted folders. (Not sure what’s causing this, but probably not a big deal. I thought there might be a delay for the server to mount, but no matter how long you wait, the first directory listing doesn’t work, and second listing works fine.)

autofs is now working, here is the (Mac-friendly) command line for the auto.smb.shares file:

/mnt/HTHD -fstype=cifs,rw,credentials=/home/osmc/.credentials,iocharset=utf8,uid=osmc,gid=osmc,nounix ://RM-MacMini/HTHD

Next step is to see if the 4K high bitrate films work using this mount (outside of Kodi) approach.

1 Like

That’s funny considering that MAC OS is unix based

Connecting to the server/drive outside of kodi using autofs improved things significantly.
With these high bitrate 4K films, I am still getting occasional stuttering and an eventual pause in the film while the system buffers…but no longer in the first 5min, and the kodi player no longer permanently freezes (as it did when I was connecting using smb within kodi). I must assume that the only remaining solution is to improve network speed (above 800Mbps), or improve the buffering/cache settings within the Vero 4K+. Any suggestions on new settings to try for the Vero cache (I’m currently running with default settings)?

Also, a separate question on autofs: Why is the recommended timeout set to 15sec (when default appears to be either 5 or 10min, depending on the research source). Is there an advantage of the 15sec timeout, and/or consequences of running a longer timeout period?

I’m not sure this would be beneficial.

What would be beneficial is ensuring that your network speed is consistent. It seems to me from your tests that you get lower speeds because of periods of poor network throughput. This will cause problems more so than say, having a constant 200Mbps network connection.

Although – fixing the network dropouts will almost certainly improve and give you full speeds in the order of ~900Mbps

I would try this…

<advancedsettings>
	<cache>
		<buffermode>4</buffermode>
	</cache>
</advancedsettings>

Setting the autofs timeout to 5 or 10 minutes should have no downsides unless your server is unreliable.

UPDATE:

Remaining buffering issues (with 4K high bitrate films) resolved with an upgrade from FireWire800 to Thunderbolt3 connections between the RAID-drive and Mac Server. (USB3 might have been sufficient, but I went straight to TB3 eliminate any questionable doubt.)

In regards to autofs (and fstab) drive mounting, I did encounter a problem with both approaches when playing back DVDs stored in a file folder (VIDEO_TS) format. Starting movie playback from the DVD menu would take 30sec-1min for movie playback to start, and similar delays were observed switching between special features, etc. (It was painfully slow, and I’m not sure why, but the problem started after using autofs.) No delays were observed when playing back mkv files. SOLUTION: I moved all DVD files (in a separate folder) back to a smb mount, but left speed-sensitive HD & UHD/4K mkv files in folders mounted via autofs.