Vero 4K and OSMC DVB-T2 stick

I’m not sure if this has been answered before but a search didn’t show anything.
I purchased the official DVB-T2 stick from the OSMC store, but it doesn’t seem to be functioning for me.

It shows up as a Realtek RTL2832 DVB-T, I had read it was planned to be a Panasonic but it’s not being detected as a T2 device even. Is this a firmware issue? It’s been like this for the month since I bought it, I’d hoped today’s update might have addressed the glitch I seem to be having.

A full reinstall of OSMC did not help, thought I’d try that in case I’d cratered something playing around with settings previously.

Other than this pretty minor issue, I’m very happy with the device.

Any thoughts or ideas appreciated.

Yes, it’s a software issue
We do have T2 support now finalised.

I will send you a PM shortly if you’re happy to try this


Thanks Sam. I’d be more than happy to try it out.

I bought the OSMC DVB stick some while ago and feel I threw the money away. It’s never worked for me in any reliable way with UK Freeview . I just pulled it out of a drawer to see if it’s working with the latest OSMC build, and as before all the mux scans failed. The MyGica stick in my LE Pi “just works” . I know my way around TVHeadend fairly well, but the OSMC stick + Vero do not get along. Is this still a recognised issue?

Shouldn’t be an issue. Are you powering the dongle with an external hub?


Which version? I have the one with the Panasonic chip in daily use. It does share a splitter/amplifier with another stick (MyGica) but I don’t have line-of-sight to a transmitter and my aerial is inside my loft. And both are on a powered USB hub.

with external power, this is what I have


Via the LE Pi I have a good set of scanned muxes but on the Vero+OSMC stick every mux scan fails.

Try a cold boot and upload some logs via My OSMC.

Have you tried this to get the DVB-T2 tuner going?

thanks, this fixed all my problems with the OSMC DVB stick on the Vero. If only this instruction could have been provided when I purchased the stick! One might assume that the official stick would work out of the box with TVHE server installed via the OSMC store, but it looks like everything is solid now. Thanks @grahamh for the suggestion.

sudo systemctl stop tvheadend
rm ~/.hts/tvheadend/input/linuxdvb/adapters/*
sudo systemctl start tvheadend

YW. This blocking of the DVB-T2 tuner isn’t inevitable. It only happens if the realtek tuner is enabled first. I’ve no idea why or how to fix it and no idea why you didn’t get at least the SDTV channels on the realtek.

The MyGica stick is also working now on my Vero. Before running the remove command you posted I was also finding that accessing the TVHE webpage was hanging a lot on initial access, now it’s instant just like my LE Pi. Great to have this fixed.