Vero 4K+ - Black screen when skipping video forward

Recently my videos have a problem.
When I skip like 10 or 30 seconds forward, I get a black screen for a while. The timebar goes on and I can hear audio but the screen stays black and usually I have to skip one more time to make video come back.

That’s the log:

I hope you can help me, because it’s a very tedious issue.

Might not solve your issue but it would approve your Video quality.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Even with those settings i get the black screen issue.

ps: I have already uploaded the log in the first post.

I also tried with and without HW acceleration and I always get the issue.

I made several tries. Nothing fixed it.

I really hope somebody can help me.
The following are the MediaInfo of the file:

Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 4.58 GiB
Duration                                 : 1 h 36 min
Overall bit rate mode                    : Variable
Overall bit rate                         : 6 795 kb/s
Writing application                      : Lavf59.4.100
Writing library                          : Lavf59.4.100
ErrorDetectionType                       : Per level 1

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : Main@L4.2
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, RefFrames               : 4 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 1 h 36 min
Bit rate mode                            : Variable
Bit rate                                 : 6 276 kb/s
Nominal bit rate                         : 2 099 kb/s
Maximum bit rate                         : 8 000 kb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 59.940 (60000/1001) FPS
Standard                                 : Component
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.050
Stream size                              : 4.23 GiB (92%)
Writing library                          : x264 core 160 r3000
Encoding settings                        : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=4 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=1 / threads=12 / lookahead_threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=120 / keyint_min=12 / scenecut=0 / intra_refresh=0 / rc_lookahead=20 / rc=abr / mbtree=1 / bitrate=2099 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=4198 / vbv_bufsize=8000 / nal_hrd=none / filler=0 / ip_ratio=1.40 / aq=1:1.00
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

ID                                       : 2
Format                                   : AC-3
Format/Info                              : Audio Coding 3
Codec ID                                 : A_AC3
Duration                                 : 1 h 36 min
Bit rate mode                            : Constant
Bit rate                                 : 384 kb/s
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 31.250 FPS (1536 SPF)
Bit depth                                : 16 bits
Compression mode                         : Lossy
Stream size                              : 265 MiB (6%)
Language                                 : English
Service kind                             : Complete Main
Default                                  : Yes
Forced                                   : No

You should post logs after making these changes.

here I have two attempts:

the first one is with:

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start
System>Display>Force 4:2:2 colour subsampling> Disabled

the second one is with:

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/Stop
System>Display>Force 4:2:2 colour subsampling> Enabled

It seems this issue is happening only with mkv h264 videos with 59.940 (60000/1001) FPS.
But that’s just what I noticed so far.

I just noticed that the issue doesn’t happen if I play a file with a similar mediaInfo, except for the fact that this file (the one playing fine) is missing the following items:

  • Writing library
  • Nominal bit rate
  • Encoding settings

It’s like if Kodi is having complications on handling files having those informations.
Is there anything wrong on those three items in the MediaInfo I posted days ago?

@sam_nazarko sorry to bother you again.
If actually there is not a solution for this then I’m going to reinstall Kodi 18 (now I’m on Kodi 19).
There’s something I can check on to fix it or should I just reinstall Kodi 18? (Hoping Kodi 18 doesn’t give me this problem)

In case, will the following steps posted by gmc do the downgrade?

@sam_nazarko I rollbacked to Kodi 18, but still can’t play flawlessly that file.
The only difference now is that I don’t get any black screen but I get a freeze frame for several seconds.
I start to believe it’s all because of 60 fps.

Sounds like the file is the problem.
If you can share the file legally I’d be willing to test it out.

@Kontrarian @sam_nazarko here’s the sample:
Around 1:40 if you skip forward 10 seconds you should see the issue (on Kodi 19 was a black screen and on Kodi 18 is a freezed image).

@Kontrarian @sam_nazarko
Hello guys, any news? Have you been able to check on my sample?

I haven’t had a chance to look at this yet.

I’m currently on holiday, so my access to test equipment is somewhat limited at the moment


I can confirm a black screen on Kodi 19. Skipping fw is no problem, but around 1:40 it is. After a few seconds video gets back.

1 Like

no problem. Enjoy your holiday :slight_smile:

Sorry, but when I go to the link provided it requires a paid subscription to download.
Can you provide a new link?

hi! I just updated the post with a new link

It’s your file.
It gets all messed up when I skip forward or back even on my PC using MPC.

What ever program that encoded it did a shady job with the key frames is my guess.
I recoded it and now it skips forward and back just fine.

I downloaded and played it on the 4K+. Can skip 10 secs early on but after 1.40, skip produces a black screen. I agree, it is a crap encode.