Vero 4k + Blank Screen & Doesn't Boot


I was unable to get a picture through my AV amp (Marantz SR7011), so connected directly to my TV (LG OLED55B7V), finally got a stable picture, applied the latest updates, shutdown and tried connecting through the amp again.

Just got a blank screen, retried a direct connection, but same result.

Tried different TV’s and my 4k Samsung monitor, all lock on to a signal, but it is just a blank screen,

It doesn’t boot fully by the looks of things so is not available on the network.

I have tried using power via the USB socket, the optical output lights up and there is activity on the ethernet port, so power looks OK, but get nothing other than the blank screen.

I’ve also tried creating recovery media and forcing it to boot from those, but no luck, just the same result.

Any suggestions?

Kind regards,

The first thing to try would be a different HDMI cable. Cables do fail sometimes.


Thanks for the suggestion, I’ve tried 4 different cables of different brands and lengths (1m to 12m, from Belkin & monoprice), and made sure they work with other components too, same result.


Have you rebooted with the Vero directly connected to the TV? Can you SSH into the Vero after rebooting, or ping it (that will tell us if it’s actually booting and just not sending a signal via the HDMI).


Yes, rebooted directly connected to 2 different TV’s and a monitor, all receive a signal as they “lock-on” (the monitor in particular is really fussy about this normally). There is activity on the ethernet (lights on the switch blink), but it does not appear on the network - unable to ping /ssh, I assigned a static address to try to make sure I was testing the right IP.

Ignoring for a moment that there shouldn’t be a connection between the network coming up and a display being detected, if you configure your Vero as follows does it then display correctly on boot and then only have an issue going through your AVR with 4k 25fps and/or 60fps content?

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Unfortunately I cannot get access to the box in any way to configure it, no ssh access and no ui.

How did you configure a static IP? On your router or on the Vero?

Your first post said that you got it working connected directly to your TV but not through your AVR. Can’t you plug it back into the TV and change your settings, then move it to the AVR?

Do you still have the SD card or USB stick connected to the Vero? Try booting without the recovery medium.

When the Vero starts, do you at least see the initial splash screen?

I tried as soon as the connection through the amp failed - retried a direct connection [to the tv] - same result, no picture and no way of accessing the settings. I was hoping there was some way of doing a reset of the video settings like on the Apple TV, but the closest I could find was the re-installation process which isn’t working either.

I suspect it is bricked, just wanted to make sure I tried everything.

Thanks for your responses.

I’ve tried with SD card and USB media and without either, same problem, no splash screen or anything just a blank screen, but definitely a signal of some sort.

Suspect the HDMI output chip has failed in some way, sounds similar to issues on the PS4, there is no physical damage to the port, not sure if that would prevent it from booting fully though.

The static IP was configured on the router, I’ve checked the logs and can’t see any connections / DHCP requests with the Vero’s MAC address.

Have your turned off the static IP and just let the Vero use DHCP?

Nope, I’ll give that a go now thanks…

Looks like I had already tried that …and forgotten… static IP has been deconfigured and vero restarted, the switch shows the port as active at 1G, but mac address not registered with the router.

Thanks for the suggestion though.

Is the switch between the Vero and the router managed? You might try restating the switch, or if you can bypass it.

Other than that, I’m out of ideas.

If you have no network and no HDMI, something’s not quite right.

What’s the last thing you were doing with the device when it was working?

Got a USB A-A cable handy?


@michaelbell0 What Vero model are we talking about? Vero 4k, Vero4k+ or an old Vero 2?

Add.: Already was pointed to the missing info.

I’d had it working directly connected to my TV, updated it to the latest available software (June I think, it was January’s previously) and rebooted a couple of times to make sure it was stable.

Shutdown the Vero cleanly and powered everything off so I could re-try connecting via the amp. Reconnected and powered everything up and got a blank screen. Assumed I was back to the previous situation, so retried connection directly to the TV, but got no picture this way either. I thought it might have somehow switched to a resolution not supported / recognised by the TV, so looked at how to reset & tried the micro SD and USB recovery options with no luck.

Thought it might be power supply so already tried the USB A power option, power seems ok though as getting ethernet activity lights on switch. No red LED at all on power-on.

My Samsung 4k monitor can be a pain locking on to a signal and that finds something and locks on fine which I find odd, but no image at any point.

I had disabled wifi unfortunately before trying via amp just to be sure any streaming issues weren’t due to it using the wifi rather than ethernet.

Just a bit stuck with no image and no connectivity.