Vero 4K + crashes more and more and doesn’t boot for some time

Toothpick method shouldn’t be necessary - it’s usually a last resort.

Can you show a screenshot of the contents of the SD/USB?


Here it is:

SUggest to try USB-A - A Cable

Someone is bringing me one. :slight_smile:

Should I plug it in with a phone charger (I have a 5V-2A)? or from a computer?

While Phone Chargers are not preferred as they don’t output stable voltage it should be good enough for testing.

OK. Thank you.

I’ve plugged it with a USB A-A cable (with a 5V 2A phone charger). No light, no boot up. Only difference, in the back: I see the red light in the optical audio output (which did not light up with the power supplies).

That’s not too bad, did you now try reinstall from USB or SD Card?

The screen stays black (no signal).

My USB stick has a light that flashes when in use, but it only flash once when I plug the Vero (with the USB stick already plugged in). It doesn’t seems to even try to do anything with it.

Did you tried the toothpick method?

I’ve tried this afternoon, nothing. Nothing on the screen (no signal) and no activity on the USB stick (I’ve tried alors with a microSD card).

(I cannot find anymore the toothpick method on the wiki, I’ve followed these instructions (found on the forum):

  • Before removing the SD card, rename the file ‘kernel.img’ to ‘recovery.img’
  • Find a non-conductive pin, such as a toothpick. Put it in the round port nearest the HDMI port. You should hear a soft, audible click
  • Keep this button held down while you or someone else connects power to the device. Keep the button held down for at least 30 seconds or until you see the installer screen come up)

Writing the first post two days ago, I thought that my Vero will eventually boot like the 2-3 other time, but it seems that this time it’s more serious.

Thank you for your replies and your patience.

Can you try that USB-A cable from a laptop or PC instead of phone charger?


It does not work either (I’ve tried several ports from my laptop, USB stick/microSD card).

I’ve tried again today (USB A-A, power supply) and still nothing at all. I think it’s dead.

Don’t hesitate to tell me if there is anything else I can try. :slight_smile:

I’m thinking about buying a new one. I bought it in october 2019, I’m not sure if there’s any warranty left?

You can raise a support ticket with order # and we can check this in detail.

1 Like

I’m having this same issue.
I’ve had a Vero 4k for a few years and bought a 4k+ a few months ago.
It crashed a couple of times but since the August update it is crashing often with the same full colour screen as mentioned by the OP.
Tonight I was watching Dawn of the Dead and it crashed 4 times during the movie. This particular movie is only Standard Definition SD480p 5.1 Dolly if that matters.
I’ve still got my Veto 4k so I’ll go back to it and open a ticket for the 4K+.
But would like to know how to troubleshoot.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for getting back to me. To replicate the crash I played the same movie as before with the debugging enabled. After the crash I had to pull the power cable and reconnect to reboot.
The log files are here:

The movie playing for the debug logs was SD 480p. Tonight we successfully played a couple for HD movies, then played an SD 480p movie (different to the other one) and it crashed again. I did not have debugging running for this one but will play again and see what happens.
Note, I have downloaded the August image for Vero 4k so can do a factory re-install if required but would rather get to the bottom of the issue. I also have an older Vero 4k which I can play the same movies with to compare after I upgrade that one to the new version as well. Is there anything else I can do to help troubleshoot this?

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Hi ActionA

These settings seem to have resolved my issue. Thanks for that.
I’m wondering why they are not set like this as default? Anyway all seems good now.

1 Like