Vero 4k does not output HDMI signal

Hi guys,

My Vero 4k has been working for several years now (except when power supply failed)
I use it mainly as a Media Center but I also have NordVPN installed on it, but speeds are well below the ones I get when running NordVPN in my computer. The main reason is that Vero 4K/unix version doesn’t support NordLynx which is responsible to improve the VPN speed.
I was advised by NordVPN to update the unix system but while doing this I was having errors with some repositories and long story short I ended up running the following command

sudo apt-get update --allow-releaseinfo-change

which worked fine until the reboot… after that, the vero 4K doesn’t start anymore (or at least it doesn’t output any HDMI signal). I tried with different HDMI cables in the usual LG Tv and also in my Dell monitor.
I created a SD card to reinstall the system, but I still don’t get any HDMI output if it is doing anything. I even tried the toothpick to click on reset button while booting the box with and without SD card… nothing seems to work… The LED is blue while on power so it should not be a problem with power supply…
So, I’m not sure what to do next. Any ideas?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Are you able to ping the box or access it via SSH?

@sam_nazarko no.
do you know what is the right procedure to reinstall the system? I used osmc-installer in Windows and followed the steps in that app to prepare the SD card with the latest version of the system. Then I put the SD card in the reader and plug the power supply on but nothing comes up in the monitor. Is that the expected behavior? Am I doing the wrong steps?
Thanks for your time.

You should see an installer screen come up if the device is functional.

Can you check your router possibly to see if the device is connecting to the network?

It’s kind of odd. The network cable is connected to PORT 2 and it shows as “green” and “Connected”

But in list of devices, it’s off and even the MAC doesn’t match the on the sticker in Vero4K (maybe it was a device I used in that port a long time ago. But there is nothing else in the list connected to PORT 2

However, looking into the statistics it is possible to see some “activity” for PORT 2, only in the “Transmitted” side

When I turn off the Vero 4K the statistics stop and PORT 2 is not connected anymore.

Do you have a USB-A cable?


Plug it in the white port and see if the system is detected as a USB devicie.

When I connected the cable there was a popup saying “setting up your device” but nothing came up in windows explorer.

Well, this is interesting… I used osmc-installer again, but this time choosing the oldest version in the list and after 3 minutes, I was able to get HDMI signal and the “Welcome” wizard to choose language and so on, and now it is working. I guess there must be something wrong with latest image…
But thanks for you time anyway.

The latest image is fine.

We would have had reports of this otherwise.

I’m glad to hear things are working well.


Hi @sam_nazarko

I got to same behavior back. As I said before, I used the 2018.07-1 to reinstall and it was ok, but when I tried to do an update from the OSMC menu, after the installation of the update the HDMI signal was gone again (I’m guessing it updated to version 2021.08-1)
I’m trying to install 2020.11-1 now from SD card.

2018.07 is a very old version.

Try 2020.11 and let me know how it goes.


Hi @sam_nazarko

2018.07 actually worked, i.e. I was able to recover Vero 4K using SD card. But after triggering the updates in OSMC, I ended up with same problem.
Then I tried 2020.11-1 and I was able to recover Vero 4K using SD card again, but after triggering the updates, it ended up in same situation without HDMI signal. Here are print screens on what I did:

and after this step nothing:

I did this for the sake of document this failure. If Vero 4K doesn’t support this update, I believe it should not show up as an update.

Lucky as I am, I can’t restore the system again using SD Card. I’m not really sure what I did to make it work before, but following exact same steps doesn’t do it anymore :worried: maybe it will work tomorrow :face_with_raised_eyebrow:

If you enable SSH Server while you have 2020.11-1 running and then you do the upgrade it would be interesting if you still can access via SSH afterwards which would allow you to upload logs and trouble shoot the issue.

Hi @fzinken

Initially, I had my Vero 4K fully working (including access to SSH) and then I tried to upgrade to latest version. After the upgrade was done, on first reboot I didn’t get any HDMI signal and SSH was not available.

Because there was no other way, I basically did a full reinstall with 2020.11-1 image. As part of initial setup of that version (language, network, etc), I activated SSH and I was able to connect again.

Without doing any other changes to the system after reinstall was done, I just tried to update to the newer version and it looks like it got to 100% (as per the print screens) but after what I suspect was the first reboot, the HDMI signal is gone and SSH is not working anymore.

I found other people in the Support site with issues, but those are happening after they actually get access to the newer version and they can upload logs. In my case, I don’t have access to anything.

Not sure what I can do to diagnose the problem. Should I try update using apt-get commands again? If yes, should I provide some extra flag to get more output of the upgrade process to see if any step failed with failing the full upgrade?

Could indicate a power supply issue that only come to the surface with the new image using more power (even so that sounds quite strange). Maybe try a new power supply.

@fzinken and @sam_nazarko

After a bit more try and error I manage to make it work, but there is something fishy going on… let me try to explain my findings…

As I said before, after updating to latest version I could not get a HDMI signal… also, trying to reinstall from SD card was not that straightforward and was not working ever time, when I was trying to recover Vero 4k with different versions.

Turns out, that everything “works” when HDMI cable is not connected.

Reinstalling from SD card works fine as long you put the SD card, turn on Vero 4K without HDMI cable and leave it running for a while… Then connect HDMI cable and then I can get a signal. On version 2020.11-1 the image is ok.

While trying to update from that version to version 2021.08-1, one can still do the update and see the screens I post before. However, after the update is “done” and not having the HDMI signal, I had to disconnect HDMI cable and restart Vero 4K without it. After a while, I connected the HDMI cable and I got HDMI signal, but a weird one… here are a few photos:

While in this ghost menu, I manage to go the option to restart (last one in main menu and then first one) and after restart, and without remove HDMI cable this time, the menu was ok.

And then it was ok, even with 1080p. Then I connected to my 4K tv and had to do this trick again (use the ghost menu to restart Vero 4K) but it looks like it working, at least for now.

I was reading about this update here OSMC’s August update is here with Kodi v19 - OSMC and it looks like the changes around video stack may be causing this stuff.

so there is problem… after using the box for a while, I restarted it again it ended up on same “No HDMI signal” and SSH was not available (the box shows blue led).
I had to remove HDMI cable, restart it (still no SSH), connect HDMI back after 20 seconds, use the “ghost” menu again to restart the box and then it was back, including SSH.