Vero 4K+ freezes randomly


I just got my Vero 4K+ last week, but unfortunatly it has not been running as good as I had expected and read from other users. The problem is basically that the Vero freezes randomly, and has to be rebooted. Below is some things I have noted about my problem/setup:

  • The device is never warm to the touch when it freezes.
  • I am still able to SSH into the device and either reboot it or restart kodi by use of

sudo systemctl stop/start mediacenter

  • I have no external devices attached, besides the accompanying RF remote control (love that btw).
  • My media sources are mounted through fstab and all work fine (as in I can browse and play media through them).
  • The Vero is connected directly to the TV.

I should note, that about a day or two into having received and set up the device, I ran into a problem where it would freeze when I cleaned the library. I suspected (because of this: Clean Library hangs - looking for removed network share?) that this was related to an fstab entry that I was no longer using (one of my first tries), but that Kodi somehow still had library entries to this mount point. I therefore deleted the “.kodi” folder, to completely reset the kodi setup and try again.

Today I managed to reproduce at least one problem that got it freezing. I navigated to an entry in the library, tried to play it, and then Kodi froze. I could restart it with systemctl, and get it to freeze the same way again. The debug logs uploaded from MyOSMC are located here:

I have previously been running OSMC on a Rpi3 and besides the use of fstab and a concurrent upgrade to a 4K tv (which spawned my Vero purchase), nothing has been changed to the setup or my configuration of the device.

I tried to reinstall the device from scratch, just to elliminate any wrongdoings I might have caused by messing with fstab and removing the .kodi folder. However, the installer didn’t have an entry for a Vero 4K+, and the 4K option didn’t show the OSMC version my device had preinstalled. So I opted not to risk it.

Is there anything I can try to do to get this working as flawlessly all the time, as it does between freezes? Beside these intermittent freezes, it is a wonderful little device, running fast and responsive, and I’m happy I got it :slight_smile:

Thanks in advance for any help - it is much appreciated! :slight_smile:


1 Like

When you experience a freeze, does the device completely lock up, or is it just Kodi?

Edit: I see you can login via SSH. That indicates the device isn’t crashing itself, which is good.

You can reinstall using the Vero 4K image (the image works for Vero 4K and Vero 4K +)


Hi Sam

Thanks for your quick reply. I will try a reinstall later tonight. Just to be sure:

The most recent Vero 4K image I can get from the installer is 2018.07-1, and that will be compatible/installable on my 4K+, even though that is running version 2018.08-2? :slight_smile:

Yes – that should be fine.

Reinstallation went fine - updated to the August update and now showing the same OSMC version as before :slight_smile:

However… I just had another freeze, trying to play a tv episode (same as in the debug logs above).

I’m more inclined to believe that is has something do to with my kodi configuration/fstab than the Vero itself, since it does not completely freeze, but only locks kodi. Any suggestions as to what I can try? :slight_smile:

What skin are you running? Can you try with either OSMC or Estuary and see if the issue still occurs?

I’m currently using Grid and have been for a while. Will try to use one of the above for a few days, to see if the problem persists. Thanks :slight_smile:

If your connection drops slightly, Kodi can freeze and won’t recover gracefully.

If you can still login via SSH then the device itself isn’t crashing.

Can you show us the fstab mount?

There has until now not been a freeze, during which I could not use SSH to reboot the device. So the device has never crashed on me :slight_smile:

Sure thing:

# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0
// /mnt/server-movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=osmc,password=osmc,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=2.0 0 0

All the previous crashes have been with the above fstab, except that the mounts were configured with SMBv3 instead of v2 (vers=3.0). This morning I tried changing it to v2 instead, to see if it made any difference. It has not crashed since, but that could just as well be a coincidence.

My media is stored on a Windows 10 PC, on which I have added a dedicated user called “osmc” to access the shares, as a result of the SMB issue some time ago. I have been using this guide as a reference when setting up fstab: Configuring fstab based Samba share mounts :slight_smile:

Using autofs may be a better solution if the connections are susceptible to drops


Thanks. I’ll look into that tomorrow :slight_smile: The only reason I went with fstab instead of the normal SMB through kodi, was because I have read multiple times, that fstab should perform better.


autofs has the same improved performance as fstab over the kodi smb shares and as same Sam has pointed out it recovers better after network drop outs, details can be found here:

Thanks Tom.

Thank you for your reply Tom. I have gotten the autofs to work according to the how-to, but had to specify a SMB version in the mount options, before it would mount properly. For now, I have chosen version 2.0, as I got an input/output error when using v3.0.

I’ll report back when anything new happens, or if the problem appears to be gone :slight_smile:

1 Like

So it’s been a week, and so far I have not had a single freeze or lockup of any kind! The autofs setup works like a charm and performance have been stellar all the way through. It appears my issue was rooted in a combination of my network setup, the Windows 10 configuration and using fstab :slight_smile:

The Vero 4K+ is a remarkably wonderful device, and I have nothing but nice things to say about it. It is truly a great upgrade over my old Raspberry Pi 3, both in capability and speed!

Thanks to all who chimed in, for taking the time to help :slight_smile: