Vero 4K H265 movies (8-bit encoded only?) - blacks show as grey, colours washed out (reduced colourspace)

That’s disappointing - thanks for looking at the logs.

Is there a way to backup the entire system (the internal storage card) - on a Pi it’s simple to backup the sd card and restore it; I’d like to be able to restore the system as it is after testing a clean install - there’s been quite a lot of effort in setting the system up so far.

I have used the in-built backup facility (Backing up Settings - General - OSMC), however this isn’t really equivalent of using dd or win32diskimager to copy the entire storage bit-for-bit. I’m not sure exactly what the backup/restore facility actually covers - I assume, for example, that installations of components such as veracrypt would be lost.


I forgot to mention, yes, the system has been rebooted between each change I’ve made whilst investigating the problem.

Is there a way to perform a clean install using the March release (or whichever predates the latest April release) - e.g. to the version which was installed when I received the machine last month?

[edit] - I’ve obtained the OSMC installer for linux, and selected what I think is the correct image Vero 4k OSMC to reinstall (2018-03-2), and have imaged this to a spare micro SD (64gb - overkill, but it’s the only one I have that’s not required on another device at present).

Before I proceed, I’m hoping there’s some way to image the entire internal storage on the Vero 4k, so I can avoid having to re-do a lot of work on the device if the problem with the colour space persists (however, if this is the case, I guess there’s the chance that I have a faulty Vero 4k anyway)

You can backup via My OSMC -> Backup. @grahamh also has a tool to do a dd like backup, but I’d suggest avoiding doing so to see if the issue does indeed persist with a fresh installation.

Many thanks


1 Like

Use the 2018.04-1 image as it’s the latest.

1 Like

I was thinking of a DD style backup, then a fresh install and testing. The DD backup would then be used to restore the system if reverting to a clean install doesn’t fix the problem.

I was thinking of going back to the version which was installed when I received the device last month, in case the latest update has some issue which resulted in the problem I’m experiencing. Do you not this this is a good approach?

Regarding the images which the installer retrieves, I’ve noticed that these are left in the Home directory on Mint Linux, and that the filenames include Vero3k, rather than vero4k.

For instance, the last two builds are:

Check this out, while be reminded that restore in the Vero4k is not trivial.

Vero4k (marketing name) is the 3rd iteration of the Vero therefore image names are Vero3

1 Like

Hi fzinken,

Thanks for the information.

I’m keen to see if a fresh install fixes the issue, as I’m concerned that the device may be faulty (and these issues always play on my mind - goes with the territory being a programmer…)

…however it’s nearly 3am here and I’m getting too tired to make decisions which could potentially cost me a lot of time in terms of setting the system up with various customisations after a clean install (assuming the problem remains - if it’s fixed, then I’ll need to add each customisation until the problem returns, assuming it does!)

Thanks for your ongoing assistance

Are Startrek and Brazil 1985 the movies that display blacks as gray? They are encoded in full range (log shows yuvj420p (pc, bt709). I don’t think full range BT.709 is properly decoded by any Amlogic SoC.

Hi wesk05,

Thanks for replying.

That’s correct, both these movies are displaying greys instead of black.

Is there anything in mediainfo output which can be used to distinguish yuvj420p encoding? Is this format distinct from that reported by mediainfo for these 8-bit files?

As noted in an earlier post, the affected files all report a “YUV” colorspace, “4:2:0 (Type 1 / Type 0)” chroma subsampling, and “BT.709” for each of color primaries, transfer characteristics, and matrix coefficients entries.

As the Pi 3 (overclocked to 1300mhz) is able to playback these films correctly, can the Vero 4k be made to handle these with software decoding, given its stronger processor? I tried switching off hardware acceleration, but saw no difference.

If the vero 4k’s hardware cannot handle 8bit hevc I must admit that I’ll be rather disappointed, as the device was purchased specifically to playback h265. My research and emails prior to purchase didn’t reveal any issues.

I’ll hold off resetting the unit for now, and eagerly await further insights, if anybody has information regarding yuvj420p encoding.

Thanks for your help

Got a sample?


Look for color range in the mediainfo output. It would say Full for (yuvj420p) and Limited for (yuv420p). Full range is actually an incorrect encoding setting.

Pi3 default output is RGB. You could try setting Vero 4K output also to RGB. I believe the output is limited range. So, it may not help. Give it a try.

A sample here would be good:


I don’t have samples for those movies. I can provide a test pattern in limited and full range. The pattern will actually help see the difference.

Limited Range - MEGA

Full Range - MEGA

1 Like


Would you like me to test these files?


I can provide you the full mediainfo data on the files if it’ll assist.

Thanks again for helping out, I really appreciate it.

I’m somewhat apprehensive about providing a sample. Could i cut a brief segment out using handbrake - would that be legal?


Thanks. If you’re referring to the forced rgb option that is designed for 2009 Philips tv’s, that’s the option that causes my vero4k to output everything in garish greens and oranges, including the osmc menus.

Happy to provide screen grabs if it will assist.

Btw the affected files all work fine on my pc in both win7 and mint linux under VLC and other media players (nvidia GTX 570 gpu)

Yes – it’s for research purposes, and only OSMC will have access to the files, so you won’t be facilitating piracy.

1 Like


I downloaded the Black & White steps (full, normal) test files and tried both on my PC and on the Vero 4k. The results were the same on both machines:

Black & White steps.mp4

  • here the black level is correct throughout - black appears as black, not grey:
  1. VLC snapshots -Black & White Steps - initial text screen - correct black level.png
  2. VLC snapshots -Black & White Steps - grid - black and white cells only- correct black level.png
  3. VLC snapshots -Black & White Steps - grid - shades- correct black level.png

Black & White steps_Full.p4

  • here the initial text screen shows as grey rather than black, but once the test pattern is displayed black appears correctly.
    VLC snapshots -Black & White Steps_Full - initial text screen - incorrect black level - grey.png
    VLC snapshots -Black & White Steps_Full - grid - black and white cells only- correct black level.png
    VLC snapshots -Black & White Steps_Full - grid - shades- correct black level.png

The ‘full version’ shows shades of grey covering most of the boxes in both the black and the white sections of the screen; the other version on shows shades of grey only in boxes 230 - 235, as far as I can make out (without checking with Gimp)

I’ve attached 6 screen shots in case they’re of any use.

These screen grabs are from VLC on Mint Linux, however the files appear identically when played via the Vero 4K on the same monitor.

I’m considering using handbrake to grab a brief section of a couple of the movies I’m having problems with, but not sure of the legality of this.

Thanks, as always, for assisting

Thanks Sam,

I’ll grab out a couple of sections.
Any preference as to where they can be uploaded to? I could create a throwaway mega account, for instance.